summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-04-01 04:20:35 +0200
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-04-01 13:03:59 +0000
commit8be499bf586f99f17e31d75c7f8ddfe0cbde18cc (patch)
tree55f1c2c669ac02aebb0479024c9e44249eea76de
parent90ee7645cc41c5fe89097dc700120ef57668fba2 (diff)
downloadtde-packaging-gentoo-8be499bf586f99f17e31d75c7f8ddfe0cbde18cc.tar.gz
tde-packaging-gentoo-8be499bf586f99f17e31d75c7f8ddfe0cbde18cc.zip
Live ebuilds: Add preliminary `KShowMail` ebuild.
Signed-off-by: Chris <xchrisx@uber.space>
-rw-r--r--trinity-apps/kshowmail/kshowmail-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/trinity-apps/kshowmail/kshowmail-9999.ebuild b/trinity-apps/kshowmail/kshowmail-9999.ebuild
new file mode 100644
index 00000000..cff4ba5d
--- /dev/null
+++ b/trinity-apps/kshowmail/kshowmail-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_TYPE="applications"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="cs de es fr hu it ru sv"
+
+inherit trinity-base-2
+
+DESCRIPTION="Show mails on a POP3 server "
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+need-trinity
+
+SLOT="${TRINITY_VER}"
+
+DEPEND+=" =trinity-base/mimelib-${PV}"
+RDEPEND+=" ${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}