summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-05-02 23:54:12 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-11-10 20:25:35 +0100
commitd68f1e223da71c1b3d013713f24d78cedaef3e95 (patch)
treea69daab6304143f2e5ef166dcca226691fbad7f2
parenta9836ea75e7cdeb6b7847efdc4d4dc50b49335d0 (diff)
downloadtde-packaging-gentoo-d68f1e223da71c1b3d013713f24d78cedaef3e95.tar.gz
tde-packaging-gentoo-d68f1e223da71c1b3d013713f24d78cedaef3e95.zip
Live ebuilds: Add `KScope` ebuild.
Signed-off-by: Chris <xchrisx@uber.space>
-rw-r--r--trinity-apps/kscope/kscope-9999.ebuild36
-rw-r--r--trinity-apps/kscope/metadata.xml7
2 files changed, 43 insertions, 0 deletions
diff --git a/trinity-apps/kscope/kscope-9999.ebuild b/trinity-apps/kscope/kscope-9999.ebuild
new file mode 100644
index 00000000..9a9c38fc
--- /dev/null
+++ b/trinity-apps/kscope/kscope-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_TYPE="applications"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de zh_CN"
+
+inherit trinity-base-2
+
+DESCRIPTION="A TDE front-end to Cscope"
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+RDEPEND="=trinity-base/kate-${PV}
+ media-gfx/graphviz
+ dev-util/ctags
+ dev-util/cscope"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison"
+
+need-trinity
+
+SLOT="${TRINITY_VER}"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}
diff --git a/trinity-apps/kscope/metadata.xml b/trinity-apps/kscope/metadata.xml
new file mode 100644
index 00000000..61b4108b
--- /dev/null
+++ b/trinity-apps/kscope/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Chris</name>
+ </maintainer>
+</pkgmetadata>