summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-04-30 16:26:06 +0200
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-05-02 12:42:28 +0000
commitffde2042a0595a8bd6e421c94ed74284eba05c82 (patch)
tree5f1791448e4b4d87673747324e5e34b7fc4e97bf
parentd877f9249e915ae9b13282628e8670a8cb684a96 (diff)
downloadtde-packaging-gentoo-ffde2042a0595a8bd6e421c94ed74284eba05c82.tar.gz
tde-packaging-gentoo-ffde2042a0595a8bd6e421c94ed74284eba05c82.zip
Live ebuilds: Add `Akode` ebuild + Akode support for `Amarok`.
Signed-off-by: Chris <xchrisx@uber.space>
-rw-r--r--media-libs/akode/akode-9999.ebuild48
-rw-r--r--media-libs/akode/metadata.xml7
-rw-r--r--trinity-apps/amarok/amarok-9999.ebuild23
3 files changed, 67 insertions, 11 deletions
diff --git a/media-libs/akode/akode-9999.ebuild b/media-libs/akode/akode-9999.ebuild
new file mode 100644
index 00000000..91df157f
--- /dev/null
+++ b/media-libs/akode/akode-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_TYPE="dependencies"
+TRINITY_MODULE_NAME="akode"
+
+inherit trinity-base-2
+
+DESCRIPTION="A simple framework to decode the most common audio formats."
+HOMEPAGE="http://www.trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+
+IUSE="alsa pulseaudio oss jack +libsamplerate mpc mp3 sndfile vorbis flac speex"
+
+DEPEND="alsa? ( media-libs/alsa-lib )
+ jack? ( virtual/jack )
+ pulseaudio? ( media-sound/pulseaudio )
+ libsamplerate? ( media-libs/libsamplerate )
+ mp3? ( media-libs/libmad )
+ speex? ( media-libs/speex )
+ flac? ( media-libs/flac )
+ mpc? ( dev-libs/mpc )
+ vorbis? ( media-libs/libvorbis )
+ sndfile? ( media-libs/libsndfile )"
+RDEPEND="${DEPEND}"
+
+# The FFMPEG plugin needs some porting,
+# to work with recent FFMPEG. So it is disabled for now.
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_FFMPEG_DECODER=OFF
+ -DWITH_SUN_SINK=OFF
+ -DWITH_LIBLTDL=OFF
+ -DWITH_ALSA_SINK=$(usex alsa)
+ -DWITH_OSS_SINK=$(usex oss)
+ -DWITH_PULSE_SINK=$(usex pulseaudio)
+ -DWITH_JACK_SINK=$(usex jack)
+ -DWITH_MPEG_DECODER=$(usex mp3)
+ -DWITH_XIPH_DECODER=$(usex vorbis)
+ -DWITH_MPC_DECODER=$(usex mpc)
+ -DWITH_SRC_RESAMPLER=$(usex libsamplerate)
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/media-libs/akode/metadata.xml b/media-libs/akode/metadata.xml
new file mode 100644
index 00000000..61b4108b
--- /dev/null
+++ b/media-libs/akode/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Chris</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/trinity-apps/amarok/amarok-9999.ebuild b/trinity-apps/amarok/amarok-9999.ebuild
index b08f9f75..f0eebbc5 100644
--- a/trinity-apps/amarok/amarok-9999.ebuild
+++ b/trinity-apps/amarok/amarok-9999.ebuild
@@ -7,10 +7,10 @@ TRINITY_MODULE_TYPE="applications"
TRINITY_EXTRAGEAR_PACKAGING="yes"
TRINITY_HANDBOOK="optional"
-TRINITY_LANGS="af ar az be bg bn br ca cs cy da de el en_GB eo es et eu fa fi
-fr ga gl he hi hu id is it ja ka km ko ku lo lt mk ms nb nds ne nl nn pa
-pl pt pt_BR ro ru rw se sk sl sq sr sr@Latn ss sv ta tg th tr uk uz uz@cyrillic
-zh_CN zh_TW"
+TRINITY_LANGS="af ar az be bg bn br ca cs cy da de el en_GB eo es
+ et eu fa fi fr ga gl he hi hu id is it ja ka km ko ku lo lt mk
+ ms nb nds ne nl nn pa pl pt pt_BR ro ru rw se sk sl sq sr sr@Latn
+ ss sv ta tg th tr uk uz uz@cyrillic zh_CN zh_TW"
TRINITY_DOC_LANGS="da de es et fr it nl pl pt pt_BR ru sv"
@@ -26,9 +26,9 @@ SLOT="${TRINITY_VER}"
# Notes about the ebuild:
#
-# - This version supports three engines: Xine, Yauap, and Akode. The only one in
-# the portage tree at the moment is Xine. Akode is still maintained by Trinity,
-# so it's a possibility, but Yauap isn't in portage tree, but could be added later.
+# - This version supports three engines: Xine, Yauap, and Akode.
+# The only ones supported at the moment are Xine and Akode.
+# Yauap isn't in Portage tree, but could be added later.
#
# - Rio Karma support needs libkarma which neeeds to be added to our overlay later.
#
@@ -39,15 +39,16 @@ SLOT="${TRINITY_VER}"
# - Otherwise the ebuild should offer all what can be done with CMake at the moment.
IUSE+=" konqsidebar +xine ipod riokarma ifp njb mtp mp4
- inotify visualization amazon mysql postgres opengl"
+ inotify visualization amazon mysql postgres opengl akode"
-REQUIRED_USE="xine"
+REQUIRED_USE="|| ( xine akode )"
DEPEND+="
dev-lang/ruby:*
media-libs/taglib
- <media-libs/xine-lib-1.2.10
dev-db/sqlite
+ xine? ( <media-libs/xine-lib-1.2.10 )
+ akode? ( =media-libs/akode-${PV} )
mp4? ( media-libs/libmp4v2 )
ipod? ( media-libs/libgpod )
riokarma? ( media-libs/libkarma )
@@ -69,6 +70,7 @@ src_configure() {
-DWITH_AMAZON="$(usex amazon)"
-DWITH_KONQSIDEBAR="$(usex konqsidebar)"
-DWITH_XINE="$(usex xine)"
+ -DWITH_AKODE="$(usex akode)"
-DWITH_IPOD="$(usex ipod)"
-DWITH_RIOKARMA="$(usex riokarma)"
-DWITH_IFP="$(usex ifp)"
@@ -82,7 +84,6 @@ src_configure() {
-DWITH_POSTGRESQL="$(usex postgres)"
-DWITH_SYSTEM_SQLITE=ON
-DWITH_YAUAP=OFF
- -DWITH_AKODE=OFF
-DWITH_DAAP=OFF
)