summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..261c0fb
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,30 @@
+SUBDIRS = \
+ build \
+ tdegtk \
+ tests
+
+ACLOCAL_AMFLAGS = -I build
+
+EXTRA_DIST = autogen.sh COPYING
+
+DISTCHECK_CONFIGURE_FLAGS = --disable-scrollkeeper
+
+MAINTAINERCLEANFILES = \
+ build/compile \
+ build/config.guess \
+ build/config.sub \
+ build/depcomp \
+ build/install-sh \
+ build/ltmain.sh \
+ build/missing \
+ Makefile.in \
+ config.h.in \
+ configure \
+ aclocal.m4
+
+release: dist
+ make $(PACKAGE)-$(VERSION).tar.gz.md5
+ make $(PACKAGE)-$(VERSION).tar.bz2.md5
+
+%.md5: %
+ md5sum $< > $@