summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-12-24 15:08:52 +0100
committerSlávek Banko <slavek.banko@axis.cz>2018-12-24 15:26:41 +0100
commit1fbbb6bb7a00e36d4e847a087f01b50c0c728125 (patch)
treee6de76b172f69b80bf16e223eec765365b0c25eb /CMakeLists.txt
parent83df9ef9555ea810992c6b65169da4d504da5681 (diff)
downloadgwenview-i18n-1fbbb6bb7a00e36d4e847a087f01b50c0c728125.tar.gz
gwenview-i18n-1fbbb6bb7a00e36d4e847a087f01b50c0c728125.zip
Conversion to the CMake building system.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 3b5c4c74473e99bee211d454d857fe325b4c55aa)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt65
1 files changed, 65 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..f71b1f9
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,65 @@
+#################################################
+#
+# (C) 2018 Slávek Banko
+# slavek.banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+cmake_minimum_required( VERSION 2.8 )
+
+
+##### general package setup #####################
+
+project( gwenview-i18n )
+set( VERSION R14.1.0 )
+
+
+##### include essential cmake modules ###########
+
+include( FindPkgConfig )
+
+
+##### include our cmake modules #################
+
+set( CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules" )
+include( TDEMacros )
+
+
+##### setup install paths #######################
+
+include( TDESetupPaths )
+tde_setup_paths( )
+
+
+##### optional stuff ############################
+
+option( BUILD_ALL "Build all" ON )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+
+
+##### configure checks
+
+include( ConfigureChecks.cmake )
+
+
+###### build translations for all languages #####
+
+if( BUILD_TRANSLATIONS )
+ file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} */messages/*.po )
+
+ foreach( _po ${po_files} )
+ string( REPLACE "/" ";" _path "${_po}" )
+ list( GET _path 0 _lang )
+ tde_create_translation( FILES ${_po} LANG ${_lang} )
+ endforeach( )
+endif( )
+
+
+###### subdirectories ###########################
+
+tde_auto_add_subdirectories( )