summaryrefslogtreecommitdiffstats
path: root/src/gvimagepart/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gvimagepart/Makefile.am')
-rw-r--r--src/gvimagepart/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/gvimagepart/Makefile.am b/src/gvimagepart/Makefile.am
new file mode 100644
index 0000000..6ed0ff3
--- /dev/null
+++ b/src/gvimagepart/Makefile.am
@@ -0,0 +1,20 @@
+INCLUDES = -I$(srcdir)/.. $(all_includes)
+
+# These are not really libraries, but modules dynamically opened.
+# So they should be installed in kde_module_dir, which is usually $kde_prefix/lib/kde3
+kde_module_LTLIBRARIES = libgvimagepart.la
+
+libgvimagepart_la_SOURCES = gvimagepart.cpp
+libgvimagepart_la_LIBADD = $(LIB_KPARTS) ../gvcore/libgwenviewcore.la
+libgvimagepart_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
+
+# Automatically generate moc files
+METASOURCES = AUTO
+
+# Install the XML-UI file to its correct location
+gvdir = $(kde_datadir)/gvimagepart
+gv_DATA = gvimagepart.rc gvimagepartpopup.rc
+
+# Install the .desktop file into the kde_services directory
+kde_services_DATA = gvimagepart.desktop
+