summaryrefslogtreecommitdiffstats
path: root/libk3bdevice/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-03-30 20:24:24 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-03-30 20:24:24 -0500
commit983ade75ae2f488477bbb796f52ce2135c202dfe (patch)
tree32fd2ad28d871b6f5f636ae5659391eac56665b5 /libk3bdevice/Makefile.am
parent39728f666128bb7d8ab24c1e3835cf0ac3c1f092 (diff)
downloadk3b-983ade75ae2f488477bbb796f52ce2135c202dfe.tar.gz
k3b-983ade75ae2f488477bbb796f52ce2135c202dfe.zip
Use TDE hardware library instead of HAL when HAL is not available
Clean up spurious build files
Diffstat (limited to 'libk3bdevice/Makefile.am')
-rw-r--r--libk3bdevice/Makefile.am10
1 files changed, 0 insertions, 10 deletions
diff --git a/libk3bdevice/Makefile.am b/libk3bdevice/Makefile.am
index 71b1b76..4489660 100644
--- a/libk3bdevice/Makefile.am
+++ b/libk3bdevice/Makefile.am
@@ -11,7 +11,6 @@ libk3bdevice_la_LIBADD = $(LIB_KIO) $(RESMGR_LIB) $(CAM_LIB) $(HAL_DBUS_LIBS) $(
# lib version 5 for K3b 1.0
libk3bdevice_la_LDFLAGS = $(all_libraries) -version-info 5:0:0 -no-undefined
-if include_HAL
libk3bdevice_la_SOURCES = k3bdevice.cpp k3bdevice_mmc.cpp k3bscsicommand.cpp \
k3btrack.cpp k3btoc.cpp k3bdevicemanager.cpp k3bmsf.cpp k3bdiskinfo.cpp \
k3bdeviceglobals.cpp k3bcrc.cpp k3bcdtext.cpp k3bhalconnection.cpp \
@@ -20,15 +19,6 @@ k3bdebug.cpp
include_HEADERS = k3bdevicemanager.h k3bdevice.h k3btoc.h k3btrack.h \
k3bdeviceglobals.h k3bdiskinfo.h k3bcdtext.h k3bmsf.h k3bdevicetypes.h \
k3bdevice_export.h k3bhalconnection.h k3bdebug.h
-else
-libk3bdevice_la_SOURCES = k3bdevice.cpp k3bdevice_mmc.cpp k3bscsicommand.cpp \
-k3btrack.cpp k3btoc.cpp k3bdevicemanager.cpp k3bmsf.cpp k3bdiskinfo.cpp \
-k3bdeviceglobals.cpp k3bcrc.cpp k3bcdtext.cpp k3bdebug.cpp
-
-include_HEADERS = k3bdevicemanager.h k3bdevice.h k3btoc.h k3btrack.h \
-k3bdeviceglobals.h k3bdiskinfo.h k3bcdtext.h k3bmsf.h k3bdevicetypes.h \
-k3bdevice_export.h k3bdebug.h
-endif
messages: rc.cpp
$(XGETTEXT) `find -name "*.cpp" -or -name "*.h"` -o $(podir)/libk3bdevice.pot