summaryrefslogtreecommitdiffstats
path: root/libk3b/plugin/libsamplerate/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libk3b/plugin/libsamplerate/Makefile.am')
-rw-r--r--libk3b/plugin/libsamplerate/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/libk3b/plugin/libsamplerate/Makefile.am b/libk3b/plugin/libsamplerate/Makefile.am
new file mode 100644
index 0000000..3154ce2
--- /dev/null
+++ b/libk3b/plugin/libsamplerate/Makefile.am
@@ -0,0 +1,20 @@
+# This file was automatically generated from the Makefile.am
+# DO NOT EDIT!
+
+noinst_LTLIBRARIES = libsamplerate.la
+#include_HEADERS = samplerate.h
+
+EXTRA_DIST = config.h.in Version_script.in
+
+COEFF_HDRS = high_qual_coeffs.h mid_qual_coeffs.h fastest_coeffs.h
+
+noinst_HEADERS = common.h float_cast.h $(COEFF_HDRS)
+
+SRC_SOURCES = samplerate.c src_sinc.c src_zoh.c src_linear.c
+
+libsamplerate_la_SOURCES = $(SRC_SOURCES)
+#libsamplerate_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@ @SHLIB_VERSION_ARG@
+libsamplerate_la_LIBADD = -lm
+
+# Disable autoheader.
+#AUTOHEADER=echo