summaryrefslogtreecommitdiffstats
path: root/libk3b/videodvd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libk3b/videodvd/Makefile.am')
-rw-r--r--libk3b/videodvd/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/libk3b/videodvd/Makefile.am b/libk3b/videodvd/Makefile.am
new file mode 100644
index 0000000..0225117
--- /dev/null
+++ b/libk3b/videodvd/Makefile.am
@@ -0,0 +1,19 @@
+AM_CPPFLAGS = -I$(srcdir) \
+ -I$(srcdir)/../core \
+ -I$(srcdir)/../../libk3bdevice \
+ -I$(srcdir)/../tools \
+ -I$(srcdir)/../plugin \
+ $(all_includes)
+
+METASOURCES = AUTO
+
+noinst_LTLIBRARIES = libvideodvd.la
+libvideodvd_la_LIBADD = -ldvdread
+
+libvideodvd_la_SOURCES = k3bvideodvd.cpp k3bvideodvdtime.cpp \
+ k3bvideodvdvideostream.cpp
+
+include_HEADERS = k3bvideodvd.h k3bvideodvdtitle.h \
+ k3bvideodvdaudiostream.h k3bvideodvdsubpicturestream.h \
+ k3bvideodvdvideostream.h k3bvideodvdtime.h \
+ k3bvideodvdptt.h