summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am92
1 files changed, 92 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..68488d0
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,92 @@
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes) $(LIBXSLT_CFLAGS) $(LIBXML_CFLAGS) $(LIBYAZ_CFLAGS) $(LIBBIBUTILS_CFLAGS)
+
+# these are the headers for your project
+noinst_HEADERS = documentlistviewitem.h fileexportertoolchain.h \
+ comment.h commentwidget.h documentlistview.h documentlistviewitem.h \
+ documentsourceview.h documentwidget.h element.h encoder.h encoderlatex.h encoderxml.h \
+ entry.h entryfield.h entrywidget.h entrywidgetauthor.h entrywidgetexternal.h \
+ entrywidgetkeyword.h entrywidgetmisc.h entrywidgetother.h entrywidgetpublication.h \
+ entrywidgetsource.h entrywidgettab.h entrywidgettitle.h entrywidgetuserdefined.h \
+ entrywidgetwarningsitem.h fieldlineedit.h fieldlistview.h file.h fileexporter.h \
+ fileexporterbibtex.h fileexporterbibutils.h fileexporterdocbook5.h fileexporterexternal.h \
+ fileexporterpdf.h fileexporterps.h fileexporterris.h fileimporterbibtex.h \
+ fileexporterrtf.h fileexporterxml.h fileexporterxslt.h fileimporter.h \
+ fileimporterbibutils.h fileimporterexternal.h fileimporterris.h findduplicates.h \
+ idsuggestions.h idsuggestionswidget.h iso5426converter.h iso6937converter.h \
+ kbibtex_part.h kbibtexshell.h latin1literal.h macro.h macrowidget.h mergeelements.h \
+ messagehandler.h preamble.h preamblewidget.h searchbar.h settings.h settingsdlg.h \
+ settingsediting.h settingsfileio.h settingsidsuggestions.h settingskeyword.h \
+ settingssearchurl.h settingsuserdefinedinput.h settingsz3950.h sidebar.h value.h \
+ valuewidget.h webquery.h webqueryamatex.h webqueryarxiv.h webquerybibsonomy.h \
+ webquerycitebase.h webqueryciteseerx.h webquerycsb.h webquerydblp.h \
+ webquerygooglescholar.h webqueryieeexplore.h webquerymathscinet.h webquerypubmed.h \
+ webquerysciencedirect.h webqueryspireshep.h webqueryz3950.h webqueryzmath.h xsltransform.h \
+ z3950connection.h
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(EXTRACTRC) *.rc >>rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kbibtex.pot
+
+KDE_ICON = AUTO
+
+# this Makefile creates both a KPart application and a KPart
+#########################################################################
+# APPLICATION SECTION
+#########################################################################
+# this is the program that gets installed. it's name is used for all
+# of the other Makefile.am variables
+bin_PROGRAMS = kbibtex
+
+# the application source, library search path, and link libraries
+kbibtex_SOURCES = kbibtexshell.cpp main.cpp
+kbibtex_LDFLAGS = $(all_libraries)
+kbibtex_LDADD = $(LIB_KPARTS)
+
+# this is where the desktop file will go
+shelldesktopdir = $(xdg_appsdir)
+shelldesktop_DATA = kbibtex.desktop
+
+#########################################################################
+# KPART SECTION
+#########################################################################
+kde_module_LTLIBRARIES = libkbibtexpart.la
+
+# the Part's source, library search path, and link libraries
+libkbibtexpart_la_SOURCES = comment.cpp fileexporterdocbook5.cpp commentwidget.cpp documentlistview.cpp \
+ documentlistviewitem.cpp documentsourceview.cpp documentwidget.cpp element.cpp encoder.cpp \
+ encoderlatex.cpp encoderxml.cpp entry.cpp entryfield.cpp entrywidget.cpp \
+ entrywidgetauthor.cpp entrywidgetexternal.cpp entrywidgetkeyword.cpp entrywidgetmisc.cpp \
+ entrywidgetother.cpp entrywidgetpublication.cpp entrywidgetsource.cpp entrywidgettab.cpp \
+ entrywidgettitle.cpp entrywidgetuserdefined.cpp entrywidgetwarningsitem.cpp \
+ z3950connection.cpp fieldlineedit.cpp fieldlistview.cpp file.cpp fileexporter.cpp \
+ fileexporterbibtex.cpp fileexporterris.cpp fileexporterbibutils.cpp fileexporterexternal.cpp fileexporterpdf.cpp \
+ fileexporterps.cpp fileexporterrtf.cpp fileexportertoolchain.cpp fileexporterxml.cpp \
+ fileexporterxslt.cpp fileimporter.cpp fileimporterbibtex.cpp fileimporterbibutils.cpp \
+ fileimporterexternal.cpp fileimporterris.cpp idsuggestions.cpp idsuggestionswidget.cpp \
+ kbibtex_part.cpp macro.cpp macrowidget.cpp mergeelements.cpp preamble.cpp webqueryieeexplore.cpp \
+ preamblewidget.cpp searchbar.cpp settings.cpp settingsdlg.cpp settingsediting.cpp \
+ settingsfileio.cpp settingsidsuggestions.cpp settingskeyword.cpp settingssearchurl.cpp \
+ settingsuserdefinedinput.cpp sidebar.cpp value.cpp valuewidget.cpp webquery.cpp webqueryamatex.cpp \
+ webqueryarxiv.cpp webqueryciteseerx.cpp webquerybibsonomy.cpp webquerycsb.cpp webquerycitebase.cpp webquerydblp.cpp webqueryz3950.cpp \
+ webquerygooglescholar.cpp webquerypubmed.cpp webqueryspireshep.cpp webqueryzmath.cpp \
+ xsltransform.cpp webquerysciencedirect.cpp findduplicates.cpp settingsz3950.cpp \
+ messagehandler.cpp iso6937converter.cpp iso5426converter.cpp webquerymathscinet.cpp
+libkbibtexpart_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+libkbibtexpart_la_LIBADD = $(LIB_KPARTS) $(LIB_KFILE) $(LIB_KUTILS) $(LIBXSLT_LIBS) $(LIBXML_LIBS) $(LIBYAZ_LIBS) $(LIBBIBUTILS_LIBS) -lkatepartinterfaces
+
+# this is where the desktop file will go
+partdesktopdir = $(kde_servicesdir)
+partdesktop_DATA = kbibtex_part.desktop
+
+# this is where the XML-GUI resource fileis go
+partrcdir = ${kde_datadir}/kbibtexpart
+partrc_DATA = kbibtex_part.rc
+shellrcdir = ${kde_datadir}/kbibtex
+shellrc_DATA = kbibtex_shell.rc
+
+appdir = $(kde_datadir)/kbibtex
+app_DATA = z3950-servers.cfg
+