summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in162
1 files changed, 0 insertions, 162 deletions
diff --git a/configure.in b/configure.in
deleted file mode 100644
index 50647ee..0000000
--- a/configure.in
+++ /dev/null
@@ -1,162 +0,0 @@
-dnl =======================================================
-dnl FILE: ./admin/configure.in.min
-dnl =======================================================
-
-dnl This file is part of the KDE libraries/packages
-dnl Copyright (C) 2001 Stephan Kulow (coolo@kde.org)
-
-dnl This file is free software; you can redistribute it and/or
-dnl modify it under the terms of the GNU Library General Public
-dnl License as published by the Free Software Foundation; either
-dnl version 2 of the License, or (at your option) any later version.
-
-dnl This library is distributed in the hope that it will be useful,
-dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
-dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-dnl Library General Public License for more details.
-
-dnl You should have received a copy of the GNU Library General Public License
-dnl along with this library; see the file COPYING.LIB. If not, write to
-dnl the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
-dnl Boston, MA 02110-1301, USA.
-
-# Original Author was Kalle@kde.org
-# I lifted it in some mater. (Stephan Kulow)
-# I used much code from Janos Farkas
-
-dnl Process this file with autoconf to produce a configure script.
-
-AC_INIT(acinclude.m4) dnl a source file from your sub dir
-
-dnl This is so we can use kde-common
-AC_CONFIG_AUX_DIR(admin)
-
-dnl This ksh/zsh feature conflicts with `cd blah ; pwd`
-unset CDPATH
-
-dnl Checking host/target/build systems, for make, install etc.
-AC_CANONICAL_SYSTEM
-dnl Perform program name transformation
-AC_ARG_PROGRAM
-
-dnl Automake doc recommends to do this only here. (Janos)
-AM_INIT_AUTOMAKE(kbiff, "3.9") dnl searches for some needed programs
-
-KDE_SET_PREFIX
-
-dnl generate the config header
-AM_CONFIG_HEADER(config.h) dnl at the distribution this done
-
-dnl Checks for programs.
-AC_CHECK_COMPILERS
-AC_ENABLE_SHARED(yes)
-AC_ENABLE_STATIC(no)
-KDE_PROG_LIBTOOL
-
-dnl for NLS support. Call them in this order!
-dnl WITH_NLS is for the po files
-AM_KDE_WITH_NLS
-
-KDE_USE_TQT(3.0)
-AC_PATH_KDE
-dnl =======================================================
-dnl FILE: configure.in.in
-dnl =======================================================
-
-#MIN_CONFIG(3.0)
-dnl PACKAGE set before
-
-AC_ARG_ENABLE(
- ssl,
- [ --disable-ssl build without SSL (imap4s and pop3s) protocol support],
- [use_ssl=$enableval],
- [use_ssl=yes])
-
-if test "$use_ssl" == "yes"; then
- AC_DEFINE([USE_SSL],[],[Compile with SSL support])
-fi
-
-
-AC_ARG_ENABLE(
- ssl,
- [ --disable-ssl build without SSL (imap4s and pop3s) protocol support],
- [use_ssl=$enableval],
- [use_ssl=yes])
-
-if test "$use_ssl" == "yes"; then
- AC_DEFINE([USE_SSL],[],[Compile with SSL support])
-fi
-
-
-AC_MSG_CHECKING(for ASUS notebook mail LED support)
-if test -f "/proc/acpi/asus/mled"; then
- AC_MSG_RESULT(yes)
- AC_DEFINE([HAVE_MLED],[],[Compile with support for Mail LED on ASUS notebooks: needs ACPI and Asus Laptop Extras (http://sourceforge.net/projects/acpi4asus/)])
-else
- AC_MSG_RESULT(no)
-fi
-KDE_CREATE_SUBDIRSLIST
-AM_CONDITIONAL(doc_SUBDIR_included, test "x$doc_SUBDIR_included" = xyes)
-AM_CONDITIONAL(kbiff_SUBDIR_included, test "x$kbiff_SUBDIR_included" = xyes)
-AM_CONDITIONAL(man_SUBDIR_included, test "x$man_SUBDIR_included" = xyes)
-AM_CONDITIONAL(po_SUBDIR_included, test "x$po_SUBDIR_included" = xyes)
-AC_CONFIG_FILES([ Makefile ])
-AC_CONFIG_FILES([ doc/Makefile ])
-AC_CONFIG_FILES([ doc/de/Makefile ])
-AC_CONFIG_FILES([ doc/de/kbiff/Makefile ])
-AC_CONFIG_FILES([ doc/en/Makefile ])
-AC_CONFIG_FILES([ doc/en/kbiff/Makefile ])
-AC_CONFIG_FILES([ doc/es/Makefile ])
-AC_CONFIG_FILES([ doc/es/kbiff/Makefile ])
-AC_CONFIG_FILES([ doc/fr/Makefile ])
-AC_CONFIG_FILES([ doc/fr/kbiff/Makefile ])
-AC_CONFIG_FILES([ kbiff/Makefile ])
-AC_CONFIG_FILES([ kbiff/pics/Makefile ])
-AC_CONFIG_FILES([ man/Makefile ])
-AC_CONFIG_FILES([ po/Makefile ])
-AC_OUTPUT
-# Check if KDE_SET_PREFIX was called, and --prefix was passed to configure
-if test -n "$kde_libs_prefix" -a -n "$given_prefix"; then
- # And if so, warn when they don't match
- if test "$kde_libs_prefix" != "$given_prefix"; then
- # And if kde doesn't know about the prefix yet
- echo ":"`tde-config --path exe`":" | grep ":$given_prefix/bin/:" 2>&1 >/dev/null
- if test $? -ne 0; then
- echo ""
- echo "Warning: you chose to install this package in $given_prefix,"
- echo "but KDE was found in $kde_libs_prefix."
- echo "For this to work, you will need to tell KDE about the new prefix, by ensuring"
- echo "that TDEDIRS contains it, e.g. export TDEDIRS=$given_prefix:$kde_libs_prefix"
- echo "Then restart KDE."
- echo ""
- fi
- fi
-fi
-
-if test x$GXX = "xyes" -a x$kde_have_gcc_visibility = "xyes" -a x$kde_cv_val_qt_gcc_visibility_patched = "xno"; then
- echo ""
- echo "Your GCC supports symbol visibility, but the patch for Qt supporting visibility"
- echo "was not included. Therefore, GCC symbol visibility support remains disabled."
- echo ""
- echo "For better performance, consider including the Qt visibility supporting patch"
- echo "located at:"
- echo ""
- echo "http://bugs.kde.org/show_bug.cgi?id=109386"
- echo ""
- echo "and recompile all of Qt and KDE. Note, this is entirely optional and"
- echo "everything will continue to work just fine without it."
- echo ""
-fi
-
-if test "$all_tests" = "bad"; then
- if test ! "$cache_file" = "/dev/null"; then
- echo ""
- echo "Please remove the file $cache_file after changing your setup"
- echo "so that configure will find the changes next time."
- echo ""
- fi
-else
- echo ""
- echo "Good - your configure finished. Start make now"
- echo ""
-fi