summaryrefslogtreecommitdiffstats
path: root/kbiff/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kbiff/CMakeLists.txt')
-rw-r--r--kbiff/CMakeLists.txt61
1 files changed, 61 insertions, 0 deletions
diff --git a/kbiff/CMakeLists.txt b/kbiff/CMakeLists.txt
new file mode 100644
index 0000000..30ccca5
--- /dev/null
+++ b/kbiff/CMakeLists.txt
@@ -0,0 +1,61 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### OpenSSL library
+
+if( USE_SSL )
+ set( _SSL ssl )
+endif()
+
+
+##### kbiff (tdeinit)
+
+tde_add_tdeinit_executable( ${PROJECT_NAME} AUTOMOC
+
+ SOURCES
+ setupdlg.cpp
+ kbiff.cpp
+ main.cpp
+ kbiffmonitor.cpp
+ notify.cpp
+ kbiffurl.cpp
+ status.cpp
+ kbiffcodec.cpp
+ led.cpp
+ kbiffcrypt.cpp
+ version.cpp
+ LINK
+ tdeio-shared
+ tdecore-shared
+ tdeui-shared
+ ${_SSL}
+)
+
+
+##### icons
+
+tde_install_icons( ${PROJECT_NAME} )
+
+
+##### other data
+
+install(
+ FILES ${PROJECT_NAME}.desktop
+ DESTINATION ${APPS_INSTALL_DIR}/Internet
+)
+
+
+##### other directory
+
+add_subdirectory( pics )