summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-05-11 17:41:22 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-05-12 16:30:30 +0200
commitc0263d89c688f750a6e68a7f77257b2be0c55990 (patch)
tree47b1f49338ff6ff2706681de80753613f9c8a27e /CMakeLists.txt
parentf0a3534123e54a962a4c7de7ebd332e6eae658d1 (diff)
downloadkchmviewer-c0263d89c688f750a6e68a7f77257b2be0c55990.tar.gz
kchmviewer-c0263d89c688f750a6e68a7f77257b2be0c55990.zip
Added controlled conversions to char* instead of automatic ascii conversions.
The definition of -UTQT_NO_ASCII_CAST is no longer needed. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f5d79d6..ebd32a3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -61,7 +61,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UTQT_NO_ASCII_CAST )
+add_definitions( -DHAVE_CONFIG_H )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )