summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-02-15 18:23:18 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-02-15 18:23:18 +0000
commit3133bbc63a2d32dac638db58fa13e966488e88b5 (patch)
tree326595b5fefc87fd7cf5ab3905bc00883fe3c919 /configure.in
downloadkchmviewer-3133bbc63a2d32dac638db58fa13e966488e88b5.tar.gz
kchmviewer-3133bbc63a2d32dac638db58fa13e966488e88b5.zip
Added abandoned KDE3 version of kchmviewer
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/kchmviewer@1090662 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in161
1 files changed, 161 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..45b5bc5
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,161 @@
+dnl =======================================================
+dnl FILE: configure.in.in
+dnl =======================================================
+
+dnl Process this file with autoconf to produce a configure script.
+dnl Most of this file was shamelessly stolen from Licq Qt plugin, which has similar configuration options
+AC_INIT
+AC_CONFIG_SRCDIR([src/main.cpp])
+AC_CONFIG_AUX_DIR(admin)
+AC_CANONICAL_SYSTEM
+AC_ARG_PROGRAM
+
+dnl All versioning is done via the following line
+AM_CONFIG_HEADER(src/config.h)
+AM_INIT_AUTOMAKE(kchmviewer, 3.1)
+
+dnl Chuck #defines for PACKAGE and VERSION into config.h
+AC_DEFINE_UNQUOTED(APP_NAME, "$PACKAGE", [ Application name ] )
+AC_DEFINE_UNQUOTED(APP_VERSION, "$VERSION", [ Application version as text ])
+AC_DEFINE_UNQUOTED(APP_INT_VERSION,$INT_VERSION, [ Application version as integer ])
+
+dnl Checks for programs.
+AC_CHECK_COMPILERS
+
+dnl Check for X and extra X libs needed
+AC_PATH_XTRA
+if test "$no_x" = yes; then
+ AC_MSG_ERROR(You need to have the X11 libraries and headers installed)
+fi
+
+KDE_PROG_LIBTOOL
+AC_ENABLE_SHARED(yes)
+AC_ENABLE_STATIC(no)
+AC_PATH_QT
+
+CHMLIBDIR="lib/chmlib"
+EXTRA_SUBDIRS=""
+
+AC_ARG_WITH(kde, AC_HELP_STRING([--with-kde],[enable KDE support]))
+
+if test "x$with_kde" = "xyes"; then
+ KDE_SET_PREFIX
+ AC_PATH_KDE
+ AM_KDE_WITH_NLS
+ AC_DEFINE(USE_KDE, 1, [use KDE support])
+fi
+
+if test "x$with_kde" != "xyes"; then
+ include_ARTS_FALSE="yes"
+ AC_PREFIX_DEFAULT(${prefix:-/usr/local})
+ KDE_SET_DEFAULT_PATHS([default])
+ eval "$kde_cv_all_paths"
+fi
+
+AM_CONDITIONAL([AMC_USE_KDE], [test "x$with_kde" = "xyes"])
+
+dnl Checking whether to use built-in, or system-wide chmlib
+dnl First check for --with-builtin-chmlib configure option - no more checks needed
+USE_BUILTIN_CHMLIB="0"
+AC_ARG_WITH(builtin-chmlib,
+ AC_HELP_STRING([--with-builtin-chmlib],[link with built-in chmlib]),
+ [ USE_BUILTIN_CHMLIB="1" ])
+
+dnl Check for the libchm in system
+if test "$USE_BUILTIN_CHMLIB" = "0"; then
+ AC_CHECK_LIB(chm, chm_open, [USE_BUILTIN_CHMLIB="0"], [USE_BUILTIN_CHMLIB="1"])
+fi
+
+if test "$USE_BUILTIN_CHMLIB" = "1"; then
+ CHM_INCLUDES="-I\$(top_srcdir)/$CHMLIBDIR"
+ CHM_LIBS="\$(top_builddir)/$CHMLIBDIR/libchm.la"
+ USE_LIB_CHM="internal"
+ EXTRA_SUBDIRS="chmlib $EXTRA_SUBDIRS"
+ AC_DEFINE(USE_BUILTIN_CHMLIB, 1, [use builtin chmlib])
+else
+ CHM_LIBS="-lchm"
+ USE_LIB_CHM="system"
+ AC_DEFINE(USE_BUILTIN_CHMLIB, 0, [use builtin chmlib])
+fi
+
+AM_CONDITIONAL([AMC_BUILD_CHMLIB], [test "$USE_BUILTIN_CHMLIB" = "1"])
+
+# libchmfile is built unconditionally
+LIBCHMFILE_INCLUDES="-I\$(top_srcdir)/lib/libchmfile -I\$(top_srcdir)/src"
+LIBCHMFILE_LIBS="\$(top_builddir)/lib/libchmfile/libchmfile.a"
+
+AC_SUBST([EXTRA_SUBDIRS])
+AC_SUBST(CHM_INCLUDES)
+AC_SUBST(USE_KDE)
+AC_SUBST(CHM_LIBS)
+AC_SUBST(LIBCHMFILE_INCLUDES)
+AC_SUBST(LIBCHMFILE_LIBS)
+
+echo ""
+echo "Please remember to use GNU make, often installed as gmake."
+echo ""
+echo "Install prefix : $prefix"
+if test "$have_kde" = yes; then
+ echo "KDE support : includes in $kde_includes, libs in $kde_libraries"
+else
+ echo "KDE support : disabled."
+fi
+echo "Qt includes : $QT_INCLUDES"
+echo "Qt libraries : $LIB_QT"
+echo "chmlib to link : $USE_LIB_CHM"
+KDE_CREATE_SUBDIRSLIST
+AC_CONFIG_FILES([ Makefile ])
+AC_CONFIG_FILES([ lib/Makefile ])
+AC_CONFIG_FILES([ lib/chmlib/Makefile ])
+AC_CONFIG_FILES([ lib/kio-msits/Makefile ])
+AC_CONFIG_FILES([ lib/libchmfile/Makefile ])
+AC_CONFIG_FILES([ po/Makefile ])
+AC_CONFIG_FILES([ src/Makefile ])
+AC_CONFIG_FILES([ src/kde/Makefile ])
+AC_CONFIG_FILES([ src/pics/Makefile ])
+AC_OUTPUT
+# Check if KDE_SET_PREFIX was called, and --prefix was passed to configure
+if test -n "$kde_libs_prefix" -a -n "$given_prefix"; then
+ # And if so, warn when they don't match
+ if test "$kde_libs_prefix" != "$given_prefix"; then
+ # And if kde doesn't know about the prefix yet
+ echo ":"`kde-config --path exe`":" | grep ":$given_prefix/bin/:" 2>&1 >/dev/null
+ if test $? -ne 0; then
+ echo ""
+ echo "Warning: you chose to install this package in $given_prefix,"
+ echo "but KDE was found in $kde_libs_prefix."
+ echo "For this to work, you will need to tell KDE about the new prefix, by ensuring"
+ echo "that KDEDIRS contains it, e.g. export KDEDIRS=$given_prefix:$kde_libs_prefix"
+ echo "Then restart KDE."
+ echo ""
+ fi
+ fi
+fi
+
+if test x$GXX = "xyes" -a x$kde_have_gcc_visibility = "xyes" -a x$kde_cv_val_qt_gcc_visibility_patched = "xno"; then
+ echo ""
+ echo "Your GCC supports symbol visibility, but the patch for Qt supporting visibility"
+ echo "was not included. Therefore, GCC symbol visibility support remains disabled."
+ echo ""
+ echo "For better performance, consider including the Qt visibility supporting patch"
+ echo "located at:"
+ echo ""
+ echo "http://bugs.kde.org/show_bug.cgi?id=109386"
+ echo ""
+ echo "and recompile all of Qt and KDE. Note, this is entirely optional and"
+ echo "everything will continue to work just fine without it."
+ echo ""
+fi
+
+if test "$all_tests" = "bad"; then
+ if test ! "$cache_file" = "/dev/null"; then
+ echo ""
+ echo "Please remove the file $cache_file after changing your setup"
+ echo "so that configure will find the changes next time."
+ echo ""
+ fi
+else
+ echo ""
+ echo "Good - your configure finished. Start make now"
+ echo ""
+fi