summaryrefslogtreecommitdiffstats
path: root/lib/tdeio-msits/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-17 17:59:07 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-17 17:59:07 +0200
commita0ea767dd23501e1ad91f6e329c71221e711fe6b (patch)
tree2f72c3b921aa2843c056ee5acca1e5ec7e2c024c /lib/tdeio-msits/CMakeLists.txt
parent55eab5ce28cffb40d7e61b5e159fa7e53d40dd4c (diff)
downloadkchmviewer-a0ea767dd23501e1ad91f6e329c71221e711fe6b.tar.gz
kchmviewer-a0ea767dd23501e1ad91f6e329c71221e711fe6b.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'lib/tdeio-msits/CMakeLists.txt')
-rw-r--r--lib/tdeio-msits/CMakeLists.txt11
1 files changed, 6 insertions, 5 deletions
diff --git a/lib/tdeio-msits/CMakeLists.txt b/lib/tdeio-msits/CMakeLists.txt
index 203fe5c..9dd5ec2 100644
--- a/lib/tdeio-msits/CMakeLists.txt
+++ b/lib/tdeio-msits/CMakeLists.txt
@@ -31,12 +31,13 @@ tde_add_kpart( tdeio_msits
##### other data
-install(
- FILES msits.protocol
+tde_create_translated_desktop(
+ SOURCE msits.protocol
DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files
)
-install(
- FILES ${PROJECT_NAME}.desktop
- DESTINATION ${XDG_APPS_INSTALL_DIR}
+tde_create_translated_desktop(
+ SOURCE ${PROJECT_NAME}.desktop
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files
)