summaryrefslogtreecommitdiffstats
path: root/src/tde/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/tde/CMakeLists.txt')
-rw-r--r--src/tde/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/tde/CMakeLists.txt b/src/tde/CMakeLists.txt
new file mode 100644
index 0000000..9370944
--- /dev/null
+++ b/src/tde/CMakeLists.txt
@@ -0,0 +1,27 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_SOURCE_DIR}/src
+ ${CMAKE_SOURCE_DIR}/lib/libchmfile
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### kdeextra (static)
+
+tde_add_library( kdeextra STATIC_PIC AUTOMOC
+
+ SOURCES
+ kchmdcopiface.skel
+ kchmdcopiface.cpp
+ kchmviewwindow_tdehtmlpart.cpp
+
+ DESTINATION ${LIB_INSTALL_DIR}
+)