summaryrefslogtreecommitdiffstats
path: root/src/electronics/components/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/electronics/components/CMakeLists.txt')
-rw-r--r--src/electronics/components/CMakeLists.txt49
1 files changed, 49 insertions, 0 deletions
diff --git a/src/electronics/components/CMakeLists.txt b/src/electronics/components/CMakeLists.txt
new file mode 100644
index 0000000..7850d19
--- /dev/null
+++ b/src/electronics/components/CMakeLists.txt
@@ -0,0 +1,49 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_SOURCE_DIR}/src
+ ${CMAKE_SOURCE_DIR}/src/electronics
+ ${CMAKE_SOURCE_DIR}/src/electronics/components
+ ${CMAKE_SOURCE_DIR}/src/electronics/simulation
+ ${CMAKE_SOURCE_DIR}/src/gui
+ ${CMAKE_SOURCE_DIR}/src/languages
+ ${CMAKE_SOURCE_DIR}/src/micro
+ ${GLIB_INCLUDE_DIRS}
+ ${GPSIM_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### components (static)
+
+tde_add_library( components STATIC_PIC AUTOMOC
+
+ SOURCES
+ ecresistor.cpp ecled.cpp ecdiode.cpp
+ ecsevensegment.cpp eckeypad.cpp
+ eccapacitor.cpp ec555.cpp eccurrentsource.cpp
+ ecfixedvoltage.cpp ecbcdto7segment.cpp
+ ecsignallamp.cpp ecclockinput.cpp
+ ecpotentiometer.cpp ecopamp.cpp ecvoltagesource.cpp
+ eccurrentsignal.cpp ecvoltagesignal.cpp
+ ecground.cpp multiinputgate.cpp fulladder.cpp
+ multiplexer.cpp demultiplexer.cpp externalconnection.cpp
+ ecsubcircuit.cpp meter.cpp probe.cpp resistordip.cpp
+ addac.cpp dependentsource.cpp flipflop.cpp
+ toggleswitch.cpp pushswitch.cpp ram.cpp
+ discretelogic.cpp piccomponent.cpp piccomponentpin.cpp
+ binarycounter.cpp bidirled.cpp matrixdisplay.cpp
+ bussplitter.cpp matrixdisplaydriver.cpp
+ magnitudecomparator.cpp serialportcomponent.cpp
+ parallelportcomponent.cpp inductor.cpp ecbjt.cpp
+ rotoswitch.cpp
+ LINK
+ elements-static
+)