summaryrefslogtreecommitdiffstats
path: root/libktorrent/net/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libktorrent/net/Makefile.am')
-rw-r--r--libktorrent/net/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/libktorrent/net/Makefile.am b/libktorrent/net/Makefile.am
new file mode 100644
index 0000000..e67354c
--- /dev/null
+++ b/libktorrent/net/Makefile.am
@@ -0,0 +1,10 @@
+INCLUDES = -I$(srcdir)/.. -I$(srcdir)/. $(all_includes)
+METASOURCES = AUTO
+libnet_la_LDFLAGS = $(all_libraries)
+noinst_LTLIBRARIES = libnet.la
+noinst_HEADERS = address.h bufferedsocket.h circularbuffer.h downloadthread.h \
+ networkthread.h portlist.h socket.h socketmonitor.h speed.h uploadthread.h
+libnet_la_SOURCES = address.cpp bufferedsocket.cpp circularbuffer.cpp \
+ downloadthread.cpp networkthread.cpp portlist.cpp socket.cpp socketgroup.cpp \
+ socketmonitor.cpp speed.cpp uploadthread.cpp
+KDE_CXXFLAGS = $(USE_EXCEPTIONS) $(USE_RTTI)