summaryrefslogtreecommitdiffstats
path: root/utests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'utests/Makefile.am')
-rw-r--r--utests/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/utests/Makefile.am b/utests/Makefile.am
new file mode 100644
index 0000000..eb25f53
--- /dev/null
+++ b/utests/Makefile.am
@@ -0,0 +1,12 @@
+INCLUDES = -I$(srcdir)/../libktorrent -I$(srcdir)/.. $(all_includes)
+METASOURCES = AUTO
+noinst_HEADERS = unittest.h testrunner.h upnpparsedescriptiontest.h \
+ upnpparseresponsetest.h dhtmsgparsetest.h biginttest.h rc4test.h difflehellmantest.h
+bin_PROGRAMS = ktutester
+ktutester_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+ktutester_SOURCES = unittest.cpp testrunner.cpp main.cpp \
+ upnpparsedescriptiontest.cpp upnpparseresponsetest.cpp dhtmsgparsetest.cpp biginttest.cpp \
+ rc4test.cpp difflehellmantest.cpp
+ktutester_LDADD = ../plugins/upnp/libktupnp.la \
+ ../libktorrent/libktorrent.la
+KDE_CXXFLAGS = $(USE_EXCEPTIONS) $(USE_RTTI)