summaryrefslogtreecommitdiffstats
path: root/plugin/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-03-01 18:55:11 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-03-01 18:55:11 +0000
commit854bf52eebd2da47ff45f6ae85f4cb89bae89876 (patch)
tree24fa0a7eabb9c300a1655d665f72327fe5ab3464 /plugin/Makefile.am
downloadsmb4k-854bf52eebd2da47ff45f6ae85f4cb89bae89876.tar.gz
smb4k-854bf52eebd2da47ff45f6ae85f4cb89bae89876.zip
Added old KDE3 version of SMB4K
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/smb4k@1097609 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'plugin/Makefile.am')
-rw-r--r--plugin/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/plugin/Makefile.am b/plugin/Makefile.am
new file mode 100644
index 0000000..db77a81
--- /dev/null
+++ b/plugin/Makefile.am
@@ -0,0 +1,13 @@
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+kde_module_LTLIBRARIES = konqsidebar_smb4k.la
+konqsidebar_smb4k_la_SOURCES = smb4k_konqplugin.cpp
+konqsidebar_smb4k_la_LDFLAGS = -module $(all_libraries) \
+ -L$(top_builddir)/smb4k/core -L$(topbuild_dir)/smb4k/widgets -lkonqsidebarplugin
+konqsidebar_smb4k_la_LIBADD = $(top_builddir)/smb4k/core/libsmb4kcore.la \
+ $(KDE_PLUGIN) $(LIB_KFILE) $(LIB_KPARTS) $(LIB_QT) $(LIB_KDECORE) \
+ $(LIB_KDEUI)
+
+globaladddir = $(kde_datadir)/konqsidebartng/add
+globaladd_DATA = smb4k_add.desktop
+noinst_HEADERS = smb4k_konqplugin.h