summaryrefslogtreecommitdiffstats
path: root/dev-tqt
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-03-23 16:42:06 +0100
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-03-24 00:03:22 +0000
commit59b36b51e2c7f1316cd53b1202d9556efe20761c (patch)
treebed975f93fcec42ab06d9379a867b65d6a74a45e /dev-tqt
parent1ed8077a58e5f201166c1bd01c629d446492d3e0 (diff)
downloadtde-packaging-gentoo-59b36b51e2c7f1316cd53b1202d9556efe20761c.tar.gz
tde-packaging-gentoo-59b36b51e2c7f1316cd53b1202d9556efe20761c.zip
Live ebuilds: Add `tqt-avahi` ebuild.
Also: Add proper Avahi support to `tdelibs`. Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'dev-tqt')
-rw-r--r--dev-tqt/avahi-tqt/avahi-tqt-9999.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-tqt/avahi-tqt/avahi-tqt-9999.ebuild b/dev-tqt/avahi-tqt/avahi-tqt-9999.ebuild
new file mode 100644
index 00000000..0213a269
--- /dev/null
+++ b/dev-tqt/avahi-tqt/avahi-tqt-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_TYPE="dependencies"
+TRINITY_MODULE_NAME="${PN}"
+
+inherit trinity-base-2
+
+DESCRIPTION="Avahi TQt bindings"
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+
+DEPEND="net-dns/avahi
+ =dev-tqt/tqtinterface-${PV}"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ cmake-utils_src_configure
+} \ No newline at end of file