summaryrefslogtreecommitdiffstats
path: root/app-mobilephone/smssend/smssend-3.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/smssend/smssend-3.5.ebuild')
-rw-r--r--app-mobilephone/smssend/smssend-3.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-mobilephone/smssend/smssend-3.5.ebuild b/app-mobilephone/smssend/smssend-3.5.ebuild
new file mode 100644
index 00000000..50cfb1ef
--- /dev/null
+++ b/app-mobilephone/smssend/smssend-3.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools
+
+# Don't use Gentoo mirrors
+RESTRICT="mirror"
+
+DESCRIPTION="Universal SMS sender"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="https://mirror.amdmi3.ru/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+
+# Without SSL support in skyutils, some providers fail.
+DEPEND="dev-libs/skyutils[ssl]"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-verizon.patch" )
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ default
+
+ mv "${S}"/configure.in "${S}"/configure.ac
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac \
+ || die 'failed to rename AM_CONFIG_HEADER macro'
+
+ eautoreconf
+}