summaryrefslogtreecommitdiffstats
path: root/trinity-apps/konversation
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/konversation')
-rw-r--r--trinity-apps/konversation/konversation-9999.ebuild18
1 files changed, 7 insertions, 11 deletions
diff --git a/trinity-apps/konversation/konversation-9999.ebuild b/trinity-apps/konversation/konversation-9999.ebuild
index 37b29965..389b17e3 100644
--- a/trinity-apps/konversation/konversation-9999.ebuild
+++ b/trinity-apps/konversation/konversation-9999.ebuild
@@ -3,7 +3,6 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-TRINITY_MODULE_TYPE="applications"
TRINITY_EXTRAGEAR_PACKAGING="yes"
TRINITY_HANDBOOK="optional"
@@ -13,25 +12,22 @@ TRINITY_LANGS="ar bg ca da de el en_GB es et fi fr gl he
TRINITY_DOC_LANGS="da es et it pt ru sv"
+TRINITY_MODULE_TYPE="applications"
inherit trinity-base-2
DESCRIPTION="A user friendly IRC Client for Trinity"
HOMEPAGE="https://trinitydesktop.org/"
-LICENSE="|| ( GPL-2 GPL-3 )"
-
-need-trinity
-SLOT="${TRINITY_VER}"
-
-IUSE+=" xscreensaver"
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+IUSE="xscreensaver"
-DEPEND+=" xscreensaver? ( x11-libs/libXScrnSaver )"
-RDEPEND+=" ${DEPEND}"
+DEPEND="xscreensaver? ( x11-libs/libXScrnSaver )"
+RDEPEND="${DEPEND}"
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DWITH_XSCREENSAVER="$(usex xscreensaver)"
)
-
trinity-base-2_src_configure
}