summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kooldock
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-apps/kooldock')
-rw-r--r--trinity-apps/kooldock/Manifest1
-rw-r--r--trinity-apps/kooldock/kooldock-14.0.12.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/trinity-apps/kooldock/Manifest b/trinity-apps/kooldock/Manifest
index 04dce275..9b228cbb 100644
--- a/trinity-apps/kooldock/Manifest
+++ b/trinity-apps/kooldock/Manifest
@@ -1 +1,2 @@
DIST kooldock-trinity-14.0.11.tar.xz 335944 BLAKE2B f8a1258d0c32504441e38864d601d22559be628f37a3b634835aacc211389422b08a7e3768520a06cb046f1e0a1507b6cbc6f7574b070b0d050337d4731b6d39 SHA512 0e06bd3bd72da8cb7389df0c873264bef1bc379102c7267c43fa8fd045dba182255740c62cf138b0310601769c08e26642e009f74617316abed342d428bd7f5d
+DIST kooldock-trinity-14.0.12.tar.xz 337172 BLAKE2B a8acadd7084203511ac5a4aa2c904a5ff319df1204f16b5f254cba186ed2a17a95d85811972cfaca05ad0f6afc9bf21b4b33a41e23cca34095f19ac4e33b8c30 SHA512 a93f82457f40f2a565a64eb44c9b80d4ad7954bface5f41c477af4523b1c67617ba553be75d980476d9e741f0788f0aa68ee488b80d495cb68ea73fb8477bde1
diff --git a/trinity-apps/kooldock/kooldock-14.0.12.ebuild b/trinity-apps/kooldock/kooldock-14.0.12.ebuild
new file mode 100644
index 00000000..0e5a5b40
--- /dev/null
+++ b/trinity-apps/kooldock/kooldock-14.0.12.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="cs de es fr it nl pl sv"
+TRINITY_MODULE_TYPE="applications/system"
+inherit trinity-base-2
+
+DESCRIPTION="A dock for TDE, which attemps to resemble the Mac OSX dock"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}