summaryrefslogtreecommitdiffstats
path: root/trinity-base/tdegraphics-tdefile-plugins
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-base/tdegraphics-tdefile-plugins')
-rw-r--r--trinity-base/tdegraphics-tdefile-plugins/Manifest1
-rw-r--r--trinity-base/tdegraphics-tdefile-plugins/tdegraphics-tdefile-plugins-14.0.12.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/trinity-base/tdegraphics-tdefile-plugins/Manifest b/trinity-base/tdegraphics-tdefile-plugins/Manifest
index a69742b8..6dbba257 100644
--- a/trinity-base/tdegraphics-tdefile-plugins/Manifest
+++ b/trinity-base/tdegraphics-tdefile-plugins/Manifest
@@ -1 +1,2 @@
DIST tdegraphics-trinity-14.0.11.tar.xz 5806172 BLAKE2B 74de0c533bb95fe61b0575b5cf0ddf1f0050e8e22c69e116b0371b9c89109f856cd2e35e5c7256ad6d8f5ec3bd3b6c30aa038fdc8e2af63322dbf5969bbaaec9 SHA512 1a55a9b2968151af0c3c0982b766fe82e589dcceca6795947a01d30c878613a00614f54a1bbd1d5daa921012e6a1d952da7d52e77c7eb12b640ee69874f6c6ff
+DIST tdegraphics-trinity-14.0.12.tar.xz 5803536 BLAKE2B 0f923874a6b0f6ce4d92934a9a6ecfd695ff98707aa174fea986f4d513dc98723289315b06bca8842b5a3848136b0bda74765c50d3232099a95c2ce27a3e8607 SHA512 315b44af211f471b6aa604e0d0ae00965298e0f5032c2ce1b9693ce8c662fcbf966799530ba36758775e922784551547e08402357df692eafeb0568a2bd46d0e
diff --git a/trinity-base/tdegraphics-tdefile-plugins/tdegraphics-tdefile-plugins-14.0.12.ebuild b/trinity-base/tdegraphics-tdefile-plugins/tdegraphics-tdefile-plugins-14.0.12.ebuild
new file mode 100644
index 00000000..3410460c
--- /dev/null
+++ b/trinity-base/tdegraphics-tdefile-plugins/tdegraphics-tdefile-plugins-14.0.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="tdegraphics"
+TRINITY_MODULE_TYPE="core"
+TSM_EXTRACT_ALSO="kghostview/dscparse/"
+inherit trinity-meta-2
+
+DESCRIPTION="tdefile plugins from tdegraphics"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="tiff openexr pdf"
+
+DEPEND="
+ tiff? ( media-libs/tiff:= )
+ openexr? ( media-libs/openexr )
+ pdf? ( app-text/poppler )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_TIFF="$(usex tiff)"
+ -DWITH_OPENEXR="$(usex openexr)"
+ -DWITH_PDF="$(usex pdf)"
+ )
+
+ trinity-meta-2_src_configure
+}