summaryrefslogtreecommitdiffstats
path: root/debian/lenny/applications/kshutdown/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-02-02 15:38:38 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-02-02 15:38:38 +0100
commit9433de094acac1066ab693be8fe5844b8f3ab4d2 (patch)
tree85be7b16cb21295861b22a090ae2852ac27e7ac9 /debian/lenny/applications/kshutdown/debian/rules
parentab9c0fd221389eeb85dc08d266bac96f2bce5e2e (diff)
downloadtde-packaging-9433de094acac1066ab693be8fe5844b8f3ab4d2.tar.gz
tde-packaging-9433de094acac1066ab693be8fe5844b8f3ab4d2.zip
DEB kshutdown: Switch to cmake.
The man page has been moved to the main tree. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'debian/lenny/applications/kshutdown/debian/rules')
-rwxr-xr-xdebian/lenny/applications/kshutdown/debian/rules48
1 files changed, 13 insertions, 35 deletions
diff --git a/debian/lenny/applications/kshutdown/debian/rules b/debian/lenny/applications/kshutdown/debian/rules
index a9c195576..d8d772064 100755
--- a/debian/lenny/applications/kshutdown/debian/rules
+++ b/debian/lenny/applications/kshutdown/debian/rules
@@ -1,42 +1,20 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
-include debian/cdbs/kde.mk
-#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+include /usr/share/cdbs/1/class/cmake.mk
+include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include debian/cdbs/debian-qt-kde.mk
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
- dh_testdir
-
- # Regenerate build system
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- autoreconf --install && automake -f && \
- $(MAKE) -f admin/Makefile.common && \
- touch debian/stamp-bootstrap
-
-binary-install/kshutdown-trinity::
- dh_testdir
- mv debian/$(cdbs_curpkg)/usr/share/man debian/$(cdbs_curpkg)/opt/trinity/share/
-
-clean::
- dh_testdir
- rm -f debian/stamp-bootstrap
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"