summaryrefslogtreecommitdiffstats
path: root/debian/lenny
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-02-09 15:24:14 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-02-09 15:24:14 +0100
commit41430a343561f651922419ae870f2f871003ca92 (patch)
tree6e6eea9eb319e58249531e54fa5ab9d492c45887 /debian/lenny
parent287115c2b369b17d08846ddfac5da90c782a4e0a (diff)
downloadtde-packaging-41430a343561f651922419ae870f2f871003ca92.tar.gz
tde-packaging-41430a343561f651922419ae870f2f871003ca92.zip
DEB tde-style-ia-ora: Switch to cmake.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'debian/lenny')
-rw-r--r--debian/lenny/applications/tde-style-ia-ora/debian/control2
-rwxr-xr-xdebian/lenny/applications/tde-style-ia-ora/debian/rules20
2 files changed, 14 insertions, 8 deletions
diff --git a/debian/lenny/applications/tde-style-ia-ora/debian/control b/debian/lenny/applications/tde-style-ia-ora/debian/control
index 1707aa9f4..27263207a 100644
--- a/debian/lenny/applications/tde-style-ia-ora/debian/control
+++ b/debian/lenny/applications/tde-style-ia-ora/debian/control
@@ -3,7 +3,7 @@ Section: tde
Priority: optional
Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
X-Original-Maintainer: Jose Luis Tallon <jltallon@adv-solutions.net>
-Build-Depends: cdbs, debhelper (>= 7.0.50~), quilt, automake, libtool, tdebase-trinity-dev
+Build-Depends: cdbs, debhelper (>= 7.0.50~), quilt, cmake, tdebase-trinity-dev
Standards-Version: 3.8.0
Package: tde-style-ia-ora-trinity
diff --git a/debian/lenny/applications/tde-style-ia-ora/debian/rules b/debian/lenny/applications/tde-style-ia-ora/debian/rules
index c9d7823f9..4a317e325 100755
--- a/debian/lenny/applications/tde-style-ia-ora/debian/rules
+++ b/debian/lenny/applications/tde-style-ia-ora/debian/rules
@@ -1,14 +1,20 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include /usr/share/cdbs/1/rules/patchsys-quilt.mk
include debian/cdbs/debian-qt-kde.mk
-#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-include /usr/share/cdbs/1/rules/utils.mk
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"