summaryrefslogtreecommitdiffstats
path: root/debian/lenny
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-03-31 03:59:46 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-03-31 03:59:46 +0200
commit7a7ad6702b68787b4607149c6e11bcd0569f335a (patch)
tree41e48b064a13fc374b9e55141506bc6225938a2d /debian/lenny
parent9f5f160a353fa4f8099018354b36324e23bbfe02 (diff)
downloadtde-packaging-7a7ad6702b68787b4607149c6e11bcd0569f335a.tar.gz
tde-packaging-7a7ad6702b68787b4607149c6e11bcd0569f335a.zip
DEB libkipi: Switch to cmake.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'debian/lenny')
-rw-r--r--debian/lenny/libraries/libkipi/debian/cdbs/debian-qt-kde.mk4
-rw-r--r--debian/lenny/libraries/libkipi/debian/cdbs/kde.mk4
-rw-r--r--debian/lenny/libraries/libkipi/debian/control2
-rwxr-xr-xdebian/lenny/libraries/libkipi/debian/rules29
-rw-r--r--debian/lenny/libraries/libkipi/debian/watch22
5 files changed, 20 insertions, 41 deletions
diff --git a/debian/lenny/libraries/libkipi/debian/cdbs/debian-qt-kde.mk b/debian/lenny/libraries/libkipi/debian/cdbs/debian-qt-kde.mk
index 9f8f97776..60310a01a 100644
--- a/debian/lenny/libraries/libkipi/debian/cdbs/debian-qt-kde.mk
+++ b/debian/lenny/libraries/libkipi/debian/cdbs/debian-qt-kde.mk
@@ -10,6 +10,7 @@ _cdbs_class_debian-qt-kde := 1
# Note: This _must_ be included before autotools.mk, or it won't work.
common-configure-arch common-configure-indep:: debian/stamp-cvs-make
debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
@@ -18,6 +19,7 @@ ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
endif
$(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
touch debian/stamp-cvs-make
include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
@@ -102,6 +104,7 @@ binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
done
clean::
+ifndef _cdbs_class_cmake
if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
cd $(DEB_SRCDIR); \
find . -name Makefile.in -print | \
@@ -110,6 +113,7 @@ clean::
configure configure.files configure.in stamp-h.in \
subdirs; \
fi
+endif
rm -f debian/stamp-cvs-make
endif
diff --git a/debian/lenny/libraries/libkipi/debian/cdbs/kde.mk b/debian/lenny/libraries/libkipi/debian/cdbs/kde.mk
index 1ac26c4b7..80176d63e 100644
--- a/debian/lenny/libraries/libkipi/debian/cdbs/kde.mk
+++ b/debian/lenny/libraries/libkipi/debian/cdbs/kde.mk
@@ -35,7 +35,9 @@ else
DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
endif
+ifndef _cdbs_class_cmake
include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
export kde_cgidir = \$${libdir}/cgi-bin
export kde_confdir = \$${sysconfdir}/trinity
@@ -59,7 +61,7 @@ endif
cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/tde"
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
diff --git a/debian/lenny/libraries/libkipi/debian/control b/debian/lenny/libraries/libkipi/debian/control
index f2355f8ae..669724b1f 100644
--- a/debian/lenny/libraries/libkipi/debian/control
+++ b/debian/lenny/libraries/libkipi/debian/control
@@ -3,7 +3,7 @@ Section: libs
Priority: optional
Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
Uploaders: Achim Bohnet <ach@mpe.mpg.de>, Mark Purcell <msp@debian.org>
-Build-Depends: cdbs, debhelper (>= 7.0.50~), quilt, libexif-dev, tdelibs14-trinity-dev (>= 4:3.4.3-2), automake, autoconf, libtool, libltdl-dev
+Build-Depends: cdbs, debhelper (>= 7.0.50~), quilt, cmake, libexif-dev, tdelibs14-trinity-dev (>= 4:3.4.3-2)
Standards-Version: 3.8.4
Package: libkipi0-trinity-dev
diff --git a/debian/lenny/libraries/libkipi/debian/rules b/debian/lenny/libraries/libkipi/debian/rules
index 9835b9048..4a317e325 100755
--- a/debian/lenny/libraries/libkipi/debian/rules
+++ b/debian/lenny/libraries/libkipi/debian/rules
@@ -1,25 +1,20 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
-include debian/cdbs/debian-qt-kde.mk
+include /usr/share/cdbs/1/class/cmake.mk
include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-include /usr/share/cdbs/1/rules/utils.mk
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_INSTALL_DOCS_libkipi0-trinity-dev = libkipi/libkipi/design
-
-DEB_KDE_ENABLE_FINAL = yes
-
-DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
+include debian/cdbs/debian-qt-kde.mk
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-clean ::
- rm -f po/*/*.gmo
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"
diff --git a/debian/lenny/libraries/libkipi/debian/watch b/debian/lenny/libraries/libkipi/debian/watch
deleted file mode 100644
index a913b7d89..000000000
--- a/debian/lenny/libraries/libkipi/debian/watch
+++ /dev/null
@@ -1,22 +0,0 @@
-# Example watch control file for uscan
-# Rename this file to "watch" and then you can run the "uscan" command
-# to check for upstream updates and more.
-# See uscan(1) for format
-
-# Compulsory line, this is a version 3 file
-version=3
-
-# Uncomment to examine a Webpage
-# <Webpage URL> <string match>
-#http://www.example.com/downloads.php #PACKAGE#-(.*)\.tar\.gz
-
-# Uncomment to examine a Webserver directory
-#http://www.example.com/pub/#PACKAGE#-(.*)\.tar\.gz
-
-# Uncommment to examine a FTP server
-#ftp://ftp.example.com/pub/#PACKAGE#-(.*)\.tar\.gz debian uupdate
-
-# Uncomment to find new files on sourceforge, for debscripts >= 2.9
-http://sf.net/kipi/libkipi-(.*)\.tar\.bz2 debian svn-upgrade
-
-