summaryrefslogtreecommitdiffstats
path: root/debian/wheezy/dependencies
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2012-12-11 03:02:18 +0100
committerSlávek Banko <slavek.banko@axis.cz>2012-12-11 03:23:05 +0100
commite12b7beacb145e0359e66ec5d4cfc0494d3ca908 (patch)
treee86872f1a89da47dcecfbec08d7d2d9749d8cf38 /debian/wheezy/dependencies
parentcbad8f3b74c7eae27da2e4fac11b736a879e2f47 (diff)
downloadtde-packaging-e12b7beacb145e0359e66ec5d4cfc0494d3ca908.tar.gz
tde-packaging-e12b7beacb145e0359e66ec5d4cfc0494d3ca908.zip
Use xz (or bzip2) compression for Debian and Ubuntu binary packages
Diffstat (limited to 'debian/wheezy/dependencies')
-rwxr-xr-xdebian/wheezy/dependencies/arts/debian/rules3
-rwxr-xr-xdebian/wheezy/dependencies/avahi-tqt/debian/rules3
-rwxr-xr-xdebian/wheezy/dependencies/dbus-1-tqt/debian/rules3
-rwxr-xr-xdebian/wheezy/dependencies/dbus-tqt/debian/rules3
-rwxr-xr-xdebian/wheezy/dependencies/libart-lgpl/debian/rules2
-rwxr-xr-xdebian/wheezy/dependencies/libcaldav/debian/rules5
-rwxr-xr-xdebian/wheezy/dependencies/libcarddav/debian/rules5
-rwxr-xr-xdebian/wheezy/dependencies/python-tqt/debian/rules5
-rwxr-xr-xdebian/wheezy/dependencies/qt3/debian/rules7
-rwxr-xr-xdebian/wheezy/dependencies/sip4-tqt/debian/rules5
-rwxr-xr-xdebian/wheezy/dependencies/tqca-tls/debian/rules5
-rwxr-xr-xdebian/wheezy/dependencies/tqscintilla/debian/rules7
-rwxr-xr-xdebian/wheezy/dependencies/tqt3/debian/rules7
-rwxr-xr-xdebian/wheezy/dependencies/tqtinterface/debian/rules3
14 files changed, 52 insertions, 11 deletions
diff --git a/debian/wheezy/dependencies/arts/debian/rules b/debian/wheezy/dependencies/arts/debian/rules
index b0a724e1a..9c9730bda 100755
--- a/debian/wheezy/dependencies/arts/debian/rules
+++ b/debian/wheezy/dependencies/arts/debian/rules
@@ -23,6 +23,9 @@ DEB_BUILD_PARALLEL = true
DEB_DH_STRIP_ARGS := --dbg-package=arts-trinity-dbg
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
PACKAGES_WITH_LIBS := libarts1c2a-trinity libartsc0-trinity
DEB_DH_MAKESHLIBS_ARGS_ALL := -V
diff --git a/debian/wheezy/dependencies/avahi-tqt/debian/rules b/debian/wheezy/dependencies/avahi-tqt/debian/rules
index d4694a4bf..54a22a44f 100755
--- a/debian/wheezy/dependencies/avahi-tqt/debian/rules
+++ b/debian/wheezy/dependencies/avahi-tqt/debian/rules
@@ -13,6 +13,9 @@ DEB_CONFIGURE_EXTRA_FLAGS += \
--disable-gtk3 \
--with-systemdsystemunitdir=/lib/systemd/system
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
post-patches:: debian/stamp-bootstrap
debian/stamp-bootstrap:
diff --git a/debian/wheezy/dependencies/dbus-1-tqt/debian/rules b/debian/wheezy/dependencies/dbus-1-tqt/debian/rules
index b7aa427f8..3b86de7db 100755
--- a/debian/wheezy/dependencies/dbus-1-tqt/debian/rules
+++ b/debian/wheezy/dependencies/dbus-1-tqt/debian/rules
@@ -4,3 +4,6 @@ include /usr/share/cdbs/1/rules/simple-patchsys.mk
include /usr/share/cdbs/1/rules/utils.mk
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/cmake.mk
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
diff --git a/debian/wheezy/dependencies/dbus-tqt/debian/rules b/debian/wheezy/dependencies/dbus-tqt/debian/rules
index 894533134..a59bed76e 100755
--- a/debian/wheezy/dependencies/dbus-tqt/debian/rules
+++ b/debian/wheezy/dependencies/dbus-tqt/debian/rules
@@ -10,3 +10,6 @@ include /usr/share/cdbs/1/class/cmake.mk
# Strict library versioning
DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
diff --git a/debian/wheezy/dependencies/libart-lgpl/debian/rules b/debian/wheezy/dependencies/libart-lgpl/debian/rules
index 4390434f7..2751eb1f2 100755
--- a/debian/wheezy/dependencies/libart-lgpl/debian/rules
+++ b/debian/wheezy/dependencies/libart-lgpl/debian/rules
@@ -20,3 +20,5 @@ GNOME_MODULE := libart_lgpl
DEB_DH_MAKESHLIBS_ARGS_$(libart-2.0-N) += -V '$(libart-2.0-N)(>= 2.3.18)'
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
diff --git a/debian/wheezy/dependencies/libcaldav/debian/rules b/debian/wheezy/dependencies/libcaldav/debian/rules
index 0dda6ea24..fb72a35e7 100755
--- a/debian/wheezy/dependencies/libcaldav/debian/rules
+++ b/debian/wheezy/dependencies/libcaldav/debian/rules
@@ -5,6 +5,9 @@ include /usr/share/quilt/quilt.make
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
# This has to be exported to make some magic below work.
export DH_OPTIONS
@@ -86,7 +89,7 @@ binary-common:
dh_shlibdeps
dh_gencontrol
dh_md5sums
- dh_builddeb
+ dh_builddeb $(DEB_DH_BUILDDEB_ARGS)
# Build architecture independent packages using the common target.
binary-indep: build install
diff --git a/debian/wheezy/dependencies/libcarddav/debian/rules b/debian/wheezy/dependencies/libcarddav/debian/rules
index 124929739..24bdcbc93 100755
--- a/debian/wheezy/dependencies/libcarddav/debian/rules
+++ b/debian/wheezy/dependencies/libcarddav/debian/rules
@@ -5,6 +5,9 @@ include /usr/share/quilt/quilt.make
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
# This has to be exported to make some magic below work.
export DH_OPTIONS
@@ -86,7 +89,7 @@ binary-common:
dh_shlibdeps
dh_gencontrol
dh_md5sums
- dh_builddeb
+ dh_builddeb $(DEB_DH_BUILDDEB_ARGS)
# Build architecture independent packages using the common target.
binary-indep: build install
diff --git a/debian/wheezy/dependencies/python-tqt/debian/rules b/debian/wheezy/dependencies/python-tqt/debian/rules
index ebb91c6e4..86eca95c9 100755
--- a/debian/wheezy/dependencies/python-tqt/debian/rules
+++ b/debian/wheezy/dependencies/python-tqt/debian/rules
@@ -3,6 +3,9 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
export DH_OPTIONS
-include /usr/share/python/python.mk
@@ -158,7 +161,7 @@ endif
dh_shlibdeps
dh_gencontrol
dh_md5sums
- dh_builddeb
+ dh_builddeb $(DEB_DH_BUILDDEB_ARGS)
# Build architecture independant packages using the common target.
binary-indep: install-indep
diff --git a/debian/wheezy/dependencies/qt3/debian/rules b/debian/wheezy/dependencies/qt3/debian/rules
index b678d312d..7ede42ad9 100755
--- a/debian/wheezy/dependencies/qt3/debian/rules
+++ b/debian/wheezy/dependencies/qt3/debian/rules
@@ -11,6 +11,9 @@ export LD_LIBRARY_PATH=$(QTDIR)/lib:$(OLD_LD_LIBRARY_PATH)
OLD_PATH := $(PATH)
export PATH=$(QTDIR)/bin:$(OLD_PATH)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
DEB_HOST_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
@@ -327,7 +330,7 @@ binary-indep: build install
dh_gencontrol -i
dh_md5sums -i
- dh_builddeb -i
+ dh_builddeb -i $(DEB_DH_BUILDDEB_ARGS)
binary-arch: build install
@@ -469,7 +472,7 @@ binary-arch: build install
dh_gencontrol -a $(IBASE)
dh_md5sums -a $(IBASE)
- dh_builddeb -a $(IBASE)
+ dh_builddeb -a $(IBASE) $(DEB_DH_BUILDDEB_ARGS)
binary: binary-indep binary-arch
.PHONY: build binary-indep binary-arch binary install clean patch unpatch
diff --git a/debian/wheezy/dependencies/sip4-tqt/debian/rules b/debian/wheezy/dependencies/sip4-tqt/debian/rules
index 0dd14099f..2286739d5 100755
--- a/debian/wheezy/dependencies/sip4-tqt/debian/rules
+++ b/debian/wheezy/dependencies/sip4-tqt/debian/rules
@@ -2,6 +2,9 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
export DH_OPTIONS
INSTDIR=$(CURDIR)/debian
@@ -134,7 +137,7 @@ endif
dh_shlibdeps
dh_gencontrol
dh_md5sums
- dh_builddeb
+ dh_builddeb $(DEB_DH_BUILDDEB_ARGS)
# Build architecture independant packages using the common target.
binary-indep:
diff --git a/debian/wheezy/dependencies/tqca-tls/debian/rules b/debian/wheezy/dependencies/tqca-tls/debian/rules
index 4ffaf90dc..fc9e58e55 100755
--- a/debian/wheezy/dependencies/tqca-tls/debian/rules
+++ b/debian/wheezy/dependencies/tqca-tls/debian/rules
@@ -6,6 +6,9 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
# These are used for cross-compiling and for saving the configure script
# from having to guess our platform (since we know it already)
@@ -104,7 +107,7 @@ binary-arch: build install
dh_shlibdeps
dh_gencontrol
dh_md5sums
- dh_builddeb
+ dh_builddeb $(DEB_DH_BUILDDEB_ARGS)
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install
diff --git a/debian/wheezy/dependencies/tqscintilla/debian/rules b/debian/wheezy/dependencies/tqscintilla/debian/rules
index 36df66cc9..8dfaa3377 100755
--- a/debian/wheezy/dependencies/tqscintilla/debian/rules
+++ b/debian/wheezy/dependencies/tqscintilla/debian/rules
@@ -5,6 +5,9 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
# This is the debhelper compatibility version to use.
export QTDIR=/usr/share/tqt3
export QMAKESPEC=$(QTDIR)/mkspecs/linux-g++
@@ -82,7 +85,7 @@ binary-indep: build install
dh_installdeb -i
dh_gencontrol -i
dh_md5sums -i
- dh_builddeb -i
+ dh_builddeb -i $(DEB_DH_BUILDDEB_ARGS)
# Build architecture-dependent files here.
binary-arch: build install
@@ -100,7 +103,7 @@ binary-arch: build install
dh_shlibdeps -a
dh_gencontrol -a
dh_md5sums -a
- dh_builddeb -a
+ dh_builddeb -a $(DEB_DH_BUILDDEB_ARGS)
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure
diff --git a/debian/wheezy/dependencies/tqt3/debian/rules b/debian/wheezy/dependencies/tqt3/debian/rules
index 3f8e98c3a..d2d66f6a7 100755
--- a/debian/wheezy/dependencies/tqt3/debian/rules
+++ b/debian/wheezy/dependencies/tqt3/debian/rules
@@ -11,6 +11,9 @@ export LD_LIBRARY_PATH=$(QTDIR)/lib:$(OLD_LD_LIBRARY_PATH)
OLD_PATH := $(PATH)
export PATH=$(QTDIR)/bin:$(OLD_PATH)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
DEB_HOST_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
@@ -331,7 +334,7 @@ binary-indep: build install
dh_gencontrol -i
dh_md5sums -i
- dh_builddeb -i
+ dh_builddeb -i $(DEB_DH_BUILDDEB_ARGS)
binary-arch: build install
@@ -462,7 +465,7 @@ binary-arch: build install
dh_gencontrol -a $(IBASE)
dh_md5sums -a $(IBASE)
- dh_builddeb -a $(IBASE)
+ dh_builddeb -a $(IBASE) $(DEB_DH_BUILDDEB_ARGS)
binary: binary-indep binary-arch
.PHONY: build binary-indep binary-arch binary install clean patch unpatch
diff --git a/debian/wheezy/dependencies/tqtinterface/debian/rules b/debian/wheezy/dependencies/tqtinterface/debian/rules
index f05e2fadd..5d8f4cb4c 100755
--- a/debian/wheezy/dependencies/tqtinterface/debian/rules
+++ b/debian/wheezy/dependencies/tqtinterface/debian/rules
@@ -14,6 +14,9 @@ DEB_OPT_FLAG += -DDEBIAN_VERSION=$(DEB_VERSION)
DEB_CMAKE_EXTRA_FLAGS := -DPKGCONFIG_INSTALL_DIR="/usr/lib/pkgconfig" -DLIB_SUFFIX="" -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_LIBRARY_PATH="/usr/lib" -DCMAKE_INCLUDE_PATH="/usr/include" -DCMAKE_VERBOSE_MAKEFILE="ON" -DWITH_QT3="ON" -DQTDIR="/usr/share/qt3" -DQT_LIBRARY_DIRS="/usr/share/qt3/lib" -DBUILD_ALL="ON" -DUSE_QT3="ON" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
# Honour "parallel=N" option of DEB_BUILD_OPTIONS. Comment out to
# never build in parallel, regardless of DEB_BUILD_OPTIONS.
DEB_BUILD_PARALLEL = true