summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2022-04-21 18:52:21 +0200
committerSlávek Banko <slavek.banko@axis.cz>2022-04-21 18:59:38 +0200
commit71eaac9990ec258fa4707e57a74d77f52da14417 (patch)
treed3523387111b742bd261daaf6265735c478f505d /debian
parentcfaca8188c485ae756f7d7f49fda1d9926d4652c (diff)
downloadtde-packaging-71eaac9990ec258fa4707e57a74d77f52da14417.tar.gz
tde-packaging-71eaac9990ec258fa4707e57a74d77f52da14417.zip
DEB sip4-tqt: Fix empty python3-sip-tqt-dbg package.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/_base/dependencies/sip4-tqt/debian/rules9
1 files changed, 8 insertions, 1 deletions
diff --git a/debian/_base/dependencies/sip4-tqt/debian/rules b/debian/_base/dependencies/sip4-tqt/debian/rules
index bee7971c1..1811da75b 100755
--- a/debian/_base/dependencies/sip4-tqt/debian/rules
+++ b/debian/_base/dependencies/sip4-tqt/debian/rules
@@ -105,6 +105,10 @@ install-arch: build
b=$$(basename $$i .so); \
mv $$i $$(dirname $$i)/$${b}_d.so; \
done
+ for i in $$(find debian/python3-sip-tqt-dbg -name '*.so'); do \
+ b=$$(basename $$i .so); \
+ mv $$i $$(dirname $$i)/$${b}_d.so; \
+ done
find debian/python-sip-tqt-dbg ! -type d ! -name '*_d.*' | xargs rm -f
find debian/python-sip-tqt-dbg -depth -empty -exec rmdir {} \;
find debian/python3-sip-tqt-dbg ! -type d ! -name '*_d.*' | xargs rm -f
@@ -164,6 +168,9 @@ ifneq (,$(findstring -a, $(DH_OPTIONS)))
rm -rf debian/python-sip-tqt-dbg/usr/share/doc/python-sip-tqt-dbg
mkdir -p debian/python-sip-tqt-dbg/usr/share/doc
ln -s python-sip-tqt debian/python-sip-tqt-dbg/usr/share/doc/python-sip-tqt-dbg
+ rm -rf debian/python3-sip-tqt-dbg/usr/share/doc/python3-sip-tqt-dbg
+ mkdir -p debian/python3-sip-tqt-dbg/usr/share/doc
+ ln -s python3-sip-tqt debian/python3-sip-tqt-dbg/usr/share/doc/python3-sip-tqt-dbg
endif
dh_compress -X.inv
dh_fixperms
@@ -172,7 +179,7 @@ ifneq (dh_pysupport,${DH_PYTHON2})
else
${DH_PYTHON2}
endif
- dh_python3
+ dh_python3 --no-dbg-cleaning
dh_installdeb
dh_shlibdeps
dh_gencontrol