summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2016-03-13 12:41:18 +0100
committerSlávek Banko <slavek.banko@axis.cz>2016-03-13 12:41:18 +0100
commitc81710673fa72eae1f639cb94fd8c9ab1df69a26 (patch)
treef325640e392cd7042446282aa256df38f66d34ae /debian
parentef27f0a103736cd0764bfb93f1a5c6e606c345d7 (diff)
downloadtde-packaging-c81710673fa72eae1f639cb94fd8c9ab1df69a26.tar.gz
tde-packaging-c81710673fa72eae1f639cb94fd8c9ab1df69a26.zip
Switch k3b-i18n to cmake on Debian and Ubuntu
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'debian')
-rw-r--r--debian/lenny/applications/k3b-i18n/debian/control2
-rwxr-xr-xdebian/lenny/applications/k3b-i18n/debian/rules127
-rw-r--r--debian/squeeze/applications/k3b-i18n/debian/control2
-rwxr-xr-xdebian/squeeze/applications/k3b-i18n/debian/rules127
4 files changed, 22 insertions, 236 deletions
diff --git a/debian/lenny/applications/k3b-i18n/debian/control b/debian/lenny/applications/k3b-i18n/debian/control
index 8086e9390..a5f371572 100644
--- a/debian/lenny/applications/k3b-i18n/debian/control
+++ b/debian/lenny/applications/k3b-i18n/debian/control
@@ -3,7 +3,7 @@ Section: tde
Priority: optional
Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
Uploaders: Francois Marier <francois@debian.org>, Fathi Boudra <fabo@debian.org>
-Build-Depends: debhelper (>= 6), quilt, automake, autoconf, libtool, libltdl-dev
+Build-Depends: debhelper (>= 6), cdbs, quilt, cmake
Build-Depends-Indep: tdelibs14-trinity-dev
Standards-Version: 3.8.3
diff --git a/debian/lenny/applications/k3b-i18n/debian/rules b/debian/lenny/applications/k3b-i18n/debian/rules
index 87d47158c..b39ae7f08 100755
--- a/debian/lenny/applications/k3b-i18n/debian/rules
+++ b/debian/lenny/applications/k3b-i18n/debian/rules
@@ -1,124 +1,17 @@
#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
-
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
- DEB_PARALLEL_JOBS ?= $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
-endif
-DEB_MAKE_PARALLEL ?= $(and $(DEB_BUILD_PARALLEL),$(DEB_PARALLEL_JOBS),-j$(DEB_PARALLEL_JOBS))
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF"
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
- INSTALL_PROGRAM += -s
-endif
-
-config.status: configure
- dh_testdir
-
-configure:
- dh_testdir
-
- # Regenerate build system
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
-
- # Add here commands to configure the package.
- ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
- --prefix=$(DEB_CONFIGURE_PREFIX) \
- --mandir=$(DEB_CONFIGURE_MANDIR) \
- --infodir=$(DEB_CONFIGURE_INFODIR)
-
-
-build: build-stamp
-
-build-stamp: config.status
- dh_testdir
-
- # Add here commands to compile the package.
- $(MAKE) $(DEB_MAKE_PARALLEL)
- #/usr/bin/docbook-to-man debian/k3b-i18n.sgml > k3b-i18n.1
-
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
-
- # Add here commands to clean up after the build process.
- [ ! -f Makefile ] || $(MAKE) distclean
-ifneq "$(wildcard /usr/share/misc/config.sub)" ""
- cp -f /usr/share/misc/config.sub config.sub
-endif
-ifneq "$(wildcard /usr/share/misc/config.guess)" ""
- cp -f /usr/share/misc/config.guess config.guess
-endif
-
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- # Add here commands to install the package into debian/k3b-i18n-trinity.
- $(MAKE) install DESTDIR=$(CURDIR)/debian/k3b-i18n-trinity $(DEB_MAKE_PARALLEL)
- mkdir -p $(CURDIR)/debian/k3b-i18n-trinity$(DEB_CONFIGURE_PREFIX)/share/doc/tde/
-
-# Build architecture-independent files here.
-binary-indep: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs
- dh_installdocs
- dh_installexamples
- dh_installman
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb $(DEB_DH_BUILDDEB_ARGS)
-
-# Build architecture-dependent files here.
-binary-arch: build install
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
diff --git a/debian/squeeze/applications/k3b-i18n/debian/control b/debian/squeeze/applications/k3b-i18n/debian/control
index 3c7c3f0aa..a5f371572 100644
--- a/debian/squeeze/applications/k3b-i18n/debian/control
+++ b/debian/squeeze/applications/k3b-i18n/debian/control
@@ -3,7 +3,7 @@ Section: tde
Priority: optional
Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
Uploaders: Francois Marier <francois@debian.org>, Fathi Boudra <fabo@debian.org>
-Build-Depends: debhelper (>= 6), cdbs, quilt, automake, autoconf, libtool, libltdl-dev
+Build-Depends: debhelper (>= 6), cdbs, quilt, cmake
Build-Depends-Indep: tdelibs14-trinity-dev
Standards-Version: 3.8.3
diff --git a/debian/squeeze/applications/k3b-i18n/debian/rules b/debian/squeeze/applications/k3b-i18n/debian/rules
index 87d47158c..b39ae7f08 100755
--- a/debian/squeeze/applications/k3b-i18n/debian/rules
+++ b/debian/squeeze/applications/k3b-i18n/debian/rules
@@ -1,124 +1,17 @@
#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
-
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
- DEB_PARALLEL_JOBS ?= $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
-endif
-DEB_MAKE_PARALLEL ?= $(and $(DEB_BUILD_PARALLEL),$(DEB_PARALLEL_JOBS),-j$(DEB_PARALLEL_JOBS))
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF"
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
- INSTALL_PROGRAM += -s
-endif
-
-config.status: configure
- dh_testdir
-
-configure:
- dh_testdir
-
- # Regenerate build system
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
-
- # Add here commands to configure the package.
- ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
- --prefix=$(DEB_CONFIGURE_PREFIX) \
- --mandir=$(DEB_CONFIGURE_MANDIR) \
- --infodir=$(DEB_CONFIGURE_INFODIR)
-
-
-build: build-stamp
-
-build-stamp: config.status
- dh_testdir
-
- # Add here commands to compile the package.
- $(MAKE) $(DEB_MAKE_PARALLEL)
- #/usr/bin/docbook-to-man debian/k3b-i18n.sgml > k3b-i18n.1
-
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
-
- # Add here commands to clean up after the build process.
- [ ! -f Makefile ] || $(MAKE) distclean
-ifneq "$(wildcard /usr/share/misc/config.sub)" ""
- cp -f /usr/share/misc/config.sub config.sub
-endif
-ifneq "$(wildcard /usr/share/misc/config.guess)" ""
- cp -f /usr/share/misc/config.guess config.guess
-endif
-
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- # Add here commands to install the package into debian/k3b-i18n-trinity.
- $(MAKE) install DESTDIR=$(CURDIR)/debian/k3b-i18n-trinity $(DEB_MAKE_PARALLEL)
- mkdir -p $(CURDIR)/debian/k3b-i18n-trinity$(DEB_CONFIGURE_PREFIX)/share/doc/tde/
-
-# Build architecture-independent files here.
-binary-indep: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs
- dh_installdocs
- dh_installexamples
- dh_installman
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb $(DEB_DH_BUILDDEB_ARGS)
-
-# Build architecture-dependent files here.
-binary-arch: build install
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install