summaryrefslogtreecommitdiffstats
path: root/redhat
diff options
context:
space:
mode:
authorFran├žois Andriot <albator78@libertysurf.fr>2018-11-29 21:41:04 +0100
committerFran├žois Andriot <albator78@libertysurf.fr>2018-11-29 21:41:04 +0100
commit0e56ad76fb0f261074b12713c080647efb9501a0 (patch)
tree779c93669b19e59de237b5025c0db5955f4b0557 /redhat
parenta39a7f7dd5a2e7ca2c105ff6622bf0f75e10e590 (diff)
downloadtde-packaging-0e56ad76fb0f261074b12713c080647efb9501a0.tar.gz
tde-packaging-0e56ad76fb0f261074b12713c080647efb9501a0.zip
RPM: rename libqt3-jni package to libtqt3-jni
Diffstat (limited to 'redhat')
-rw-r--r--redhat/main/tdebindings/tdebindings-14.0.0.spec44
1 files changed, 25 insertions, 19 deletions
diff --git a/redhat/main/tdebindings/tdebindings-14.0.0.spec b/redhat/main/tdebindings/tdebindings-14.0.0.spec
index 5256a254d..4fb236edc 100644
--- a/redhat/main/tdebindings/tdebindings-14.0.0.spec
+++ b/redhat/main/tdebindings/tdebindings-14.0.0.spec
@@ -297,7 +297,7 @@ Group: System/Libraries
Requires: trinity-libdcop3-java = %{version}-%{release}
Requires: trinity-libdcop3-jni = %{version}-%{release}
Requires: trinity-libqt3-java = %{version}-%{release}
-Requires: trinity-libqt3-jni = %{version}-%{release}
+Requires: trinity-libtqt3-jni = %{version}-%{release}
Requires: trinity-libtrinity-java = %{version}-%{release}
Requires: trinity-libtrinity-jni = %{version}-%{release}
@@ -373,7 +373,7 @@ This package is part of the official TDE bindings module.
Summary: Java bindings for Qt [Trinity]
Group: System/Libraries
Requires: trinity-libdcop3-jni = %{version}-%{release}
-Requires: trinity-libqt3-jni = %{version}-%{release}
+Requires: trinity-libtqt3-jni = %{version}-%{release}
Requires: trinity-juic = %{version}-%{release}
%description -n trinity-libqt3-java
@@ -393,41 +393,47 @@ This package is part of the official TDE bindings module.
##########
-%package -n trinity-libqt3-jni
-Summary: Java bindings for Qt ( Native libraries ) [Trinity]
+%package -n trinity-libtqt3-jni
+Summary: Java bindings for TQt ( Native libraries ) [Trinity]
Group: System/Libraries
-%description -n trinity-libqt3-jni
+Obsoletes: trinity-libqt3-jni < %{version}-%{release}
+Provides: trinity-libqt3-jni = %{version}-%{release}
+
+%description -n trinity-libtqt3-jni
This package contains the shared libraries necessary to run Java
programs using the Java Qt bindings. Qt is a very popular GUI
toolkit, used by the TDE desktop environment.
This package is part of the official TDE bindings module.
-%files -n trinity-libqt3-jni
+%files -n trinity-libtqt3-jni
%defattr(-,root,root,-)
-%{tde_libdir}/libqtjavasupport.la
-%{tde_libdir}/libqtjavasupport.so.*
-%{tde_libdir}/jni/libqtjava.la
-%{tde_libdir}/jni/libqtjava.so.*
+%{tde_libdir}/lib*qtjavasupport.la
+%{tde_libdir}/lib*qtjavasupport.so.*
+%{tde_libdir}/jni/lib*qtjava.la
+%{tde_libdir}/jni/lib*qtjava.so.*
%doc qtjava/ChangeLog
##########
-%package -n trinity-libqt3-jni-devel
-Summary: Development files fo Java bindings for Qt ( Native libraries ) [Trinity]
+%package -n trinity-libtqt3-jni-devel
+Summary: Development files fo Java bindings for TQt ( Native libraries ) [Trinity]
Group: Development/Languages/Java
-Requires: trinity-libqt3-jni = %{version}-%{release}
+Requires: trinity-libtqt3-jni = %{version}-%{release}
+
+Obsoletes: trinity-libqt3-jni-devel < %{version}-%{release}
+Provides: trinity-libqt3-jni-devel = %{version}-%{release}
-%description -n trinity-libqt3-jni-devel
-This package contains the development files for trinity-libqt3-jni.
+%description -n trinity-libtqt3-jni-devel
+This package contains the development files for trinity-libtqt3-jni.
This package is part of the official TDE bindings module.
-%files -n trinity-libqt3-jni-devel
+%files -n trinity-libtqt3-jni-devel
%defattr(-,root,root,-)
-%{tde_libdir}/libqtjavasupport.so
-%{tde_libdir}/jni/libqtjava.so
+%{tde_libdir}/lib*qtjavasupport.so
+%{tde_libdir}/jni/lib*qtjava.so
##########
@@ -963,7 +969,7 @@ Requires: trinity-libsmoketde-devel = %{version}-%{release}
Requires: trinity-libkjsembed-devel = %{version}-%{release}
Requires: trinity-libxparts-devel = %{version}-%{release}
Requires: trinity-libdcop-c-devel = %{version}-%{release}
-Requires: trinity-libqt3-jni-devel = %{version}-%{release}
+Requires: trinity-libtqt3-jni-devel = %{version}-%{release}
Requires: trinity-libtrinity-jni-devel = %{version}-%{release}
%description devel