summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/tdeio-umountwrapper/debian
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2019-04-03 22:56:40 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2019-04-03 22:56:40 +0900
commit11394aecd1f906fee2ebd2b90412aeba4651fbff (patch)
treebcf750380e6d9fc7dbe524e16bbe2afde25dcfa0 /ubuntu/_base/applications/tdeio-umountwrapper/debian
parentd24bd898174453b586ac90f2ef7a60165fa26fde (diff)
downloadtde-packaging-11394aecd1f906fee2ebd2b90412aeba4651fbff.tar.gz
tde-packaging-11394aecd1f906fee2ebd2b90412aeba4651fbff.zip
DEB: use _base folder for a distro instead of specific distros (squeeze
and maverick). Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'ubuntu/_base/applications/tdeio-umountwrapper/debian')
-rw-r--r--ubuntu/_base/applications/tdeio-umountwrapper/debian/cdbs/debian-qt-kde.mk119
-rw-r--r--ubuntu/_base/applications/tdeio-umountwrapper/debian/cdbs/kde.mk91
-rw-r--r--ubuntu/_base/applications/tdeio-umountwrapper/debian/cdbs/versions.pl19
-rw-r--r--ubuntu/_base/applications/tdeio-umountwrapper/debian/changelog71
-rw-r--r--ubuntu/_base/applications/tdeio-umountwrapper/debian/compat1
-rw-r--r--ubuntu/_base/applications/tdeio-umountwrapper/debian/control17
-rw-r--r--ubuntu/_base/applications/tdeio-umountwrapper/debian/copyright30
-rw-r--r--ubuntu/_base/applications/tdeio-umountwrapper/debian/docs2
-rw-r--r--ubuntu/_base/applications/tdeio-umountwrapper/debian/install3
-rw-r--r--ubuntu/_base/applications/tdeio-umountwrapper/debian/media_safelyremove.desktop74
-rw-r--r--ubuntu/_base/applications/tdeio-umountwrapper/debian/patches/series0
-rw-r--r--ubuntu/_base/applications/tdeio-umountwrapper/debian/postrm56
-rw-r--r--ubuntu/_base/applications/tdeio-umountwrapper/debian/preinst92
-rwxr-xr-xubuntu/_base/applications/tdeio-umountwrapper/debian/rules20
-rw-r--r--ubuntu/_base/applications/tdeio-umountwrapper/debian/source/format1
-rw-r--r--ubuntu/_base/applications/tdeio-umountwrapper/debian/source/options6
16 files changed, 602 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/tdeio-umountwrapper/debian/cdbs/debian-qt-kde.mk b/ubuntu/_base/applications/tdeio-umountwrapper/debian/cdbs/debian-qt-kde.mk
new file mode 100644
index 000000000..60310a01a
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-umountwrapper/debian/cdbs/debian-qt-kde.mk
@@ -0,0 +1,119 @@
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
+ touch debian/stamp-cvs-make
+
+include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+clean::
+ifndef _cdbs_class_cmake
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+endif
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/ubuntu/_base/applications/tdeio-umountwrapper/debian/cdbs/kde.mk b/ubuntu/_base/applications/tdeio-umountwrapper/debian/cdbs/kde.mk
new file mode 100644
index 000000000..80176d63e
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-umountwrapper/debian/cdbs/kde.mk
@@ -0,0 +1,91 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Description: A class for KDE packages; sets KDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_class_kde
+_cdbs_class_kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+ifndef _cdbs_class_cmake
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+common-build-arch common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-arch common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+
+clean::
+ rm -f debian/stamp-kde-apidox
+
+# This is a convenience target for calling manually. It's not part of
+# the build process.
+buildprep: clean apply-patches
+ $(MAKE) -f admin/Makefile.common dist
+ debian/rules clean
+
+endif
diff --git a/ubuntu/_base/applications/tdeio-umountwrapper/debian/cdbs/versions.pl b/ubuntu/_base/applications/tdeio-umountwrapper/debian/cdbs/versions.pl
new file mode 100644
index 000000000..1b110f7af
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-umountwrapper/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "TDE-Version3=$version3\n";
+print "TDE-Version2=$version2\n";
+print "TDE-Next-Version3=$version3_next\n";
+print "TDE-Next-Version2=$version2_next\n";
diff --git a/ubuntu/_base/applications/tdeio-umountwrapper/debian/changelog b/ubuntu/_base/applications/tdeio-umountwrapper/debian/changelog
new file mode 100644
index 000000000..f33d0b302
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-umountwrapper/debian/changelog
@@ -0,0 +1,71 @@
+tdeio-umountwrapper-trinity (0.2-1ubuntu3) karmic; urgency=low
+
+ * Karmic rebuild
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 Jul 2009 16:08:00 -0600
+
+tdeio-umountwrapper-trinity (0.2-1ubuntu2) intrepid; urgency=low
+
+ * Moved Trinity to /opt/trinity
+ * Integrated properly with KDE4.2+
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 05 March 2009 29:52:00 -0600
+
+tdeio-umountwrapper-trinity (0.2-0ubuntu3) intrepid; urgency=low
+
+ * Added -trinity suffix
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 31 Dec 2008 14:46:00 -0600
+
+kio-umountwrapper (0.2-0ubuntu6.2) hardy-proposed; urgency=low
+
+ * Fix syntax in postrm
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Wed, 27 Aug 2008 00:00:03 +0100
+
+kio-umountwrapper (0.2-0ubuntu6.1) hardy-proposed; urgency=low
+
+ * debian/preinst, debian/postrm: make sure than the directories used by
+ dpkg-divert exist
+
+ -- Gauvain Pocentek <gauvain@ulteo.com> Sun, 29 Jun 2008 11:06:10 +0200
+
+kio-umountwrapper (0.2-0ubuntu6) hardy; urgency=low
+
+ * Update from Jan Klötzke to also support encrypted removable drives
+ correctly, closes LP: #186841
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Wed, 06 Feb 2008 16:04:46 +0000
+
+kio-umountwrapper (0.2-0ubuntu5) hardy; urgency=low
+
+ * Do not try to divert /usr/../dolphin/../media_safelyremove.desktop,
+ since dolphin doesn't install that anymore. (LP: #183292)
+
+ -- Timo Aaltonen <tepsipakki@ubuntu.com> Mon, 28 Jan 2008 13:28:39 +0200
+
+kio-umountwrapper (0.2-0ubuntu4) hardy; urgency=low
+
+ * Fix build failure with g++-4.3.
+
+ -- Matthias Klose <doko@ubuntu.com> Thu, 24 Jan 2008 09:44:46 +0000
+
+kio-umountwrapper (0.2-0ubuntu3) gutsy; urgency=low
+
+ * Add kdepot patch for translations.
+ * Change maintainer to Ubuntu Core Dev.
+
+ -- Frode M. Døving <frode@ubuntu.com> Mon, 23 Jul 2007 00:00:21 +0200
+
+kio-umountwrapper (0.2-0ubuntu2) gutsy; urgency=low
+
+ * Add d3lphin support, as the dolphin package in gutsy is actually patched
+ to become d3lphin.
+
+ -- Frode M. Døving <frode@ubuntu.com> Sun, 22 Jul 2007 22:40:54 +0200
+
+kio-umountwrapper (0.2-0ubuntu1) gutsy; urgency=low
+
+ * Initial release.
+
+ -- Frode M. Døving <frode@ubuntu.com> Thu, 31 May 2007 14:05:33 +0200
diff --git a/ubuntu/_base/applications/tdeio-umountwrapper/debian/compat b/ubuntu/_base/applications/tdeio-umountwrapper/debian/compat
new file mode 100644
index 000000000..7f8f011eb
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-umountwrapper/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/ubuntu/_base/applications/tdeio-umountwrapper/debian/control b/ubuntu/_base/applications/tdeio-umountwrapper/debian/control
new file mode 100644
index 000000000..ed8a42aae
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-umountwrapper/debian/control
@@ -0,0 +1,17 @@
+Source: tdeio-umountwrapper-trinity
+Section: tde
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+Build-Depends: debhelper (>= 7.0.50~), quilt, cdbs, cmake, tdelibs14-trinity-dev
+Standards-Version: 3.8.4
+
+Package: tdeio-umountwrapper-trinity
+Architecture: any
+Depends: ${shlibs:Depends}
+Replaces: kio-umountwrapper-kde3 (<< 4:14.0.0~), kio-umountwrapper-trinity (<< 4:14.0.0~)
+Breaks: kio-umountwrapper-kde3 (<< 4:14.0.0~), kio-umountwrapper-trinity (<< 4:14.0.0~)
+Description: progress dialog for safely removing devices in Trinity.
+ Wrapper around tdeio_media_mountwrapper.
+ Provides a progress dialog for Safely Removing of devices in Trinity.
+ .
+ Homepage: http://frode.kde.no/misc/tdeio_umountwrapper/
diff --git a/ubuntu/_base/applications/tdeio-umountwrapper/debian/copyright b/ubuntu/_base/applications/tdeio-umountwrapper/debian/copyright
new file mode 100644
index 000000000..08e471ac6
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-umountwrapper/debian/copyright
@@ -0,0 +1,30 @@
+This package was debianized by Frode M. Dving <frode@lnix.net>
+on Tue, 10-May-2007 20:55:10 +0200
+
+Upstream authors are
+
+ Frode M. Dving <frode@lnix.net>
+
+License:
+
+ All files are licenced GPL v2 or later
+
+ This program is free software; you can redistribute it and/or
+ modify it under the terms of the GNU General Public
+ License as published by the Free Software Foundation; either
+ version 2 of the License, or (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
+
+ On Debian GNU/Linux systems, the complete text of the GNU General
+ Public License can be found in `/usr/share/common-licenses/GPL'.
+
+ The Debian packaging is under the same license as the program.
+
diff --git a/ubuntu/_base/applications/tdeio-umountwrapper/debian/docs b/ubuntu/_base/applications/tdeio-umountwrapper/debian/docs
new file mode 100644
index 000000000..6f12db508
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-umountwrapper/debian/docs
@@ -0,0 +1,2 @@
+AUTHORS
+README
diff --git a/ubuntu/_base/applications/tdeio-umountwrapper/debian/install b/ubuntu/_base/applications/tdeio-umountwrapper/debian/install
new file mode 100644
index 000000000..e9c5b29fb
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-umountwrapper/debian/install
@@ -0,0 +1,3 @@
+debian/media_safelyremove.desktop /opt/trinity/share/apps/konqueror/servicemenus
+debian/media_safelyremove.desktop /opt/trinity/share/apps/dolphin/servicemenus
+debian/media_safelyremove.desktop /opt/trinity/share/apps/d3lphin/servicemenus
diff --git a/ubuntu/_base/applications/tdeio-umountwrapper/debian/media_safelyremove.desktop b/ubuntu/_base/applications/tdeio-umountwrapper/debian/media_safelyremove.desktop
new file mode 100644
index 000000000..38fa25d92
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-umountwrapper/debian/media_safelyremove.desktop
@@ -0,0 +1,74 @@
+[Desktop Entry]
+ServiceTypes=media/removable_mounted,media/removable_mounted_decrypted,media/removable_unmounted,media/removable_unmounted_decrypted,media/camera_mounted,media/camera_unmounted
+Actions=MediaSafelyRemove;
+X-TDE-Priority=TopLevel
+X-TDE-MediaNotifierHide=true
+
+[Desktop Action MediaSafelyRemove]
+Name=Safely Remove
+Name[af]=Verwyder veilig
+Name[ar]=أحذف بأمان
+Name[be]=Бяспечна адлучыць
+Name[bg]=Безопасно изваждане
+Name[bn]=নিরাপদভাবে সরাও
+Name[bs]=Sigurno ukloni
+Name[ca]=Extreu amb seguretat
+Name[cs]=Bezpečně odstranit
+Name[csb]=Remôj na bezpieczny ôrt
+Name[da]=Fjern sikkert
+Name[de]=Sicher entfernen
+Name[el]=Ασφαλής αφαίρεση
+Name[eo]=Sekura Forigo
+Name[es]=Extracción segura
+Name[et]=Eemalda turvaliselt
+Name[eu]=Atera arriskurik gabe
+Name[fa]=حذف امن
+Name[fi]=Poista turvallisesti
+Name[fr]=Enlever en toute sécurité
+Name[fy]=Feilich ferwiderje
+Name[ga]=Bain Amach go Sábháilte
+Name[gl]=Eliminar de Maneira Segura
+Name[he]=שליפה בבטחה
+Name[hr]=Slobodno uklonite
+Name[hu]=Biztonságos leválasztás
+Name[is]=Fjarlægja öruggt
+Name[it]=Rimozione sicura
+Name[ja]=安全に取り除く
+Name[kk]=Қауіпсіз алып шығу
+Name[km]=យកចេញ​ដោយ​សុវត្ថិភាព
+Name[lt]=Saugiai pašalinti
+Name[mk]=Безбедно отстрани
+Name[ms]=Buang Dengan Selamat
+Name[nb]=Sikker fjerning
+Name[nds]=Seker rutnehmen
+Name[ne]=सुरक्षीत रुपमा हटाउनुहोस्
+Name[nl]=Veilig verwijderen
+Name[nn]=Trygg fjerning
+Name[pa]=ਸੁਰੱਖਿਅਤ ਹਟਾਓ
+Name[pl]=Usuń w sposób bezpieczny
+Name[pt]=Retirar com Segurança
+Name[pt_BR]=Remover de Modo Seguro
+Name[ro]=Scoate în siguranță
+Name[ru]=Безопасно извлечь
+Name[rw]=Gukuramo Neza
+Name[se]=Dorvvošlaš eretváldin
+Name[sk]=Bezpečne odpojiť
+Name[sl]=Varno odstrani
+Name[sr]=Безбедно уклони
+Name[sr@Latn]=Bezbedno ukloni
+Name[sv]=Säker urkoppling
+Name[ta]=பாதுகாப்பாக நீக்கு
+Name[te]=జాగరత్తగా తియి
+Name[tg]=Баровардани бехетар
+Name[th]=ถอดออกอย่างปลอดภัย
+Name[tr]=Güvenli Kaldır
+Name[tt]=İmin Çığaru
+Name[uk]=Безпечно вилучити
+Name[uz]=Эҳтиётлик билан узиш
+Name[vi]=Gỡ ra An toàn
+Name[wa]=Ositer e såvrité
+Name[zh_CN]=安全删除
+Name[zh_TW]=安全的移除
+Exec=tdeio_umountwrapper %u
+
+X-Ubuntu-Gettext-Domain=desktop_tdebase
diff --git a/ubuntu/_base/applications/tdeio-umountwrapper/debian/patches/series b/ubuntu/_base/applications/tdeio-umountwrapper/debian/patches/series
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-umountwrapper/debian/patches/series
diff --git a/ubuntu/_base/applications/tdeio-umountwrapper/debian/postrm b/ubuntu/_base/applications/tdeio-umountwrapper/debian/postrm
new file mode 100644
index 000000000..705c5b806
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-umountwrapper/debian/postrm
@@ -0,0 +1,56 @@
+#! /bin/sh
+# -*- Mode: Sh -*-
+# Author: Frode M. Døving <frode@lnix.net> (C) 2007
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+#
+
+set -e
+
+package_name=tdeio-umountwrapper-trinity
+
+# make sure than the directories exist before running dpkg-divert
+mkdir -p /opt/trinity/share/apps/konqueror/servicemenus/
+mkdir -p /opt/trinity/share/apps/dolphin/servicemenus/
+mkdir -p /opt/trinity/share/apps/d3lphin/servicemenus/
+
+case "$1" in
+ remove)
+ dpkg-divert --package $package_name --rename --remove \
+ /opt/trinity/share/apps/konqueror/servicemenus/media_safelyremove.desktop
+
+ dpkg-divert --package $package_name --rename --remove \
+ /opt/trinity/share/apps/dolphin/servicemenus/media_safelyremove.desktop
+
+ dpkg-divert --package $package_name --rename --remove \
+ /opt/trinity/share/apps/d3lphin/servicemenus/media_safelyremove.desktop
+
+ # try to remove the dirs we've created for pkg-divert
+ rmdir --ignore-fail-on-non-empty /opt/trinity/share/apps/konqueror/servicemenus/
+ rmdir --ignore-fail-on-non-empty /opt/trinity/share/apps/dolphin/servicemenus/
+ rmdir --ignore-fail-on-non-empty /opt/trinity/share/apps/d3lphin/servicemenus/
+ ;;
+
+ upgrade)
+ exit 0
+ ;;
+
+ *) echo "$0: didn't understand being called with \`$1'" 1>&2
+ exit 0;;
+esac
+
+#DEBHELPER#
+
+exit 0
diff --git a/ubuntu/_base/applications/tdeio-umountwrapper/debian/preinst b/ubuntu/_base/applications/tdeio-umountwrapper/debian/preinst
new file mode 100644
index 000000000..0b210a270
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-umountwrapper/debian/preinst
@@ -0,0 +1,92 @@
+#! /bin/sh
+# -*- Mode: Sh -*-
+# Author: Frode M. Døving <frode@lnix.net> (C) 2007
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+#
+#
+
+set -e
+
+package_name=tdeio-umountwrapper-trinity
+
+# make sure than the directories exist before running dpkg-divert
+mkdir -p /opt/trinity/share/apps/konqueror/servicemenus/
+mkdir -p /opt/trinity/share/apps/dolphin/servicemenus/
+mkdir -p /opt/trinity/share/apps/d3lphin/servicemenus/
+
+case "$1" in
+ install)
+ # remove old diversions if present
+ divert=`dpkg-divert --listpackage "/opt/trinity/share/apps/konqueror/servicemenus/media_safelyremove.desktop"`
+ if [ -n "$divert" ] && [ "$divert" = "kio-umountwrapper-trinity" ]; then
+ dpkg-divert --package kio-umountwrapper-trinity --rename --remove /opt/trinity/share/apps/konqueror/servicemenus/media_safelyremove.desktop
+ fi
+ divert=`dpkg-divert --listpackage "/opt/trinity/share/apps/dolphin/servicemenus/media_safelyremove.desktop"`
+ if [ -n "$divert" ] && [ "$divert" = "kio-umountwrapper-trinity" ]; then
+ dpkg-divert --package kio-umountwrapper-trinity --rename --remove /opt/trinity/share/apps/dolphin/servicemenus/media_safelyremove.desktop
+ fi
+ divert=`dpkg-divert --listpackage "/opt/trinity/share/apps/d3lphin/servicemenus/media_safelyremove.desktop"`
+ if [ -n "$divert" ] && [ "$divert" = "kio-umountwrapper-trinity" ]; then
+ dpkg-divert --package kio-umountwrapper-trinity --rename --remove /opt/trinity/share/apps/d3lphin/servicemenus/media_safelyremove.desktop
+ fi
+
+ # add new diversions
+ dpkg-divert --package $package_name \
+ --divert /opt/trinity/share/apps/konqueror/servicemenus/media_safelyremove.desktop.distrib \
+ --rename /opt/trinity/share/apps/konqueror/servicemenus/media_safelyremove.desktop
+
+ dpkg-divert --package $package_name \
+ --divert /opt/trinity/share/apps/dolphin/servicemenus/media_safelyremove.desktop.distrib \
+ --rename /opt/trinity/share/apps/dolphin/servicemenus/media_safelyremove.desktop
+
+ dpkg-divert --package $package_name \
+ --divert /opt/trinity/share/apps/d3lphin/servicemenus/media_safelyremove.desktop.distrib \
+ --rename /opt/trinity/share/apps/d3lphin/servicemenus/media_safelyremove.desktop
+
+ ;;
+ upgrade)
+ divert=`dpkg-divert --listpackage "/opt/trinity/share/apps/konqueror/servicemenus/media_safelyremove.desktop"`
+ if [ -z "$divert" ]; then
+ dpkg-divert --package $package_name \
+ --divert /opt/trinity/share/apps/konqueror/servicemenus/media_safelyremove.desktop.distrib \
+ --rename /opt/trinity/share/apps/konqueror/servicemenus/media_safelyremove.desktop
+ fi
+
+ divert=`dpkg-divert --listpackage "/opt/trinity/share/apps/dolphin/servicemenus/media_safelyremove.desktop"`
+ if [ -z "$divert" ]; then
+ dpkg-divert --package $package_name \
+ --divert /opt/trinity/share/apps/dolphin/servicemenus/media_safelyremove.desktop.distrib \
+ --rename /opt/trinity/share/apps/dolphin/servicemenus/media_safelyremove.desktop
+ fi
+
+ divert=`dpkg-divert --listpackage "/opt/trinity/share/apps/d3lphin/servicemenus/media_safelyremove.desktop"`
+ if [ -z "$divert" ]; then
+ dpkg-divert --package $package_name \
+ --divert /opt/trinity/share/apps/d3lphin/servicemenus/media_safelyremove.desktop.distrib \
+ --rename /opt/trinity/share/apps/d3lphin/servicemenus/media_safelyremove.desktop
+ fi
+
+ exit 0
+ ;;
+
+ *) echo "$0: didn't understand being called with \`$1'" 1>&2
+ exit 0
+ ;;
+esac
+
+#DEBHELPER#
+
+exit 0
diff --git a/ubuntu/_base/applications/tdeio-umountwrapper/debian/rules b/ubuntu/_base/applications/tdeio-umountwrapper/debian/rules
new file mode 100755
index 000000000..18b1c07e2
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-umountwrapper/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include debian/cdbs/debian-qt-kde.mk
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"
diff --git a/ubuntu/_base/applications/tdeio-umountwrapper/debian/source/format b/ubuntu/_base/applications/tdeio-umountwrapper/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-umountwrapper/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/ubuntu/_base/applications/tdeio-umountwrapper/debian/source/options b/ubuntu/_base/applications/tdeio-umountwrapper/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/ubuntu/_base/applications/tdeio-umountwrapper/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*