summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/abakus/debian
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-28 15:25:23 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-28 15:25:23 -0600
commit971b00b04e026f6115aa1155b483a12f1768e2be (patch)
tree9b1285a7b189b3b80a912ccd5a676c81334223c9 /ubuntu/maverick/applications/abakus/debian
parent6c7c61327875a1f75b5756189acca554b33ae26b (diff)
downloadtde-packaging-971b00b04e026f6115aa1155b483a12f1768e2be.tar.gz
tde-packaging-971b00b04e026f6115aa1155b483a12f1768e2be.zip
Fix abakus build on Debian and Ubuntu
Diffstat (limited to 'ubuntu/maverick/applications/abakus/debian')
-rwxr-xr-xubuntu/maverick/applications/abakus/debian/rules15
1 files changed, 14 insertions, 1 deletions
diff --git a/ubuntu/maverick/applications/abakus/debian/rules b/ubuntu/maverick/applications/abakus/debian/rules
index 8041bcf1e..10ec1e1b3 100755
--- a/ubuntu/maverick/applications/abakus/debian/rules
+++ b/ubuntu/maverick/applications/abakus/debian/rules
@@ -23,4 +23,17 @@ DEB_CMAKE_EXTRA_FLAGS := -DLIB_SUFFIX="" -DCMAKE_INSTALL_PREFIX="/opt/trinity" -
# Honour "parallel=N" option of DEB_BUILD_OPTIONS. Comment out to
# never build in parallel, regardless of DEB_BUILD_OPTIONS.
-DEB_BUILD_PARALLEL = true \ No newline at end of file
+DEB_BUILD_PARALLEL = true
+
+debian/abakus.xpm: icons/hi64-app-abakus.png
+ convert -resize 32 $< $@
+
+common-build-arch:: debian/abakus.xpm
+
+common-install-arch::
+ install -D -m 644 debian/abakus.xpm debian/abakus-trinity/opt/trinity/share/pixmaps/abakus.xpm
+ chrpath -d debian/abakus-trinity/opt/trinity/bin/abakus
+ dh_icons -pabakus
+
+clean::
+ rm -f debian/abakus.xpm