summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/filelight/debian
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2019-04-03 22:56:40 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2019-04-03 22:56:40 +0900
commit11394aecd1f906fee2ebd2b90412aeba4651fbff (patch)
treebcf750380e6d9fc7dbe524e16bbe2afde25dcfa0 /ubuntu/maverick/applications/filelight/debian
parentd24bd898174453b586ac90f2ef7a60165fa26fde (diff)
downloadtde-packaging-11394aecd1f906fee2ebd2b90412aeba4651fbff.tar.gz
tde-packaging-11394aecd1f906fee2ebd2b90412aeba4651fbff.zip
DEB: use _base folder for a distro instead of specific distros (squeeze
and maverick). Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'ubuntu/maverick/applications/filelight/debian')
-rw-r--r--ubuntu/maverick/applications/filelight/debian/cdbs/debian-qt-kde.mk119
-rw-r--r--ubuntu/maverick/applications/filelight/debian/cdbs/kde.mk91
-rw-r--r--ubuntu/maverick/applications/filelight/debian/cdbs/versions.pl19
-rw-r--r--ubuntu/maverick/applications/filelight/debian/changelog197
-rw-r--r--ubuntu/maverick/applications/filelight/debian/compat1
-rw-r--r--ubuntu/maverick/applications/filelight/debian/control22
-rw-r--r--ubuntu/maverick/applications/filelight/debian/copyright42
-rw-r--r--ubuntu/maverick/applications/filelight/debian/filelight.163
-rw-r--r--ubuntu/maverick/applications/filelight/debian/menu6
-rw-r--r--ubuntu/maverick/applications/filelight/debian/patches/series0
-rwxr-xr-xubuntu/maverick/applications/filelight/debian/rules32
-rw-r--r--ubuntu/maverick/applications/filelight/debian/source/format1
-rw-r--r--ubuntu/maverick/applications/filelight/debian/source/options6
13 files changed, 0 insertions, 599 deletions
diff --git a/ubuntu/maverick/applications/filelight/debian/cdbs/debian-qt-kde.mk b/ubuntu/maverick/applications/filelight/debian/cdbs/debian-qt-kde.mk
deleted file mode 100644
index 60310a01a..000000000
--- a/ubuntu/maverick/applications/filelight/debian/cdbs/debian-qt-kde.mk
+++ /dev/null
@@ -1,119 +0,0 @@
-ifndef _cdbs_bootstrap
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-endif
-
-ifndef _cdbs_class_debian-qt-kde
-_cdbs_class_debian-qt-kde := 1
-
-# Note: This _must_ be included before autotools.mk, or it won't work.
-common-configure-arch common-configure-indep:: debian/stamp-cvs-make
-debian/stamp-cvs-make:
-ifndef _cdbs_class_cmake
- cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
-endif
- touch debian/stamp-cvs-make
-
-include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
-
-ifndef _cdbs_rules_patchsys_quilt
-DEB_PATCHDIRS := debian/patches/common debian/patches
-endif
-
-DEB_KDE_ENABLE_FINAL := yes
-DEB_INSTALL_DOCS_ALL :=
-
-DEB_DH_MAKESHLIBS_ARGS_ALL := -V
-DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
-
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
- ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
- else
- cdbs_kde_enable_final =
- endif
-endif
-
-common-build-arch:: debian/stamp-man-pages
-debian/stamp-man-pages:
- if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
- for f in $$(find debian/man -name '*.sgml'); do \
- docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
- done
- for f in $$(find debian/man -name '*.man'); do \
- soelim -I debian/man $$f \
- > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
- done
- touch debian/stamp-man-pages
-
-common-binary-indep::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_INDEP_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-common-binary-arch::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_ARCH_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-clean::
- rm -rf debian/man/out
- -rmdir debian/man
- rm -f debian/stamp-man-pages
- rm -rf debian/shlibs-check
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
- if test -e debian/$(cdbs_curpkg).lintian; then \
- install -p -D -m644 debian/$(cdbs_curpkg).lintian \
- debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
- fi
- if test -e debian/$(cdbs_curpkg).presubj; then \
- install -p -D -m644 debian/$(cdbs_curpkg).presubj \
- debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
- fi
-
-binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
- set -e; \
- for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
- pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
- echo Building $$pkg HTML docs...; \
- mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
- done
- for pkg in $(DOC_HTML_PRUNE) ; do \
- rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- done
-
-clean::
-ifndef _cdbs_class_cmake
- if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
- cd $(DEB_SRCDIR); \
- find . -name Makefile.in -print | \
- xargs --no-run-if-empty rm -f; \
- rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
- configure configure.files configure.in stamp-h.in \
- subdirs; \
- fi
-endif
- rm -f debian/stamp-cvs-make
-
-endif
diff --git a/ubuntu/maverick/applications/filelight/debian/cdbs/kde.mk b/ubuntu/maverick/applications/filelight/debian/cdbs/kde.mk
deleted file mode 100644
index 80176d63e..000000000
--- a/ubuntu/maverick/applications/filelight/debian/cdbs/kde.mk
+++ /dev/null
@@ -1,91 +0,0 @@
-# -*- mode: makefile; coding: utf-8 -*-
-# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
-# Description: A class for KDE packages; sets KDE environment variables, etc
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-# 02111-1307 USA.
-
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-
-ifndef _cdbs_class_kde
-_cdbs_class_kde := 1
-
-# for dh_icons
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
-
-include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
-
-ifdef _cdbs_tarball_dir
-DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
-else
-DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
-endif
-
-ifndef _cdbs_class_cmake
-include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
-endif
-
-export kde_cgidir = \$${libdir}/cgi-bin
-export kde_confdir = \$${sysconfdir}/trinity
-export kde_htmldir = \$${datadir}/doc/tde/HTML
-
-ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
-endif
-
-ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final =
- cdbs_kde_enable_debug = --enable-debug=yes
-else
- cdbs_kde_enable_debug = --disable-debug
-endif
-
-ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_debug = --enable-debug=full
-endif
-
-cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
-
-cleanbuilddir::
- -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
-
-common-build-arch common-build-indep:: debian/stamp-kde-apidox
-debian/stamp-kde-apidox:
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
- touch $@
-
-common-install-arch common-install-indep:: common-install-kde-apidox
-common-install-kde-apidox::
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
-
-clean::
- rm -f debian/stamp-kde-apidox
-
-# This is a convenience target for calling manually. It's not part of
-# the build process.
-buildprep: clean apply-patches
- $(MAKE) -f admin/Makefile.common dist
- debian/rules clean
-
-endif
diff --git a/ubuntu/maverick/applications/filelight/debian/cdbs/versions.pl b/ubuntu/maverick/applications/filelight/debian/cdbs/versions.pl
deleted file mode 100644
index 1b110f7af..000000000
--- a/ubuntu/maverick/applications/filelight/debian/cdbs/versions.pl
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/env perl
-
-use strict;
-use warnings;
-
-my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
-my ($version3, $version3_next);
-my ($version2, $version2_next);
-
-($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
-($version2 = $version3) =~ s/\.[^.]+$//;
-
-($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
-($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
-
-print "TDE-Version3=$version3\n";
-print "TDE-Version2=$version2\n";
-print "TDE-Next-Version3=$version3_next\n";
-print "TDE-Next-Version2=$version2_next\n";
diff --git a/ubuntu/maverick/applications/filelight/debian/changelog b/ubuntu/maverick/applications/filelight/debian/changelog
deleted file mode 100644
index d59a45c8e..000000000
--- a/ubuntu/maverick/applications/filelight/debian/changelog
+++ /dev/null
@@ -1,197 +0,0 @@
-filelight-trinity (1.0-2ubuntu5) karmic; urgency=low
-
- * Karmic rebuild
-
- -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 Jul 2009 16:08:00 -0600
-
-filelight-trinity (1.0-2ubuntu4) intrepid; urgency=low
-
- * Moved Trinity to /opt/trinity
- * Integrated properly with KDE4.2+
-
- -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 04 March 2009 01:11:00 -0600
-
-filelight-trinity (1.0-2ubuntu3) intrepid; urgency=low
-
- * Added -trinity suffix
-
- -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Mon, 09 Feb 2009 10:27:00 -0600
-
-filelight (1.0-2ubuntu2) intrepid; urgency=low
-
- * Remove documentation, it conflicts with the -l10n package (LP: #245974)
-
- -- Harald Sitter <apachelogger@ubuntu.com> Sun, 24 Aug 2008 00:56:23 +0200
-
-filelight (1.0-2ubuntu1) intrepid; urgency=low
-
- * Merge from debian unstable, remaining changes:
- - Changed Maintainer field per spec
- - debian/rules: prevent the installation of locale files (they are provided
- by the filelight-l10n package)
- - debian/patches
- + Don't merge patches which change any Makefile.in, they
- would break.
-
- -- Harald Sitter <apachelogger@ubuntu.com> Wed, 07 May 2008 10:00:29 +0100
-
-filelight (1.0-2) unstable; urgency=low
-
- * 'man filelight' typos: "representating", "filesystem" and
- "diskspace" (Closes: #452618). Thanks to A. Costa.
- * Update policy to 3.7.3. No changes needed.
- * Fixed Vcs-Svn and VCs-Browser fields.
- * Reordered CDBS build rules and removing autotools.mk since it clashes with
- kde.mk.
- * Moving to quilt patch system.
- * Removed dpatch comments from 10_fix-filelight.desktop
- * Reworked buildsystem: added patches 98_buildprep; removed
- 01_configure-update, 02_dist-files and 07_install-radial-map.diff; updated
- 05_fPIX_radialmap_part.
- * Removed watch file.
-
- -- Raúl Sánchez Siles <rasasi78@gmail.com> Tue, 06 May 2008 17:10:35 +0200
-
-filelight (1.0-1) unstable; urgency=low
-
- * New upstream release: Crashes fix, displaying non-latin1 correctly and
- several new features. (Closes: #445935, #424741)
- * Splitted l10n to a new package.
- * Bugs closed:
- + filelight always places hover information on first monitor (Closes:
- #255896)
- + filelight doesn't handle utf-8 files (Closes: #256423)
- + always crashing on exit (Closes: #404460)
- + bug in filelight - crash on exit (Closes: #356626)
- + glibc detects free() of invalid pointer on exit (Closes: #343903)
- + memory usage is obscene (Closes: #231399)
- + lots of noise on stderr from RadialMap methods (Closes: #343905)
- + very large files and directories lead to confusion (Closes: #393827)
- + Filelight ignores large files (Closes: #341680)
- + Piles of WARNING messages on startup, but it works. (Closes:
- #307717)
- + filelight lacks a manpage [patch] (Closes: #414934). Thanks to
- James R. Van Zandt.
- + Spelling mistake in package description (Closes: #363410). Thanks to
- James Westby.
- + please build with --disable-debug to prevent spurious stdout-output
- (Closes: #408554)
- + filelight(GNU/k*BSD): FTBFS: out of date config.sub/config.guess
- (Closes: #304605)
- + lots of noise on stderr from RadialMap methods (Closes: #343905)
- * Packaging issues:
- + Changed packaging to CDBS.
- + Provide upstream AUTHORS file.
- + Honour the nostrip in the DEB_BUILD_OPTIONS. (Closes: #436852)
- + Changed menu section to Applications/File Management to comply with newer
- menu policy.
- + Implemented dpatch, avoiding direct upstream patching(ugly).
- + please remove old editor backup files from diff (Closes: #354706)
- + Update package policy to latest 3.7.2.
- + Change Uploader(me) and Maintainers(Debian KDE Extras Team).
-
- -- Raúl Sánchez Siles <rasasi78@gmail.com> Fri, 16 Nov 2007 19:20:42 +0100
-
-filelight (1.0-0ubuntu2) gutsy; urgency=low
-
- * Removed postrm and postinst since they are not needed
- * Added patch for desktop file typo
-
- -- Harald Sitter <sitter.harald@gmail.com> Mon, 4 Jun 2007 21:58:53 +0200
-
-filelight (1.0-0ubuntu1) gutsy; urgency=low
-
- * New Upstream Release
- * Standards-Version: 3.7.2
- * Added manpage
- * Moved to cdbs
- * Removed debian/conffiles due to cdbs
-
- -- Harald Sitter <sitter.harald@gmail.com> Sun, 22 Apr 2007 14:48:10 +0200
-
-filelight (0.99beta6-1ubuntu1) dapper; urgency=low
-
- * Resynchronise with Debian.
-
- -- Benjamin Montgomery <bmontgom@montynet.org> Tue, 6 Dec 2005 22:12:09 -0600
-
-filelight (0.99beta6-1) unstable; urgency=low
-
- * New upstream (beta) release. Closes: #304497
- * Can delete files with spaces in the filename. Closes: #265384
-
- * Rebuilt for C++ transition. Closes: #327002, #327231
-
- * debian/rules (checkdir): update for source reorganization.
- * debian/rules (binary-arch): deal with the new libfilelight.so.
-
- * debian/menu: quote all strings (via lintian).
- * debian/rules (binary-arch): install menu file to /usr/share/menu
- rather than /usr/lib/menu (via lintian).
-
- * debian/control (Standards-Version): updated to 3.6.2.1.
- * debian/copyright: update download location to be non-version specific.
- Update FSF address (via lintian).
-
- * debian/control (Build-Depends): add autoconf and gettext.
-
- * src/part/radial/Makefile.am: add -fPIC to CFLAGS.
- * src/part/radial/Makefile.in: add -fPIC to INCLUDES. Copied from
- Michael Vogt's Ubuntu change. Not a good/proper long term solution,
- but it'll compile at least.
-
- * debian/rules (clean): also remove po/*.gmo, autom4te.cache and
- config.log to keep diff.gz clean.
-
- -- James Troup <james@nocrew.org> Mon, 19 Sep 2005 01:43:42 +0100
-
-filelight (0.99beta6-0ubuntu3) breezy; urgency=low
-
- * rebuild for c++ transition
- * fixed a missing -fPIC in src/part/radialMap
-
- -- Michael Vogt <michael.vogt@ubuntu.com> Wed, 14 Sep 2005 15:05:38 +0200
-
-filelight (0.99beta6-0ubuntu2) breezy; urgency=low
-
- * Add autoconf as build-dep
-
- -- Jonathan Riddell <jr@jriddell.org> Tue, 7 Jun 2005 17:05:56 +0000
-
-filelight (0.99beta6-0ubuntu1) breezy; urgency=low
-
- * New upstream release
-
- -- Jonathan Riddell <jr@jriddell.org> Tue, 7 Jun 2005 14:30:49 +0000
-
-filelight (0.6.4.1-1build1) breezy; urgency=low
-
- * Rebuild for new C++ ABI
-
- -- Matthias Klose <doko@ubuntu.com> Mon, 6 Jun 2005 16:34:50 +0000
-
-filelight (0.6.4.1-1) unstable; urgency=low
-
- * New upstream release.
-
- * debian/menu: new file, provided by Justin B Rye <jbr@edlug.org.uk>.
- Closes: #234301
- * debian/postinst: call update-menus.
- * debian/postrm: likewise.
- * debian/rules: install menu file and postinst and postrm.
-
- * src/filelight.desktop: Patch from Christoffer Sawicki <qerub@home.se>
- to fix typo (Generic Name -> GenericName). Closes: #230670
-
- * debian/control: reword extended description to include 'disk usage' to
- aid in searching with apt-cache as suggested by Remi Vanicat
- <vanicat@debian.org>. Closes: #231060
-
- -- James Troup <james@nocrew.org> Mon, 23 Feb 2004 14:55:16 +0000
-
-filelight (0.6.3.1-1) unstable; urgency=low
-
- * Initial Release. Closes: #228812
-
- -- James Troup <james@nocrew.org> Wed, 21 Jan 2004 03:11:00 +0100
-
diff --git a/ubuntu/maverick/applications/filelight/debian/compat b/ubuntu/maverick/applications/filelight/debian/compat
deleted file mode 100644
index 7f8f011eb..000000000
--- a/ubuntu/maverick/applications/filelight/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-7
diff --git a/ubuntu/maverick/applications/filelight/debian/control b/ubuntu/maverick/applications/filelight/debian/control
deleted file mode 100644
index b90fda11c..000000000
--- a/ubuntu/maverick/applications/filelight/debian/control
+++ /dev/null
@@ -1,22 +0,0 @@
-Source: filelight-trinity
-Section: tde
-Priority: optional
-Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
-XSBC-Original-Maintainer: Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>
-Uploaders: Ral Snchez Siles <rasasi78@gmail.com>
-Standards-Version: 3.8.4
-Build-Depends: debhelper (>= 7.0.50~), cdbs, cmake, tdelibs14-trinity-dev, xutils, chrpath, quilt (>= 0.40), libltdl-dev
-Homepage: http://www.methylblue.com/filelight/
-
-Package: filelight-trinity
-Architecture: any
-Depends: ${shlibs:Depends}
-Replaces: filelight-kde3 (<< 4:14.0.0~), filelight-trinity (<< 4:14.0.0~)
-Breaks: filelight-kde3 (<< 4:14.0.0~), filelight-trinity (<< 4:14.0.0~)
-Description: show where your diskspace is being used [Trinity]
- Filelight allows you to understand your disk usage by graphically
- representing your filesystem as a set of concentric, segmented rings.
- .
- It is like a pie-chart, but the segments nest, allowing you to see both
- which directories take up all your space, and which directories
- and files inside those directories are the real culprits.
diff --git a/ubuntu/maverick/applications/filelight/debian/copyright b/ubuntu/maverick/applications/filelight/debian/copyright
deleted file mode 100644
index c02dc5949..000000000
--- a/ubuntu/maverick/applications/filelight/debian/copyright
+++ /dev/null
@@ -1,42 +0,0 @@
-This is Debian GNU's prepackaged version of filelight, a program to
-show you where your diskspace is being used. Debianized by James
-Troup <james@nocrew.org> on Wed, 21 Jan 2004 and reworked by Raúl
-Sánchez Siles <rasasi78@gmail.com> on Fri, 16 Nov 2007 13:03:04 +0100
-
-The Debian packaging is (C) 2007, Raul Sánchez Siles <rasasi78@gmail.com>
-and is licensed under the GPLv2, which can be found at
-'/usr/share/common-licenses/GPL-2'.
-
-It was downloaded from:
-
- http://www.methylblue.com/filelight/#packages
-
-Upstream Author: Max Howell <max.howell@methylblue.com>
-
-License:
-
- This package and debian/filelight.1 is free software; you can redistribute
- it and/or modify it under the terms of the GNU General Public License as
- published by the Free Software Foundation; version 2 dated June, 1991.
-
- This package is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this package; if not, write to the Free Software
- Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
-
-On Debian systems, the complete text of the GNU General
-Public License version 2 can be found at `/usr/share/common-licenses/GPL-2'.
-
-Copyright
-
-Filelight:
-
- (C) 2005-2006 Max Howell <max.howell@methylblue.com>
-
-debian/filelight.1:
-
- Copyright (C) 2006 by J. R. Van Zandt <jrvz@comcast.net>
diff --git a/ubuntu/maverick/applications/filelight/debian/filelight.1 b/ubuntu/maverick/applications/filelight/debian/filelight.1
deleted file mode 100644
index ce932984b..000000000
--- a/ubuntu/maverick/applications/filelight/debian/filelight.1
+++ /dev/null
@@ -1,63 +0,0 @@
-.\" Hey, EMACS: -*- nroff -*-
-.TH FILELIGHT 1 "March 14, 2007"
-.\" Please adjust this date whenever revising the manpage.
-.SH NAME
-filelight \- graphically display disk usage
-.SH SYNOPSIS
-.B filelight
-.RI [ " path " ]
-.SH DESCRIPTION
-\fBfilelight\fP allows you to understand exactly where your disk space
-is being used by graphically representing your file system as a set
-of concentric segmented rings, where each segment subtends an angle
-proportional to the disk space occupied by that file or directory.
-.PP
-You can specify a directory to scan on startup at the command line eg:
-.nf
- filelight /home/mxcl
-.fi
-Starting at the root requires a scan of the entire directory tree,
-which may take a while.
-.PP
-\fBfilelight\fP is available in Konqueror under \fBView | View Mode | RadialMap View\fP.
-.SH RUN-TIME COMMANDS
-
-.TP
-.B Hover over segments
-to find out more about the region of the file system it represents.
-.TP
-.B Click on directories
-to see them in more detail (recenter the
-display on that directory).
-.TP
-.B Click on files
-to launch in the appropriate viewer (as configured in
-Konqueror).
-.TP
-.B Middle click
-to open files/directories with Konqueror.
-.TP
-.B Right click on the center white circle
-to manipulate the directory the view is centered about.
-.TP
-.B Enlarge the window
-for more detail - small files are hidden at
-smaller window sizes.
-.SH SEE ALSO
-.BR du (1),
-.BR df (1),
-.BR fsviewer (1),
-.BR gdmap (1),
-.BR philesight (1),
-.BR xcruiser (1).
-.BR xdiskusage (1).
-.br
-.SH BUGS
-Please report any bugs using the built-in bug reporter under
-the "help" menu, or to either filelight@methylblue.com or the forums at
-http://www.methylblue.com/filelight/.
-.SH AUTHOR
-\fBfilelight\fP was written by Max Howell (max.howell@methylblue.com).
-.PP
-This manual page was written by J. R. Van Zandt,
-for the Debian project (but may be used by others).
diff --git a/ubuntu/maverick/applications/filelight/debian/menu b/ubuntu/maverick/applications/filelight/debian/menu
deleted file mode 100644
index 943809a61..000000000
--- a/ubuntu/maverick/applications/filelight/debian/menu
+++ /dev/null
@@ -1,6 +0,0 @@
-?package(filelight-trinity):needs="X11" \
- section="Apps/System" \
- hints="TDE, Monitoring, Files" \
- command="/opt/trinity/bin/filelight" \
- title="Filelight" \
- longtitle="Filelight: disk usage as concentric rings"
diff --git a/ubuntu/maverick/applications/filelight/debian/patches/series b/ubuntu/maverick/applications/filelight/debian/patches/series
deleted file mode 100644
index e69de29bb..000000000
--- a/ubuntu/maverick/applications/filelight/debian/patches/series
+++ /dev/null
diff --git a/ubuntu/maverick/applications/filelight/debian/rules b/ubuntu/maverick/applications/filelight/debian/rules
deleted file mode 100755
index f296f481e..000000000
--- a/ubuntu/maverick/applications/filelight/debian/rules
+++ /dev/null
@@ -1,32 +0,0 @@
-#!/usr/bin/make -f
-# debian/rules file - for filelight (1.0)
-# Copyright 2007 Raúl Sánchez Siles
-# This packaging is licensed under GPLv2
-# see /usr/share/common-licenses/GPL-2 for details.
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/cmake.mk
-include debian/cdbs/kde.mk
-#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-DEB_INSTALL_MANPAGES_filelight := debian/filelight.1
-DEB_DH_ALWAYS_EXCLUDE=.svn
-
-# Build options
-DEB_CMAKE_EXTRA_FLAGS := \
- -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
- -DCONFIG_INSTALL_DIR="/etc/trinity" \
- -DSYSCONF_INSTALL_DIR="/etc" \
- -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_VERBOSE_MAKEFILE="ON" \
- -DCMAKE_SKIP_RPATH="OFF" \
- -DBUILD_ALL="ON"
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
diff --git a/ubuntu/maverick/applications/filelight/debian/source/format b/ubuntu/maverick/applications/filelight/debian/source/format
deleted file mode 100644
index 163aaf8d8..000000000
--- a/ubuntu/maverick/applications/filelight/debian/source/format
+++ /dev/null
@@ -1 +0,0 @@
-3.0 (quilt)
diff --git a/ubuntu/maverick/applications/filelight/debian/source/options b/ubuntu/maverick/applications/filelight/debian/source/options
deleted file mode 100644
index 72f1f5450..000000000
--- a/ubuntu/maverick/applications/filelight/debian/source/options
+++ /dev/null
@@ -1,6 +0,0 @@
-# Use xz instead of gzip
-compression = "xz"
-compression-level = 9
-
-# Don't run differences
-diff-ignore = .*