summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/k3b-i18n/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2016-02-28 02:18:58 +0100
committerSlávek Banko <slavek.banko@axis.cz>2016-02-28 02:18:58 +0100
commit639c18e5e10b68f5dea1b68665ba08b2e25f08e5 (patch)
treef2decf15060995babefc7a7cf2b0d9ee1530e612 /ubuntu/maverick/applications/k3b-i18n/debian/rules
parenta02d02a9479da792b2196de5e84811b012e95b05 (diff)
downloadtde-packaging-639c18e5e10b68f5dea1b68665ba08b2e25f08e5.tar.gz
tde-packaging-639c18e5e10b68f5dea1b68665ba08b2e25f08e5.zip
Allow parallel make for i18n packages on Debian and Ubuntu
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ubuntu/maverick/applications/k3b-i18n/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/k3b-i18n/debian/rules9
1 files changed, 7 insertions, 2 deletions
diff --git a/ubuntu/maverick/applications/k3b-i18n/debian/rules b/ubuntu/maverick/applications/k3b-i18n/debian/rules
index 9c9661607..87d47158c 100755
--- a/ubuntu/maverick/applications/k3b-i18n/debian/rules
+++ b/ubuntu/maverick/applications/k3b-i18n/debian/rules
@@ -15,6 +15,11 @@ DEB_CONFIGURE_PREFIX := /opt/trinity
DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+ DEB_PARALLEL_JOBS ?= $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+endif
+DEB_MAKE_PARALLEL ?= $(and $(DEB_BUILD_PARALLEL),$(DEB_PARALLEL_JOBS),-j$(DEB_PARALLEL_JOBS))
+
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
@@ -63,7 +68,7 @@ build-stamp: config.status
dh_testdir
# Add here commands to compile the package.
- $(MAKE)
+ $(MAKE) $(DEB_MAKE_PARALLEL)
#/usr/bin/docbook-to-man debian/k3b-i18n.sgml > k3b-i18n.1
touch build-stamp
@@ -91,7 +96,7 @@ install: build
dh_installdirs
# Add here commands to install the package into debian/k3b-i18n-trinity.
- $(MAKE) install DESTDIR=$(CURDIR)/debian/k3b-i18n-trinity
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/k3b-i18n-trinity $(DEB_MAKE_PARALLEL)
mkdir -p $(CURDIR)/debian/k3b-i18n-trinity$(DEB_CONFIGURE_PREFIX)/share/doc/tde/
# Build architecture-independent files here.