summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/kbibtex/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2013-07-04 17:38:49 +0200
committerSlávek Banko <slavek.banko@axis.cz>2013-07-04 17:40:24 +0200
commite164b04fd3c45cf4c4ee47f1efadfc8bbc920bbc (patch)
treefc158797f2d6b77a9e0cba5b8f5f9582b0363809 /ubuntu/maverick/applications/kbibtex/debian/rules
parentb679e3718923d1e4f5a5a433346f39bf10ef0225 (diff)
downloadtde-packaging-e164b04fd3c45cf4c4ee47f1efadfc8bbc920bbc.tar.gz
tde-packaging-e164b04fd3c45cf4c4ee47f1efadfc8bbc920bbc.zip
Add packaging files for kbibtex on Debian and Ubuntu
Diffstat (limited to 'ubuntu/maverick/applications/kbibtex/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/kbibtex/debian/rules33
1 files changed, 33 insertions, 0 deletions
diff --git a/ubuntu/maverick/applications/kbibtex/debian/rules b/ubuntu/maverick/applications/kbibtex/debian/rules
new file mode 100755
index 000000000..590ff494e
--- /dev/null
+++ b/ubuntu/maverick/applications/kbibtex/debian/rules
@@ -0,0 +1,33 @@
+#!/usr/bin/make -f
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+LDFLAGS += -Wl,--as-needed
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/kde.mk
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ dh_testdir
+
+ # Regenerate build system
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ autoreconf --install && automake -f && \
+ $(MAKE) -f admin/Makefile.common && \
+ touch debian/stamp-bootstrap
+
+clean::
+ dh_testdir
+ rm -f debian/stamp-bootstrap