summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/kcmautostart/debian/rules
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-05-05 17:52:39 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-05-05 17:52:39 -0500
commit1057c1a3e7ae3e43bb15d4a41c3c3a481f0a3e91 (patch)
tree8000ac58e153eab553f8136dfd7d15d6b396408e /ubuntu/maverick/applications/kcmautostart/debian/rules
parent94c9bd080585eff86bdbeeb3670b66e1240cc62e (diff)
downloadtde-packaging-1057c1a3e7ae3e43bb15d4a41c3c3a481f0a3e91.tar.gz
tde-packaging-1057c1a3e7ae3e43bb15d4a41c3c3a481f0a3e91.zip
Add initial packaging files for kcmautostart on Debian and Ubuntu
Diffstat (limited to 'ubuntu/maverick/applications/kcmautostart/debian/rules')
-rw-r--r--ubuntu/maverick/applications/kcmautostart/debian/rules24
1 files changed, 24 insertions, 0 deletions
diff --git a/ubuntu/maverick/applications/kcmautostart/debian/rules b/ubuntu/maverick/applications/kcmautostart/debian/rules
new file mode 100644
index 000000000..242fb2c84
--- /dev/null
+++ b/ubuntu/maverick/applications/kcmautostart/debian/rules
@@ -0,0 +1,24 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+include /usr/share/cdbs/1/class/autotools.mk
+include /usr/share/cdbs/1/rules/debhelper.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap