summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/kdirstat/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-11-04 12:55:14 +0100
committerSlávek Banko <slavek.banko@axis.cz>2018-11-04 12:55:14 +0100
commit4b11983ef2300e3a28a28932a64cf2b991f6772d (patch)
treee31c77130695758e4a14c18c2de39d6d2bb607ef /ubuntu/maverick/applications/kdirstat/debian/rules
parent84b9012cd16fd4bb51079faa067ace40dd6951d0 (diff)
downloadtde-packaging-4b11983ef2300e3a28a28932a64cf2b991f6772d.tar.gz
tde-packaging-4b11983ef2300e3a28a28932a64cf2b991f6772d.zip
DEB kdirstat: Switch to cmake.
The man page has been moved to the main tree. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ubuntu/maverick/applications/kdirstat/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/kdirstat/debian/rules43
1 files changed, 12 insertions, 31 deletions
diff --git a/ubuntu/maverick/applications/kdirstat/debian/rules b/ubuntu/maverick/applications/kdirstat/debian/rules
index 018dd234e..18b1c07e2 100755
--- a/ubuntu/maverick/applications/kdirstat/debian/rules
+++ b/ubuntu/maverick/applications/kdirstat/debian/rules
@@ -1,39 +1,20 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
-include debian/cdbs/kde.mk
+include /usr/share/cdbs/1/class/cmake.mk
#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/tde
+include debian/cdbs/debian-qt-kde.mk
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-LDFLAGS += -Wl,--as-needed
-
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
-
-clean::
- rm -f po/*.gmo
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"