summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/kerry/debian
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-07-10 16:17:43 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-07-10 16:17:43 -0500
commit9b2075d9b89fc628c447fbb98f43ef72e4a9c81d (patch)
tree2de9e866f064b1c7d36df24de1df305474f949fe /ubuntu/maverick/applications/kerry/debian
downloadtde-packaging-9b2075d9b89fc628c447fbb98f43ef72e4a9c81d.tar.gz
tde-packaging-9b2075d9b89fc628c447fbb98f43ef72e4a9c81d.zip
Initial import from old SVN repository
Note that only the Debian and Ubuntu folders were preserved
Diffstat (limited to 'ubuntu/maverick/applications/kerry/debian')
-rw-r--r--ubuntu/maverick/applications/kerry/debian/cdbs/buildvars.mk86
-rw-r--r--ubuntu/maverick/applications/kerry/debian/cdbs/debian-qt-kde.mk109
-rw-r--r--ubuntu/maverick/applications/kerry/debian/cdbs/kde.mk97
-rw-r--r--ubuntu/maverick/applications/kerry/debian/cdbs/team-members16
-rw-r--r--ubuntu/maverick/applications/kerry/debian/cdbs/uploaders.mk29
-rw-r--r--ubuntu/maverick/applications/kerry/debian/cdbs/versions.pl19
-rw-r--r--ubuntu/maverick/applications/kerry/debian/changelog99
-rw-r--r--ubuntu/maverick/applications/kerry/debian/compat1
-rw-r--r--ubuntu/maverick/applications/kerry/debian/control17
-rw-r--r--ubuntu/maverick/applications/kerry/debian/control.in19
-rw-r--r--ubuntu/maverick/applications/kerry/debian/copyright35
-rw-r--r--ubuntu/maverick/applications/kerry/debian/kerry.1.docbook109
-rw-r--r--ubuntu/maverick/applications/kerry/debian/patches/kubuntu_03_no_beagle_autostart.patch12
-rw-r--r--ubuntu/maverick/applications/kerry/debian/patches/kubuntu_04_no_core_kmenu_entry.desktop.patch19
-rw-r--r--ubuntu/maverick/applications/kerry/debian/patches/kubuntu_05_shortkey.patch13
-rw-r--r--ubuntu/maverick/applications/kerry/debian/postinst12
-rw-r--r--ubuntu/maverick/applications/kerry/debian/postrm12
-rwxr-xr-xubuntu/maverick/applications/kerry/debian/rules32
18 files changed, 736 insertions, 0 deletions
diff --git a/ubuntu/maverick/applications/kerry/debian/cdbs/buildvars.mk b/ubuntu/maverick/applications/kerry/debian/cdbs/buildvars.mk
new file mode 100644
index 000000000..23d4709dc
--- /dev/null
+++ b/ubuntu/maverick/applications/kerry/debian/cdbs/buildvars.mk
@@ -0,0 +1,86 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2002,2003 Colin Walters <walters@debian.org>
+# Description: Defines some useful variables, but no rules
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_rules_buildvars
+_cdbs_rules_buildvars = 1
+
+CDBS_VERSION = something
+
+# Common useful variables
+DEB_SOURCE_PACKAGE := $(strip $(shell egrep '^Source: ' debian/control | cut -f 2 -d ':'))
+DEB_VERSION := $(shell dpkg-parsechangelog | egrep '^Version:' | cut -f 2 -d ' ')
+DEB_NOEPOCH_VERSION := $(shell echo $(DEB_VERSION) | cut -d: -f2-)
+DEB_UPSTREAM_VERSION := $(shell echo $(DEB_NOEPOCH_VERSION) | sed 's/-[^-]*$$//')
+DEB_ISNATIVE := $(shell dpkg-parsechangelog | egrep '^Version:' | perl -ne 'print if not /^Version:\s*.*-/;')
+
+# Split into arch/indep packages
+ifneq ($(DEB_INDEP_PACKAGES),cdbs)
+DEB_INDEP_PACKAGES := $(filter-out $(DONT_BUILD), $(strip $(shell $(_cdbs_scripts_path)/list-packages indep)))
+DEB_ARCH_PACKAGES := $(filter-out $(DONT_BUILD), $(filter-out $(DEB_INDEP_PACKAGES),$(strip $(shell $(_cdbs_scripts_path)/list-packages same))))
+endif
+# Split into normal and udeb packages
+ifeq ($(DEB_UDEB_PACKAGES),)
+DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+DEB_UDEB_PACKAGES = $(filter-out $(DONT_BUILD),$(filter %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+else
+DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES), $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+endif
+# Too much bother for now. If someone complains we'll fix it.
+#DEB_ARCH_UDEB_PACKAGES = $(filter %-udeb, $(DEB_ARCH_PACKAGES))
+#DEB_INDEP_UDEB_PACKAGES = $(filter %-udeb, $(DEB_INDEP_PACKAGES))
+# A handy list of every package, udeb or not
+DEB_ALL_PACKAGES = $(filter-out $(DONT_BUILD),$(DEB_PACKAGES) $(DEB_UDEB_PACKAGES))
+DEB_INDEP_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_INDEP_PACKAGES)))
+DEB_ARCH_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_ARCH_PACKAGES)))
+
+DEB_DBG_PACKAGES = $(filter-out $(DONT_BUILD), $(filter %-dbg, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+
+# Some support for srcdir != builddir builds.
+# These are relative to the root of the package
+DEB_SRCDIR ?= .
+DEB_BUILDDIR ?= $(strip $(DEB_SRCDIR))
+
+# Miscellaneous bits
+DEB_ARCH = $(shell dpkg --print-architecture)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_HOST_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_HOST_GNU_SYSTEM)
+DEB_HOST_GNU_CPU ?= $(shell dpkg-architecture -qDEB_HOST_GNU_CPU)
+DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
+DEB_HOST_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
+DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_BUILD_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_SYSTEM)
+DEB_BUILD_GNU_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_CPU)
+DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
+DEB_BUILD_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU)
+DEB_BUILD_ARCH_OS ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)
+
+ifeq ($(words $(DEB_ALL_PACKAGES)),1)
+ DEB_DESTDIR = $(CURDIR)/debian/$(strip $(DEB_ALL_PACKAGES))/
+else
+ DEB_DESTDIR = $(CURDIR)/debian/tmp/
+endif
+
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), cdbs (>= 0.4.23-1.1)
+
+endif
diff --git a/ubuntu/maverick/applications/kerry/debian/cdbs/debian-qt-kde.mk b/ubuntu/maverick/applications/kerry/debian/cdbs/debian-qt-kde.mk
new file mode 100644
index 000000000..cae625265
--- /dev/null
+++ b/ubuntu/maverick/applications/kerry/debian/cdbs/debian-qt-kde.mk
@@ -0,0 +1,109 @@
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+ touch debian/stamp-cvs-make
+
+include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
+include debian/cdbs/uploaders.mk
+
+DEB_PATCHDIRS := debian/patches/common debian/patches
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/opt/trinity/lib)
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/opt/trinity/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/opt/trinity/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/kde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/kde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/kde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/kde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/kde/HTML/en/$$pkg; \
+ done
+
+clean::
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/ubuntu/maverick/applications/kerry/debian/cdbs/kde.mk b/ubuntu/maverick/applications/kerry/debian/cdbs/kde.mk
new file mode 100644
index 000000000..5b6508f8c
--- /dev/null
+++ b/ubuntu/maverick/applications/kerry/debian/cdbs/kde.mk
@@ -0,0 +1,97 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Description: A class for KDE packages; sets KDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_class_kde
+_cdbs_class_kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/kde/HTML
+
+ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/kde"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+common-build-arch common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-prehook-impl::
+ mkdir -p po
+ -XGETTEXT=/usr/bin/kde-xgettext EXTRACTATTR=/opt/trinity/bin/extractattr sh $(DEB_SRCDIR)/admin/cvs.sh extract-messages
+ -for file in po/*pot; do \
+ sed "s/charset=CHARSET/charset=UTF-8/" -i $$file; \
+ done
+
+common-install-arch common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+
+clean::
+ rm -f debian/stamp-kde-apidox
+ rm -rf po/*.pot
+
+# This is a convenience target for calling manually. It's not part of
+# the build process.
+buildprep: clean apply-patches
+ $(MAKE) -f admin/Makefile.common dist
+ debian/rules clean
+
+endif
diff --git a/ubuntu/maverick/applications/kerry/debian/cdbs/team-members b/ubuntu/maverick/applications/kerry/debian/cdbs/team-members
new file mode 100644
index 000000000..05761af6e
--- /dev/null
+++ b/ubuntu/maverick/applications/kerry/debian/cdbs/team-members
@@ -0,0 +1,16 @@
+Sune Vuorela <debian@pusling.com>
+Ana Beatriz Guerrero Lopez <ana@debian.org>
+Fathi Boudra <fboudra@free.fr>
+Modestas Vainius <geromanas@mailas.com>
+Josh Metzler <joshdeb@metzlers.org>
+Isaac Clerencia <isaac@debian.org>
+Adeodato Simó <dato@net.com.org.es>
+Adeodato Simo <dato@net.com.org.es>
+Christopher Martin <chrsmrtn@debian.org>
+Daniel Schepler <schepler@debian.org>
+Sarah Hobbs <hobbsee@ubuntu.com>
+Nacho Barrientos Arias <nacho@debian.org>
+Ricardo Javier Cardenes Medina <rcardenes@debian.org>
+Ricardo Cardenes <rcardenes@debian.org>
+Armin Berres <trigger+debian@space-based.de>
+Francesco Pedrini <francesco.pedrini@gmail.com>
diff --git a/ubuntu/maverick/applications/kerry/debian/cdbs/uploaders.mk b/ubuntu/maverick/applications/kerry/debian/cdbs/uploaders.mk
new file mode 100644
index 000000000..31adfe31e
--- /dev/null
+++ b/ubuntu/maverick/applications/kerry/debian/cdbs/uploaders.mk
@@ -0,0 +1,29 @@
+
+MAINTAINER=Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
+UPLOADERS=$(shell grep -e +++ -e "^ -- " debian/changelog | grep -v "debian-qt-kde@lists.debian.org" | head -13 | /bin/sed 's/^\s*//;s/\s*$$//;s/^+++\? Changes by //;s/^+++\? //;s/-- //;s/:$$//;s/ <.*//' | sort -u | while read line ; do grep "$$line" debian/cdbs/team-members ; done | tr "\n" ", " | sed 's/,/, /g;s/, $$//')
+
+
+debian/control.tmp:
+ @if [ ! -e debian/control.in ] ; then \
+ echo "this package is not yet prepared for using automatic update of uploaders"; \
+ echo "Please do so."; \
+ exit 1; \
+ fi
+ @sed 's/@@@UPLOADERS@@@/$(UPLOADERS)/;s#@@@MAINTAINER@@@#$(MAINTAINER)#' debian/control.in > debian/control.tmp
+
+check-uploaders: debian/control.tmp
+ @if ! diff -q debian/control debian/control.tmp ; then \
+ echo "WARNING:: Control file differs from manually generated one" ; \
+ echo "WARNING:: Please update it manually and check it afterwards" ; \
+ echo "WARNING:: Uploaders are updated by debian/rules update-uploaders" ;\
+ echo "WARNING:: If this is a binNMU, NMU or security upload, just ignore" ;\
+ fi
+
+
+clean::
+ rm -f debian/control.tmp
+
+update-uploaders: debian/control.tmp
+ @mv -f debian/control.tmp debian/control
+
+makebuilddir:: check-uploaders
diff --git a/ubuntu/maverick/applications/kerry/debian/cdbs/versions.pl b/ubuntu/maverick/applications/kerry/debian/cdbs/versions.pl
new file mode 100644
index 000000000..9ce11d8a3
--- /dev/null
+++ b/ubuntu/maverick/applications/kerry/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/-[^-]+$//;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "KDE-Version3=$version3\n";
+print "KDE-Version2=$version2\n";
+print "KDE-Next-Version3=$version3_next\n";
+print "KDE-Next-Version2=$version2_next\n";
diff --git a/ubuntu/maverick/applications/kerry/debian/changelog b/ubuntu/maverick/applications/kerry/debian/changelog
new file mode 100644
index 000000000..5ad17f564
--- /dev/null
+++ b/ubuntu/maverick/applications/kerry/debian/changelog
@@ -0,0 +1,99 @@
+kerry-trinity (1:0.2.1-0ubuntu6) lucid; urgency=low
+
+ * KDE3 Lucid rebuild
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Sat, 14 Aug 2010 10:00:00 -0600
+
+kerry (1:0.2.1-0ubuntu5) hardy; urgency=low
+
+ * Add patch kubuntu_08_libbeagle1_transition.patch to make configure
+ use libbeagle1, so binary objects are built. (LP: #211591).
+ * Add patch kubuntu_09_remove-sh.patch to remove .sh extension
+ from beagled-shutdown script.
+ * Add postinst and postrm scripts to run ldconfig when kerry is
+ installed or removed.
+ * denian/rules: remove rpath from the binary and library files.
+ * debian/control:
+ - set minimum version of libbeagle-dev to 0.3.0 in build-depends.
+ - add chrpath to build-depends.
+ - bump standards-version to 3.7.3, no further changes needed.
+ - move Homepage from description to control fields.
+ * Update kubuntu_04_no_core_kmenu_entry.desktop.patch to remove
+ deprecated encoding field.
+ * Add patch kubuntu_10_update-kcmbeagle-desktop.patch to remove
+ deprecated encoding field from the kcmbeagle desktop file.
+
+ -- Albert Damen <albrt@gmx.net> Tue, 08 Apr 2008 21:50:06 +0200
+
+kerry (1:0.2.1-0ubuntu4) hardy; urgency=low
+
+ * Rebuild for libbeagle0 -> libbeagle1 transition (LP: #192262).
+
+ -- Andrea Colangelo <warp10@libero.it> Sat, 16 Feb 2008 00:02:29 +0100
+
+kerry (1:0.2.1-0ubuntu3) gutsy; urgency=low
+
+ * Added kubuntu_06_knotes_integration.patch to fix knotes integration
+ failing to open a note, opening an empty note instead
+ * kubuntu_07_french_translation.patch for complete french translation
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Sat, 30 Jun 2007 01:14:05 +0200
+
+kerry (1:0.2.1-0ubuntu2) feisty; urgency=low
+
+ * Build-Depends on libbeagle-dev instead of beagle-dev to actually compile
+ kerry (Closes: Malone #76773)
+
+ -- Adrien Cunin <adri2000@gmail.com> Thu, 18 Jan 2007 12:33:38 +0100
+
+kerry (1:0.2.1-0ubuntu1) feisty; urgency=low
+
+ * New upstream release.
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Tue, 05 Dec 2006 18:03:31 +0100
+
+kerry (1:0.1-0ubuntu2) dapper; urgency=low
+
+ * kubuntu_05_shortkey.diff: Change main key combo to stop clashing with
+ YaKuake this time.
+
+ -- Jonathan Patrick Davies <jpatrick@ubuntu.com> Sun, 09 Apr 2006 21:14:46 +0200
+
+kerry (1:0.1-0ubuntu1) dapper; urgency=low
+
+ * New upstream release.
+ * Patched up patches.
+ * Removed makebuilddir/kerry from debian/rules: no longer necessary.
+
+ -- Jonathan Patrick Davies <jpatrick@ubuntu.com> Sun, 09 Apr 2006 11:35:34 +0200
+
+kerry (0.09-0ubuntu4) dapper; urgency=low
+
+ * Added kubuntu_05_shortkey.diff: Remove Alt-Space shortcut to stop
+ conflicting with Katapult.
+
+ -- Jonathan Patrick Davies <jpatrick@ubuntu.com> Fri, 07 Apr 2006 21:11:45 +0200
+
+kerry (0.09-0ubuntu3) dapper; urgency=low
+
+ * Added kubuntu_04_no_core_kmenu_entry.desktop.patch to avoid double entry
+ in Kmenu
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Tue, 29 Mar 2006 3:30:37 +0100
+
+kerry (0.09-0ubuntu2) dapper; urgency=low
+
+ * Switched to cdbs
+ * Added kubuntu_01_kdepot.patch for pot file extraction to Rosetta
+ * kubuntu_01_kerry.diff becomes kubuntu_02_fix_shutdown_script_path.patch
+ * Added kubuntu_03_no_beagle_autostart.diff to remove autostart desktop file
+ for beagle as new beagle package already has it
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Mon, 28 Mar 2006 20:50:37 +0100
+
+kerry (0.09-0ubuntu1) dapper; urgency=low
+
+ * Initial release.
+ * Created kubuntu_01_kerry.diff - install scripts to /usr/bin.
+
+ -- Jonathan Patrick Davies <jpatrick@ubuntu.com> Sun, 26 Mar 2006 15:51:20 +0200
diff --git a/ubuntu/maverick/applications/kerry/debian/compat b/ubuntu/maverick/applications/kerry/debian/compat
new file mode 100644
index 000000000..7ed6ff82d
--- /dev/null
+++ b/ubuntu/maverick/applications/kerry/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/ubuntu/maverick/applications/kerry/debian/control b/ubuntu/maverick/applications/kerry/debian/control
new file mode 100644
index 000000000..15efeb828
--- /dev/null
+++ b/ubuntu/maverick/applications/kerry/debian/control
@@ -0,0 +1,17 @@
+Source: kerry-trinity
+Section: kde
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+Build-Depends: debhelper (>= 5.0.0), cdbs, kdelibs4-trinity-dev, libkonq4-trinity-dev, libbeagle-dev (>= 0.3.0), docbook2x, chrpath, automake, autoconf, libtool, libltdl-dev
+Homepage: http://en.opensuse.org/Kerry
+Standards-Version: 3.8.4
+
+Package: kerry-trinity
+Architecture: any
+Depends: ${shlibs:Depends}, beagle (>= 0.2.3)
+Description: a KDE frontend for the Beagle desktop search daemon [Trinity]
+ Kerry is a KDE3 frontend for the Beagle desktop search daemon.
+ .
+ A program for indexing and searching user's data. At the moment, it can index
+ filesystems, chat logs, mail and data, RSS and other.
+ .
diff --git a/ubuntu/maverick/applications/kerry/debian/control.in b/ubuntu/maverick/applications/kerry/debian/control.in
new file mode 100644
index 000000000..f59651723
--- /dev/null
+++ b/ubuntu/maverick/applications/kerry/debian/control.in
@@ -0,0 +1,19 @@
+Source: kerry-trinity
+Section: kde
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+XSBC-Original-Maintainer: @@@MAINTAINER@@@
+Uploaders: @@@UPLOADERS@@@
+Build-Depends: debhelper (>= 5.0.0), cdbs, kdelibs4-trinity-dev, libkonq4-trinity-dev, libqt3-mt-dev, libbeagle-dev (>= 0.3.0), docbook2x, chrpath, automake1.11-trinity, autoconf2.63, libtool, libltdl-dev
+Homepage: http://en.opensuse.org/Kerry
+Standards-Version: 3.8.3
+
+Package: kerry-trinity
+Architecture: any
+Depends: ${shlibs:Depends}, beagle (>= 0.2.3)
+Description: a KDE frontend for the Beagle desktop search daemon [Trinity]
+ Kerry is a KDE3 frontend for the Beagle desktop search daemon.
+ .
+ A program for indexing and searching user's data. At the moment, it can index
+ filesystems, chat logs, mail and data, RSS and other.
+ .
diff --git a/ubuntu/maverick/applications/kerry/debian/copyright b/ubuntu/maverick/applications/kerry/debian/copyright
new file mode 100644
index 000000000..96a9180c9
--- /dev/null
+++ b/ubuntu/maverick/applications/kerry/debian/copyright
@@ -0,0 +1,35 @@
+This package was debianized by Jonathan Patrick Davies <jpatrick@ubuntu.com> on
+Sun, 26 Mar 2006 15:51:20 +0200.
+
+It was downloaded from http://www.kde-apps.org/content/show.php?content=36832
+
+Upstream Authors: Stephan Binner <binner@kde.org>
+ Debajyoti Bera <dbera.web@gmail.com>
+
+
+Copyright:
+ Copyright (C) 2005 Novell, Inc.
+ Copyright (C) 2005 Petri Damst�n <petri.damsten@iki.fi>
+ Copyright (C) 2005 Debajyoti Bera <dbera.web@gmail.com>
+ Copyright (C) 1998 Kurt Granroth <granroth@kde.org>
+ Copyright (C) 2000 Peter Putzer <putzer@kde.org>
+ Copyright (C) 2005 Jaroslaw Staniek <js@iidea.pl>
+
+License:
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the
+ Free Software Foundation, Inc.,
+ 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL-2'.
diff --git a/ubuntu/maverick/applications/kerry/debian/kerry.1.docbook b/ubuntu/maverick/applications/kerry/debian/kerry.1.docbook
new file mode 100644
index 000000000..49eb68460
--- /dev/null
+++ b/ubuntu/maverick/applications/kerry/debian/kerry.1.docbook
@@ -0,0 +1,109 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
+"http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" [
+]>
+<refentry>
+ <refentryinfo>
+ <author>
+ <firstname>Jonathan Patrick</firstname>
+ <surname>Davies</surname>
+ <email>jpatrick@ubuntu.com</email>
+ </author>
+ <copyright>
+ <year>2006</year>
+ <holder>Jonathan Patrick Davies</holder>
+ </copyright>
+ <!-- XXX IMPORTANT XXX -->
+ <!-- Keep this date up to date: -->
+ <date>2006-03-26</date>
+ <!-- ^^^^^^^^^^ -->
+ </refentryinfo>
+ <refmeta>
+ <refentrytitle>kerry</refentrytitle>
+ <manvolnum>1</manvolnum>
+ </refmeta>
+ <refnamediv>
+ <refname>kerry</refname>
+ <refpurpose>a Beagle frontend for KDE</refpurpose>
+ </refnamediv>
+ <refsynopsisdiv>
+ <cmdsynopsis>
+ <command>kautoclick</command>
+ <arg choice="opt">
+ <option><replaceable>Qt-options</replaceable></option>
+ </arg>
+ <arg choice="opt">
+ <option><replaceable>KDE-options</replaceable></option>
+ </arg>
+ </cmdsynopsis>
+ </refsynopsisdiv>
+ <refsect1>
+ <title>DESCRIPTION</title>
+ <para>
+ Kerry is a frontend for Beagle for the <productname>KDE</productname> desktop.
+ </para>
+ </refsect1>
+ <refsect1>
+ <title>OPTIONS</title>
+ <para>
+ All <productname>KDE</productname> and <productname>Qt</productname>
+ programs accept a some common command-line options. Kerry has no
+ application-specific options.
+ </para>
+ <para>
+ <variablelist>
+ <title>Generic options:</title>
+ <varlistentry>
+ <term> <option>--help</option> </term>
+ <listitem> <para>Show help about options</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--help-qt</option> </term>
+ <listitem> <para>Show Qt specific options</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--help-kde</option> </term>
+ <listitem> <para>Show KDE specific options</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--help-all</option> </term>
+ <listitem> <para>Show all options</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--author</option> </term>
+ <listitem> <para>Show author information</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>-v</option>, <option>--version</option> </term>
+ <listitem> <para>Show version information</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--license</option> </term>
+ <listitem> <para>Show license information</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--</option> </term>
+ <listitem> <para>Indicates end of options</para> </listitem>
+ </varlistentry>
+ </variablelist>
+ <!-- TODO * add all the rest of the options, but maybe find an automated
+ way to keep it up to date -->
+ </para>
+ </refsect1>
+ <refsect1>
+ <title>COPYRIGHT</title>
+ <para>
+ This manual page was written by Jonathan Patrick Davies
+ <email>jpatrick@ubuntu.com</email> for the
+ <productname>Ubuntu</productname> system (but may be used by others).
+ Permission is granted to copy, distribute and/or modify this document
+ under the terms of the <acronym>GNU</acronym> General Public License,
+ Version 2 or any later version published by the Free Software Foundation.
+ </para>
+ <para>
+ On Debian systems, the complete text of the GNU General Public
+ License can be found in
+ <filename>/usr/share/common-licenses/GPL</filename>.
+ </para>
+ </refsect1>
+</refentry>
diff --git a/ubuntu/maverick/applications/kerry/debian/patches/kubuntu_03_no_beagle_autostart.patch b/ubuntu/maverick/applications/kerry/debian/patches/kubuntu_03_no_beagle_autostart.patch
new file mode 100644
index 000000000..cbd096957
--- /dev/null
+++ b/ubuntu/maverick/applications/kerry/debian/patches/kubuntu_03_no_beagle_autostart.patch
@@ -0,0 +1,12 @@
+diff -Nur kerry-0.2.1/kerry/src/Makefile.am kerry-0.2.1.new/kerry/src/Makefile.am
+--- kerry-0.2.1/kerry/src/Makefile.am 2006-12-05 18:28:31.000000000 +0100
++++ kerry-0.2.1.new/kerry/src/Makefile.am 2006-12-05 18:28:53.000000000 +0100
+@@ -31,7 +31,7 @@
+ kerry_la_LIBADD = -lkio -lkonq $(LIB_KDEUI) $(LIBBEAGLE_LIBADD) $(GLIB_LIBADD) $(LIB_KABC)
+
+ autostartdir = $(datadir)/autostart
+-autostart_DATA = kerry.autostart.desktop beagled.desktop
++autostart_DATA = kerry.autostart.desktop
+
+ shutdowndir = $(prefix)/bin
+ shutdown_SCRIPTS = beagled-shutdown.sh
diff --git a/ubuntu/maverick/applications/kerry/debian/patches/kubuntu_04_no_core_kmenu_entry.desktop.patch b/ubuntu/maverick/applications/kerry/debian/patches/kubuntu_04_no_core_kmenu_entry.desktop.patch
new file mode 100644
index 000000000..bc560f754
--- /dev/null
+++ b/ubuntu/maverick/applications/kerry/debian/patches/kubuntu_04_no_core_kmenu_entry.desktop.patch
@@ -0,0 +1,19 @@
+diff -Nur -x '*.orig' -x '*~' kerry-0.2.1/kerry/src/kerry.desktop kerry-0.2.1.new/kerry/src/kerry.desktop
+--- kerry-0.2.1/kerry/src/kerry.desktop 2006-12-04 14:35:38.000000000 +0100
++++ kerry-0.2.1.new/kerry/src/kerry.desktop 2008-04-08 22:55:31.000000000 +0200
+@@ -1,6 +1,5 @@
+ [Desktop Entry]
+ X-SuSE-translate=true
+-Encoding=UTF-8
+ Name=Kerry Beagle
+ GenericName=Desktop Search
+ GenericName[ar]=بحث على سطح المكتب
+@@ -25,7 +24,7 @@
+ Exec=kerry --show-searchdialog
+ Icon=kerry
+ Type=Application
+-Categories=Qt;KDE;Application;Core;Utility;Filesystem;
++Categories=Qt;KDE;Application;Utility;Filesystem;
+ Terminal=false
+ X-DCOP-ServiceType=Unique
+ X-KDE-StartupNotify=false
diff --git a/ubuntu/maverick/applications/kerry/debian/patches/kubuntu_05_shortkey.patch b/ubuntu/maverick/applications/kerry/debian/patches/kubuntu_05_shortkey.patch
new file mode 100644
index 000000000..6478949f6
--- /dev/null
+++ b/ubuntu/maverick/applications/kerry/debian/patches/kubuntu_05_shortkey.patch
@@ -0,0 +1,13 @@
+diff -Nur kerry-0.2.1/kerry/src/kerryapp.cpp kerry-0.2.1.new/kerry/src/kerryapp.cpp
+--- kerry-0.2.1/kerry/src/kerryapp.cpp 2006-12-04 14:35:38.000000000 +0100
++++ kerry-0.2.1.new/kerry/src/kerryapp.cpp 2006-12-05 18:30:44.000000000 +0100
+@@ -122,8 +122,7 @@
+ globalKeys = new KGlobalAccel(this);
+ globalKeys->insert( "Program:kerry", i18n("Kerry Beagle Search") );
+
+- KShortcut showDialogShortcut = KShortcut(ALT+Key_Space);
+- showDialogShortcut.append( KKey( Key_F12 ) );
++ KShortcut showDialogShortcut = KShortcut(CTRL+SHIFT+Key_Space);
+ globalKeys->insert( "Show Kerry Dialog", i18n("Show Search Dialog"), QString::null, showDialogShortcut, showDialogShortcut, hitListWindow, SLOT(showSearchDialog()) );
+ globalKeys->insert( "Search Primary Selection with Kerry", i18n("Search Primary Selection"), QString::null, CTRL+ALT+Key_Space, CTRL+ALT+Key_Space, this, SLOT(searchPrimarySelection()) );
+ configChanged();
diff --git a/ubuntu/maverick/applications/kerry/debian/postinst b/ubuntu/maverick/applications/kerry/debian/postinst
new file mode 100644
index 000000000..98c4063a3
--- /dev/null
+++ b/ubuntu/maverick/applications/kerry/debian/postinst
@@ -0,0 +1,12 @@
+#!/bin/sh
+# postinst script for kerry-trinity
+
+set -e
+
+if [ "$1" = "configure" ] ; then
+ ldconfig
+fi
+
+#DEBHELPER#
+
+exit 0
diff --git a/ubuntu/maverick/applications/kerry/debian/postrm b/ubuntu/maverick/applications/kerry/debian/postrm
new file mode 100644
index 000000000..d1ae3b96c
--- /dev/null
+++ b/ubuntu/maverick/applications/kerry/debian/postrm
@@ -0,0 +1,12 @@
+#!/bin/sh
+# postrm script for kerry-trinity
+
+set -e
+
+if [ "$1" = "remove" ] ; then
+ ldconfig
+fi
+
+#DEBHELPER#
+
+exit 0
diff --git a/ubuntu/maverick/applications/kerry/debian/rules b/ubuntu/maverick/applications/kerry/debian/rules
new file mode 100755
index 000000000..8689ee969
--- /dev/null
+++ b/ubuntu/maverick/applications/kerry/debian/rules
@@ -0,0 +1,32 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+# include /usr/share/cdbs/1/class/kde.mk
+include debian/cdbs/debian-qt-kde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
+
+DEB_INSTALL_MANPAGES_kerry-trinity = kerry.1
+
+build/kerry-trinity::
+ docbook2x-man debian/kerry.1.docbook
+
+clean::
+ rm -f kerry.1
+
+binary-post-install/kerry-trinity::
+ chrpath -d debian/kerry-trinity/opt/trinity/lib/libkdeinit_kerry.so
+ chrpath -d debian/kerry-trinity/opt/trinity/bin/kerry
+ chrpath -d debian/kerry-trinity/opt/trinity/lib/kde3/kerry.so
+ chrpath -d debian/kerry-trinity/opt/trinity/lib/kde3/kcm_beagle.so
+ mkdir -p debian/kerry-trinity/opt/trinity/share/man/man1/
+ mv debian/kerry-trinity/usr/share/man/man1/kerry.1 debian/kerry-trinity/opt/trinity/share/man/man1/kerry.1
+ rm -rf debian/kerry-trinity/usr/share/man