summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/kiosktool/debian/cdbs
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-09-22 15:42:46 +0200
committerSlávek Banko <slavek.banko@axis.cz>2018-09-22 15:43:47 +0200
commit0d7bf314821cfb57fdd61033b855d70ef06bc3d7 (patch)
tree3a5af11e80cee21e672a6500c147859f901eae39 /ubuntu/maverick/applications/kiosktool/debian/cdbs
parent956611c1a1339d4bd39397d1971b34553ebf0788 (diff)
downloadtde-packaging-0d7bf314821cfb57fdd61033b855d70ef06bc3d7.tar.gz
tde-packaging-0d7bf314821cfb57fdd61033b855d70ef06bc3d7.zip
DEB kiosktool: Switch to cmake
The man page has been moved to the main tree Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ubuntu/maverick/applications/kiosktool/debian/cdbs')
-rw-r--r--ubuntu/maverick/applications/kiosktool/debian/cdbs/debian-qt-kde.mk6
-rw-r--r--ubuntu/maverick/applications/kiosktool/debian/cdbs/kde.mk4
2 files changed, 8 insertions, 2 deletions
diff --git a/ubuntu/maverick/applications/kiosktool/debian/cdbs/debian-qt-kde.mk b/ubuntu/maverick/applications/kiosktool/debian/cdbs/debian-qt-kde.mk
index 9920696ce..32ba4acfb 100644
--- a/ubuntu/maverick/applications/kiosktool/debian/cdbs/debian-qt-kde.mk
+++ b/ubuntu/maverick/applications/kiosktool/debian/cdbs/debian-qt-kde.mk
@@ -10,6 +10,7 @@ _cdbs_class_debian-qt-kde := 1
# Note: This _must_ be included before autotools.mk, or it won't work.
common-configure-arch common-configure-indep:: debian/stamp-cvs-make
debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
@@ -18,10 +19,11 @@ ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
endif
$(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
touch debian/stamp-cvs-make
include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
-include debian/cdbs/uploaders.mk
+#include debian/cdbs/uploaders.mk
ifndef _cdbs_rules_patchsys_quilt
DEB_PATCHDIRS := debian/patches/common debian/patches
@@ -103,6 +105,7 @@ binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
done
clean::
+ifndef _cdbs_class_cmake
if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
cd $(DEB_SRCDIR); \
find . -name Makefile.in -print | \
@@ -111,6 +114,7 @@ clean::
configure configure.files configure.in stamp-h.in \
subdirs; \
fi
+endif
rm -f debian/stamp-cvs-make
endif
diff --git a/ubuntu/maverick/applications/kiosktool/debian/cdbs/kde.mk b/ubuntu/maverick/applications/kiosktool/debian/cdbs/kde.mk
index 765560c89..023886fc8 100644
--- a/ubuntu/maverick/applications/kiosktool/debian/cdbs/kde.mk
+++ b/ubuntu/maverick/applications/kiosktool/debian/cdbs/kde.mk
@@ -35,7 +35,9 @@ else
DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
endif
+ifndef _cdbs_class_cmake
include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
export kde_cgidir = \$${libdir}/cgi-bin
export kde_confdir = \$${sysconfdir}/trinity
@@ -59,7 +61,7 @@ endif
cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/tde"
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%: