summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/tdeio-apt/debian/rules
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-03-06 14:38:41 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-03-06 14:38:41 -0600
commite473251d6d5a894f939a57e580e38e9e96b9cd69 (patch)
treed28b7cf287c6fcd65ebdb01573389885e2133ebc /ubuntu/maverick/applications/tdeio-apt/debian/rules
parent309f28e865c2733f3752110254ba8c227b980876 (diff)
downloadtde-packaging-e473251d6d5a894f939a57e580e38e9e96b9cd69.tar.gz
tde-packaging-e473251d6d5a894f939a57e580e38e9e96b9cd69.zip
Update Debian and Ubuntu packaging to match new module names
Diffstat (limited to 'ubuntu/maverick/applications/tdeio-apt/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/tdeio-apt/debian/rules38
1 files changed, 38 insertions, 0 deletions
diff --git a/ubuntu/maverick/applications/tdeio-apt/debian/rules b/ubuntu/maverick/applications/tdeio-apt/debian/rules
new file mode 100755
index 000000000..f9ce7782e
--- /dev/null
+++ b/ubuntu/maverick/applications/tdeio-apt/debian/rules
@@ -0,0 +1,38 @@
+#!/usr/bin/make -f
+DEB_PATCH_SUFFIX = .patch .dpatch
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+include debian/cdbs/kde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/tde
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap
+
+configure/tdeio-apt-trinity::
+ #fix rpath issue
+ # -chmod +x debian/fixrpath
+ # debian/fixrpath $(DEB_BUILDDIR)
+
+install/tdeio-apt-trinity::
+ uudecode debian/kdedeb_logo.png.uu -o $(DEB_DESTDIR)/opt/trinity/share/apps/tdeio_apt/kdedeb_logo.png