summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/tdeio-ftps/debian
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2019-04-03 22:56:40 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2019-04-03 22:56:40 +0900
commit11394aecd1f906fee2ebd2b90412aeba4651fbff (patch)
treebcf750380e6d9fc7dbe524e16bbe2afde25dcfa0 /ubuntu/maverick/applications/tdeio-ftps/debian
parentd24bd898174453b586ac90f2ef7a60165fa26fde (diff)
downloadtde-packaging-11394aecd1f906fee2ebd2b90412aeba4651fbff.tar.gz
tde-packaging-11394aecd1f906fee2ebd2b90412aeba4651fbff.zip
DEB: use _base folder for a distro instead of specific distros (squeeze
and maverick). Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'ubuntu/maverick/applications/tdeio-ftps/debian')
-rw-r--r--ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/debian-qt-kde.mk119
-rw-r--r--ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/kde.mk91
-rw-r--r--ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/versions.pl19
-rw-r--r--ubuntu/maverick/applications/tdeio-ftps/debian/changelog36
-rw-r--r--ubuntu/maverick/applications/tdeio-ftps/debian/compat1
-rw-r--r--ubuntu/maverick/applications/tdeio-ftps/debian/control19
-rw-r--r--ubuntu/maverick/applications/tdeio-ftps/debian/copyright34
-rw-r--r--ubuntu/maverick/applications/tdeio-ftps/debian/docs2
-rwxr-xr-xubuntu/maverick/applications/tdeio-ftps/debian/rules24
-rw-r--r--ubuntu/maverick/applications/tdeio-ftps/debian/source/format1
-rw-r--r--ubuntu/maverick/applications/tdeio-ftps/debian/source/options6
11 files changed, 0 insertions, 352 deletions
diff --git a/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/debian-qt-kde.mk b/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/debian-qt-kde.mk
deleted file mode 100644
index 60310a01a..000000000
--- a/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/debian-qt-kde.mk
+++ /dev/null
@@ -1,119 +0,0 @@
-ifndef _cdbs_bootstrap
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-endif
-
-ifndef _cdbs_class_debian-qt-kde
-_cdbs_class_debian-qt-kde := 1
-
-# Note: This _must_ be included before autotools.mk, or it won't work.
-common-configure-arch common-configure-indep:: debian/stamp-cvs-make
-debian/stamp-cvs-make:
-ifndef _cdbs_class_cmake
- cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
-endif
- touch debian/stamp-cvs-make
-
-include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
-
-ifndef _cdbs_rules_patchsys_quilt
-DEB_PATCHDIRS := debian/patches/common debian/patches
-endif
-
-DEB_KDE_ENABLE_FINAL := yes
-DEB_INSTALL_DOCS_ALL :=
-
-DEB_DH_MAKESHLIBS_ARGS_ALL := -V
-DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
-
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
- ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
- else
- cdbs_kde_enable_final =
- endif
-endif
-
-common-build-arch:: debian/stamp-man-pages
-debian/stamp-man-pages:
- if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
- for f in $$(find debian/man -name '*.sgml'); do \
- docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
- done
- for f in $$(find debian/man -name '*.man'); do \
- soelim -I debian/man $$f \
- > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
- done
- touch debian/stamp-man-pages
-
-common-binary-indep::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_INDEP_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-common-binary-arch::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_ARCH_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-clean::
- rm -rf debian/man/out
- -rmdir debian/man
- rm -f debian/stamp-man-pages
- rm -rf debian/shlibs-check
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
- if test -e debian/$(cdbs_curpkg).lintian; then \
- install -p -D -m644 debian/$(cdbs_curpkg).lintian \
- debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
- fi
- if test -e debian/$(cdbs_curpkg).presubj; then \
- install -p -D -m644 debian/$(cdbs_curpkg).presubj \
- debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
- fi
-
-binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
- set -e; \
- for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
- pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
- echo Building $$pkg HTML docs...; \
- mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
- done
- for pkg in $(DOC_HTML_PRUNE) ; do \
- rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- done
-
-clean::
-ifndef _cdbs_class_cmake
- if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
- cd $(DEB_SRCDIR); \
- find . -name Makefile.in -print | \
- xargs --no-run-if-empty rm -f; \
- rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
- configure configure.files configure.in stamp-h.in \
- subdirs; \
- fi
-endif
- rm -f debian/stamp-cvs-make
-
-endif
diff --git a/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/kde.mk b/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/kde.mk
deleted file mode 100644
index 80176d63e..000000000
--- a/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/kde.mk
+++ /dev/null
@@ -1,91 +0,0 @@
-# -*- mode: makefile; coding: utf-8 -*-
-# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
-# Description: A class for KDE packages; sets KDE environment variables, etc
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-# 02111-1307 USA.
-
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-
-ifndef _cdbs_class_kde
-_cdbs_class_kde := 1
-
-# for dh_icons
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
-
-include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
-
-ifdef _cdbs_tarball_dir
-DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
-else
-DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
-endif
-
-ifndef _cdbs_class_cmake
-include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
-endif
-
-export kde_cgidir = \$${libdir}/cgi-bin
-export kde_confdir = \$${sysconfdir}/trinity
-export kde_htmldir = \$${datadir}/doc/tde/HTML
-
-ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
-endif
-
-ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final =
- cdbs_kde_enable_debug = --enable-debug=yes
-else
- cdbs_kde_enable_debug = --disable-debug
-endif
-
-ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_debug = --enable-debug=full
-endif
-
-cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
-
-cleanbuilddir::
- -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
-
-common-build-arch common-build-indep:: debian/stamp-kde-apidox
-debian/stamp-kde-apidox:
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
- touch $@
-
-common-install-arch common-install-indep:: common-install-kde-apidox
-common-install-kde-apidox::
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
-
-clean::
- rm -f debian/stamp-kde-apidox
-
-# This is a convenience target for calling manually. It's not part of
-# the build process.
-buildprep: clean apply-patches
- $(MAKE) -f admin/Makefile.common dist
- debian/rules clean
-
-endif
diff --git a/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/versions.pl b/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/versions.pl
deleted file mode 100644
index 1b110f7af..000000000
--- a/ubuntu/maverick/applications/tdeio-ftps/debian/cdbs/versions.pl
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/env perl
-
-use strict;
-use warnings;
-
-my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
-my ($version3, $version3_next);
-my ($version2, $version2_next);
-
-($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
-($version2 = $version3) =~ s/\.[^.]+$//;
-
-($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
-($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
-
-print "TDE-Version3=$version3\n";
-print "TDE-Version2=$version2\n";
-print "TDE-Next-Version3=$version3_next\n";
-print "TDE-Next-Version2=$version2_next\n";
diff --git a/ubuntu/maverick/applications/tdeio-ftps/debian/changelog b/ubuntu/maverick/applications/tdeio-ftps/debian/changelog
deleted file mode 100644
index 08c670539..000000000
--- a/ubuntu/maverick/applications/tdeio-ftps/debian/changelog
+++ /dev/null
@@ -1,36 +0,0 @@
-tdeio-ftps-trinity (0.1-0ubuntu3+build2) hardy; urgency=low
-
- * Initial Release for TDE
-
- -- Slávek Banko <slavek.banko@axis.cz> Sat, 27 Jul 2013 12:21:12 +0200
-
-kio-ftps (0.1-0ubuntu3+build2) hardy; urgency=low
-
- * Ported to hardy
-
- -- Jakub Dvorak <nytmyn@gmail.com> Sat, 26 Jul 2008 20:45:28 +0200
-
-kio-ftps (0.1-0ubuntu3) gutsy; urgency=low
-
- * Changed distribution to gutsy
-
- -- Jakub Dvorak <nytmyn@gmail.com> Sat, 26 Jul 2008 20:45:18 +0200
-
-kio-ftps (0.1-0ubuntu2) feisty; urgency=low
-
- [ Marcus Czeslinski ]
- * debian/rules: add --libdir=/usr/lib/kde3 to DEB_CONFIGURE_EXTRA_FLAGS
- to install into kde3 Libs directory
-
- [ Jakub Dvorak ]
- *
-
- -- Jakub Dvorak <nytmyn@gmail.com> Tue, 18 Dec 2007 10:05:23 +0100
-
-kio-ftps (0.1-0k
-ubuntu1) feisty; urgency=low
-
- * Initial release
-
- -- Marcus Czeslinski <kubuntu@czessi.net> Tue, 17 Apr 2007 15:56:22 +0200
-
diff --git a/ubuntu/maverick/applications/tdeio-ftps/debian/compat b/ubuntu/maverick/applications/tdeio-ftps/debian/compat
deleted file mode 100644
index 7f8f011eb..000000000
--- a/ubuntu/maverick/applications/tdeio-ftps/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-7
diff --git a/ubuntu/maverick/applications/tdeio-ftps/debian/control b/ubuntu/maverick/applications/tdeio-ftps/debian/control
deleted file mode 100644
index ded3d5042..000000000
--- a/ubuntu/maverick/applications/tdeio-ftps/debian/control
+++ /dev/null
@@ -1,19 +0,0 @@
-Source: tdeio-ftps-trinity
-Section: tde
-Priority: optional
-Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
-Build-Depends: debhelper (>= 7.0.50~), cdbs, cmake, tdelibs14-trinity-dev
-Standards-Version: 3.8.3
-
-Package: tdeio-ftps-trinity
-Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}
-Description: an ftps TDEIO slave for TDE
- tdeio-ftps-trinity is an ftps TDEIO slave for TDE, based on rfc4217 and
- build upon the ftp TDEIO-slave sources. tdeio-ftps-trinity should work
- yet with most server implementations It issues an "AUTH TLS"
- command after connecting and refuses to continue, when it's
- not supported.
- .
- Homepage: http://kasablanca.berlios.de/kio-ftps/
-
diff --git a/ubuntu/maverick/applications/tdeio-ftps/debian/copyright b/ubuntu/maverick/applications/tdeio-ftps/debian/copyright
deleted file mode 100644
index bcb77e6d0..000000000
--- a/ubuntu/maverick/applications/tdeio-ftps/debian/copyright
+++ /dev/null
@@ -1,34 +0,0 @@
-This package was debianized by Marcus Czeslinski <kubuntu@czessi.net> on
-Tue, 17 Apr 2007 15:56:22 +0200.
-
-It was downloaded from http://kasablanca.berlios.de/kio-ftps/
-
-Upstream Author: David Faure <faure@kde.org>, Magnus Kulke <magnus.kulke@radicalapproach.de>
-
-Copyright: 2006, David Faure <faure@kde.org>, Magnus Kulke <magnus.kulke@radicalapproach.de>
-
-License:
-
- This package is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 2 of the License, or
- (at your option) any later version.
-
- This package is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this package; if not, write to the Free Software
- Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
-
-On Debian systems, the complete text of the GNU General
-Public License can be found in `/usr/share/common-licenses/GPL'.
-
-The Debian packaging is (C) 2007, Marcus Czeslinski <kubuntu@czessi.net> and
-is licensed under the GPL, see above.
-
-
-# Please also look if there are files or directories which have a
-# different copyright/license attached and list them here.
diff --git a/ubuntu/maverick/applications/tdeio-ftps/debian/docs b/ubuntu/maverick/applications/tdeio-ftps/debian/docs
deleted file mode 100644
index 6f12db508..000000000
--- a/ubuntu/maverick/applications/tdeio-ftps/debian/docs
+++ /dev/null
@@ -1,2 +0,0 @@
-AUTHORS
-README
diff --git a/ubuntu/maverick/applications/tdeio-ftps/debian/rules b/ubuntu/maverick/applications/tdeio-ftps/debian/rules
deleted file mode 100755
index 4c83c4c6d..000000000
--- a/ubuntu/maverick/applications/tdeio-ftps/debian/rules
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/usr/bin/make -f
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/cmake.mk
-#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-include debian/cdbs/debian-qt-kde.mk
-
-# Honour "parallel=N" option of DEB_BUILD_OPTIONS. Comment out to
-# never build in parallel, regardless of DEB_BUILD_OPTIONS.
-DEB_BUILD_PARALLEL = true
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-DEB_CMAKE_EXTRA_FLAGS := \
- -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
- -DCONFIG_INSTALL_DIR="/etc/trinity" \
- -DSYSCONF_INSTALL_DIR="/etc/trinity" \
- -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_VERBOSE_MAKEFILE="ON" \
- -DCMAKE_SKIP_RPATH="OFF" \
- -DBUILD_ALL="ON" \
- -DWITH_ALL_OPTIONS="ON"
diff --git a/ubuntu/maverick/applications/tdeio-ftps/debian/source/format b/ubuntu/maverick/applications/tdeio-ftps/debian/source/format
deleted file mode 100644
index 163aaf8d8..000000000
--- a/ubuntu/maverick/applications/tdeio-ftps/debian/source/format
+++ /dev/null
@@ -1 +0,0 @@
-3.0 (quilt)
diff --git a/ubuntu/maverick/applications/tdeio-ftps/debian/source/options b/ubuntu/maverick/applications/tdeio-ftps/debian/source/options
deleted file mode 100644
index 72f1f5450..000000000
--- a/ubuntu/maverick/applications/tdeio-ftps/debian/source/options
+++ /dev/null
@@ -1,6 +0,0 @@
-# Use xz instead of gzip
-compression = "xz"
-compression-level = 9
-
-# Don't run differences
-diff-ignore = .*