summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/tdmtheme/debian
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-01-22 00:20:07 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-01-22 00:20:07 -0600
commit96dbf4dcb1e04571363422a97649fc929b35beb8 (patch)
treead8c3a9d2d4c1e9919a30ec7663e3f0b64e7d8f9 /ubuntu/maverick/applications/tdmtheme/debian
parent80e4199df2ac852cfb22848698cabe9ba28e5a67 (diff)
downloadtde-packaging-96dbf4dcb1e04571363422a97649fc929b35beb8.tar.gz
tde-packaging-96dbf4dcb1e04571363422a97649fc929b35beb8.zip
Second part of prior commit
Diffstat (limited to 'ubuntu/maverick/applications/tdmtheme/debian')
-rw-r--r--ubuntu/maverick/applications/tdmtheme/debian/README.Debian7
-rw-r--r--ubuntu/maverick/applications/tdmtheme/debian/cdbs/buildvars.mk86
-rw-r--r--ubuntu/maverick/applications/tdmtheme/debian/cdbs/debian-qt-kde.mk109
-rw-r--r--ubuntu/maverick/applications/tdmtheme/debian/cdbs/kde.mk97
-rw-r--r--ubuntu/maverick/applications/tdmtheme/debian/cdbs/team-members16
-rw-r--r--ubuntu/maverick/applications/tdmtheme/debian/cdbs/uploaders.mk29
-rw-r--r--ubuntu/maverick/applications/tdmtheme/debian/cdbs/versions.pl19
-rw-r--r--ubuntu/maverick/applications/tdmtheme/debian/changelog123
-rw-r--r--ubuntu/maverick/applications/tdmtheme/debian/compat1
-rw-r--r--ubuntu/maverick/applications/tdmtheme/debian/control19
-rw-r--r--ubuntu/maverick/applications/tdmtheme/debian/copyright46
-rw-r--r--ubuntu/maverick/applications/tdmtheme/debian/docs1
-rw-r--r--ubuntu/maverick/applications/tdmtheme/debian/patches/.gitignore0
-rwxr-xr-xubuntu/maverick/applications/tdmtheme/debian/rules38
-rw-r--r--ubuntu/maverick/applications/tdmtheme/debian/source/format1
-rw-r--r--ubuntu/maverick/applications/tdmtheme/debian/source/options6
-rw-r--r--ubuntu/maverick/applications/tdmtheme/debian/tdmtheme.lintian-overrides6
-rw-r--r--ubuntu/maverick/applications/tdmtheme/debian/watch2
18 files changed, 606 insertions, 0 deletions
diff --git a/ubuntu/maverick/applications/tdmtheme/debian/README.Debian b/ubuntu/maverick/applications/tdmtheme/debian/README.Debian
new file mode 100644
index 000000000..066828faf
--- /dev/null
+++ b/ubuntu/maverick/applications/tdmtheme/debian/README.Debian
@@ -0,0 +1,7 @@
+tdmtheme for Debian
+-------------------
+
+tdmtheme is a KDE Control Module (KCM). To run it, open KDE Control Center and
+go to System Administration to find TDM Theme Manager.
+
+ -- Fathi Boudra <fabo@debian.org>, Mon, 31 Jul 2006 18:33:26 +0200
diff --git a/ubuntu/maverick/applications/tdmtheme/debian/cdbs/buildvars.mk b/ubuntu/maverick/applications/tdmtheme/debian/cdbs/buildvars.mk
new file mode 100644
index 000000000..23d4709dc
--- /dev/null
+++ b/ubuntu/maverick/applications/tdmtheme/debian/cdbs/buildvars.mk
@@ -0,0 +1,86 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2002,2003 Colin Walters <walters@debian.org>
+# Description: Defines some useful variables, but no rules
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_rules_buildvars
+_cdbs_rules_buildvars = 1
+
+CDBS_VERSION = something
+
+# Common useful variables
+DEB_SOURCE_PACKAGE := $(strip $(shell egrep '^Source: ' debian/control | cut -f 2 -d ':'))
+DEB_VERSION := $(shell dpkg-parsechangelog | egrep '^Version:' | cut -f 2 -d ' ')
+DEB_NOEPOCH_VERSION := $(shell echo $(DEB_VERSION) | cut -d: -f2-)
+DEB_UPSTREAM_VERSION := $(shell echo $(DEB_NOEPOCH_VERSION) | sed 's/-[^-]*$$//')
+DEB_ISNATIVE := $(shell dpkg-parsechangelog | egrep '^Version:' | perl -ne 'print if not /^Version:\s*.*-/;')
+
+# Split into arch/indep packages
+ifneq ($(DEB_INDEP_PACKAGES),cdbs)
+DEB_INDEP_PACKAGES := $(filter-out $(DONT_BUILD), $(strip $(shell $(_cdbs_scripts_path)/list-packages indep)))
+DEB_ARCH_PACKAGES := $(filter-out $(DONT_BUILD), $(filter-out $(DEB_INDEP_PACKAGES),$(strip $(shell $(_cdbs_scripts_path)/list-packages same))))
+endif
+# Split into normal and udeb packages
+ifeq ($(DEB_UDEB_PACKAGES),)
+DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+DEB_UDEB_PACKAGES = $(filter-out $(DONT_BUILD),$(filter %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+else
+DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES), $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+endif
+# Too much bother for now. If someone complains we'll fix it.
+#DEB_ARCH_UDEB_PACKAGES = $(filter %-udeb, $(DEB_ARCH_PACKAGES))
+#DEB_INDEP_UDEB_PACKAGES = $(filter %-udeb, $(DEB_INDEP_PACKAGES))
+# A handy list of every package, udeb or not
+DEB_ALL_PACKAGES = $(filter-out $(DONT_BUILD),$(DEB_PACKAGES) $(DEB_UDEB_PACKAGES))
+DEB_INDEP_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_INDEP_PACKAGES)))
+DEB_ARCH_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_ARCH_PACKAGES)))
+
+DEB_DBG_PACKAGES = $(filter-out $(DONT_BUILD), $(filter %-dbg, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+
+# Some support for srcdir != builddir builds.
+# These are relative to the root of the package
+DEB_SRCDIR ?= .
+DEB_BUILDDIR ?= $(strip $(DEB_SRCDIR))
+
+# Miscellaneous bits
+DEB_ARCH = $(shell dpkg --print-architecture)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_HOST_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_HOST_GNU_SYSTEM)
+DEB_HOST_GNU_CPU ?= $(shell dpkg-architecture -qDEB_HOST_GNU_CPU)
+DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
+DEB_HOST_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
+DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_BUILD_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_SYSTEM)
+DEB_BUILD_GNU_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_CPU)
+DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
+DEB_BUILD_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU)
+DEB_BUILD_ARCH_OS ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)
+
+ifeq ($(words $(DEB_ALL_PACKAGES)),1)
+ DEB_DESTDIR = $(CURDIR)/debian/$(strip $(DEB_ALL_PACKAGES))/
+else
+ DEB_DESTDIR = $(CURDIR)/debian/tmp/
+endif
+
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), cdbs (>= 0.4.23-1.1)
+
+endif
diff --git a/ubuntu/maverick/applications/tdmtheme/debian/cdbs/debian-qt-kde.mk b/ubuntu/maverick/applications/tdmtheme/debian/cdbs/debian-qt-kde.mk
new file mode 100644
index 000000000..47e83ef4a
--- /dev/null
+++ b/ubuntu/maverick/applications/tdmtheme/debian/cdbs/debian-qt-kde.mk
@@ -0,0 +1,109 @@
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+ touch debian/stamp-cvs-make
+
+include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
+include debian/cdbs/uploaders.mk
+
+DEB_PATCHDIRS := debian/patches/common debian/patches
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/kde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/kde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/kde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/kde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/kde/HTML/en/$$pkg; \
+ done
+
+clean::
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/ubuntu/maverick/applications/tdmtheme/debian/cdbs/kde.mk b/ubuntu/maverick/applications/tdmtheme/debian/cdbs/kde.mk
new file mode 100644
index 000000000..5b6508f8c
--- /dev/null
+++ b/ubuntu/maverick/applications/tdmtheme/debian/cdbs/kde.mk
@@ -0,0 +1,97 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Description: A class for KDE packages; sets KDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_class_kde
+_cdbs_class_kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/kde/HTML
+
+ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/kde"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+common-build-arch common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-prehook-impl::
+ mkdir -p po
+ -XGETTEXT=/usr/bin/kde-xgettext EXTRACTATTR=/opt/trinity/bin/extractattr sh $(DEB_SRCDIR)/admin/cvs.sh extract-messages
+ -for file in po/*pot; do \
+ sed "s/charset=CHARSET/charset=UTF-8/" -i $$file; \
+ done
+
+common-install-arch common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+
+clean::
+ rm -f debian/stamp-kde-apidox
+ rm -rf po/*.pot
+
+# This is a convenience target for calling manually. It's not part of
+# the build process.
+buildprep: clean apply-patches
+ $(MAKE) -f admin/Makefile.common dist
+ debian/rules clean
+
+endif
diff --git a/ubuntu/maverick/applications/tdmtheme/debian/cdbs/team-members b/ubuntu/maverick/applications/tdmtheme/debian/cdbs/team-members
new file mode 100644
index 000000000..05761af6e
--- /dev/null
+++ b/ubuntu/maverick/applications/tdmtheme/debian/cdbs/team-members
@@ -0,0 +1,16 @@
+Sune Vuorela <debian@pusling.com>
+Ana Beatriz Guerrero Lopez <ana@debian.org>
+Fathi Boudra <fboudra@free.fr>
+Modestas Vainius <geromanas@mailas.com>
+Josh Metzler <joshdeb@metzlers.org>
+Isaac Clerencia <isaac@debian.org>
+Adeodato Simó <dato@net.com.org.es>
+Adeodato Simo <dato@net.com.org.es>
+Christopher Martin <chrsmrtn@debian.org>
+Daniel Schepler <schepler@debian.org>
+Sarah Hobbs <hobbsee@ubuntu.com>
+Nacho Barrientos Arias <nacho@debian.org>
+Ricardo Javier Cardenes Medina <rcardenes@debian.org>
+Ricardo Cardenes <rcardenes@debian.org>
+Armin Berres <trigger+debian@space-based.de>
+Francesco Pedrini <francesco.pedrini@gmail.com>
diff --git a/ubuntu/maverick/applications/tdmtheme/debian/cdbs/uploaders.mk b/ubuntu/maverick/applications/tdmtheme/debian/cdbs/uploaders.mk
new file mode 100644
index 000000000..31adfe31e
--- /dev/null
+++ b/ubuntu/maverick/applications/tdmtheme/debian/cdbs/uploaders.mk
@@ -0,0 +1,29 @@
+
+MAINTAINER=Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
+UPLOADERS=$(shell grep -e +++ -e "^ -- " debian/changelog | grep -v "debian-qt-kde@lists.debian.org" | head -13 | /bin/sed 's/^\s*//;s/\s*$$//;s/^+++\? Changes by //;s/^+++\? //;s/-- //;s/:$$//;s/ <.*//' | sort -u | while read line ; do grep "$$line" debian/cdbs/team-members ; done | tr "\n" ", " | sed 's/,/, /g;s/, $$//')
+
+
+debian/control.tmp:
+ @if [ ! -e debian/control.in ] ; then \
+ echo "this package is not yet prepared for using automatic update of uploaders"; \
+ echo "Please do so."; \
+ exit 1; \
+ fi
+ @sed 's/@@@UPLOADERS@@@/$(UPLOADERS)/;s#@@@MAINTAINER@@@#$(MAINTAINER)#' debian/control.in > debian/control.tmp
+
+check-uploaders: debian/control.tmp
+ @if ! diff -q debian/control debian/control.tmp ; then \
+ echo "WARNING:: Control file differs from manually generated one" ; \
+ echo "WARNING:: Please update it manually and check it afterwards" ; \
+ echo "WARNING:: Uploaders are updated by debian/rules update-uploaders" ;\
+ echo "WARNING:: If this is a binNMU, NMU or security upload, just ignore" ;\
+ fi
+
+
+clean::
+ rm -f debian/control.tmp
+
+update-uploaders: debian/control.tmp
+ @mv -f debian/control.tmp debian/control
+
+makebuilddir:: check-uploaders
diff --git a/ubuntu/maverick/applications/tdmtheme/debian/cdbs/versions.pl b/ubuntu/maverick/applications/tdmtheme/debian/cdbs/versions.pl
new file mode 100644
index 000000000..9ce11d8a3
--- /dev/null
+++ b/ubuntu/maverick/applications/tdmtheme/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/-[^-]+$//;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "KDE-Version3=$version3\n";
+print "KDE-Version2=$version2\n";
+print "KDE-Next-Version3=$version3_next\n";
+print "KDE-Next-Version2=$version2_next\n";
diff --git a/ubuntu/maverick/applications/tdmtheme/debian/changelog b/ubuntu/maverick/applications/tdmtheme/debian/changelog
new file mode 100644
index 000000000..4097b1255
--- /dev/null
+++ b/ubuntu/maverick/applications/tdmtheme/debian/changelog
@@ -0,0 +1,123 @@
+tdmtheme-trinity (1.2.2-1ubuntu5) karmic; urgency=low
+
+ * Karmic rebuild
+ * Fixed theme switching problem
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 July 2009 16:08:00 -0600
+
+tdmtheme-trinity (1.2.2-1ubuntu1) intrepid; urgency=low
+
+ * Added -trinity suffix
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Mon, 27 Apr 2009 19:00:00 -0600
+
+tdmtheme (1.2.2-1ubuntu1) intrepid; urgency=low
+
+ [ Sergey Rudchenko ]
+ * Merge from debian unstable, remaining changes:
+ * kubuntu_02_confchanges.diff. Patch from Stefan Skotte
+ * kubuntu_01_kcm_systemsettings.diff - kcm module inclusion in the Appearance section
+
+ [ Harald Sitter ]
+ * Remove Homepage from long description
+
+ -- Harald Sitter <apachelogger@ubuntu.com> Fri, 06 Jun 2008 00:46:45 +0200
+
+tdmtheme (1.2.2-1) unstable; urgency=low
+
+ * New upstream release:
+ * actually saves theme changes (Closes: #447683)
+ * does not crash kcontrol when opened as user (Closes: #435946)
+ * Update e-mail addresses.
+ * Bump Standards-Version to 3.7.3.
+ * Use Homepage field.
+
+ [ Kel Modderman ]
+ * Refresh debian/patches/10_tdmtheme-override-warning.diff to apply against
+ new upstream release.
+
+ [ Fathi Boudra ]
+ * Build with --as-needed linker flag.
+
+ -- Fathi Boudra <fabo@debian.org> Sat, 22 Dec 2007 15:36:15 +0100
+
+tdmtheme (1.2.2-0ubuntu2) hardy; urgency=low
+
+ * Re-adds kubuntu_02_confchanges.diff. Patch from Stefan Skotte
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Fri, 15 Feb 2008 10:25:44 +0100
+
+tdmtheme (1.2.2-0ubuntu1) hardy; urgency=low
+
+ * New upstream release.
+ * Removed 10_tdmtheme-override-warning.diff.
+ * Removed kubuntu_02_confchanges.diff.
+ * Updated Standards-Version to 3.7.3
+
+ -- Jonathan Patrick Davies <jpatrick@kubuntu.org> Mon, 22 Dec 2007 11:48:18 +0100
+
+tdmtheme (1.2.1-0ubuntu1) hardy; urgency=low
+
+ * New upstream release.
+ * Merged new Debian changelog and changes to Ubuntu package.
+ * Create kubuntu_02_confchanges.diff - Debian changes to source originally in source.
+ Removes any changes in the *.orig.tar.gz. Patch has also been sent upstream.
+ * Updated kubuntu_01_kcm_systemsettings.diff.
+ * Changed homepage.
+
+ -- Jonathan Patrick Davies <jpatrick@kubuntu.org> Mon, 22 Oct 2007 21:18:56 +0200
+
+tdmtheme (1.2-1) unstable; urgency=low
+
+ * New upstream release.
+ * Update tdmtheme override warning patch.
+ * Add patch to replace deprecated qlist.h include.
+ * Add Build-Depends: quilt, automake1.7.
+ * Update copyright file.
+ * Update watch file.
+
+ -- Fathi Boudra <fboudra@free.fr> Wed, 03 Oct 2007 12:17:40 +0200
+
+tdmtheme (1.2-0ubuntu2) gutsy; urgency=low
+
+ [ Stefan Skotte ]
+ * added support for tdm.d with override files.
+ * various bugfixes for normal tdmrc usage, including save and apply
+ not working, themeDir not set correctly etc.
+
+ [ Sarah Hobbs ]
+ * Modify Maintainer value to match the DebianMaintainerField
+ specification.
+
+ -- Sarah Hobbs <hobbsee@ubuntu.com> Fri, 05 Oct 2007 19:09:00 +1000
+
+tdmtheme (1.2-0ubuntu1) gutsy; urgency=low
+
+ * New upstream release
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Sat, 29 Sep 2007 11:17:55 +0200
+
+tdmtheme (1.1.2-2ubuntu1) feisty; urgency=low
+
+ * Added kubuntu_01_kcm_systemsettings.diff for tde-systemsettings
+ inclusion in the Appearance section
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Tue, 13 Feb 2007 06:18:32 +0100
+
+tdmtheme (1.1.2-2) unstable; urgency=low
+
+ [ Mark Purcell ]
+ * Add debian/rules get-orig-source target for http://buildserver.net.
+
+ [ Fathi Boudra ]
+ * Add a patch to warn users about tdm override files introduced with
+ desktop-base. Thanks to Sune Vuorela.
+
+ -- Fathi Boudra <fboudra@free.fr> Wed, 31 Jan 2007 21:11:45 +0100
+
+tdmtheme (1.1.2-1) unstable; urgency=low
+
+ * Initial release (Closes: #380661)
+
+ -- Fathi Boudra <fboudra@free.fr> Mon, 31 Jul 2006 18:33:26 +0200
+
diff --git a/ubuntu/maverick/applications/tdmtheme/debian/compat b/ubuntu/maverick/applications/tdmtheme/debian/compat
new file mode 100644
index 000000000..7ed6ff82d
--- /dev/null
+++ b/ubuntu/maverick/applications/tdmtheme/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/ubuntu/maverick/applications/tdmtheme/debian/control b/ubuntu/maverick/applications/tdmtheme/debian/control
new file mode 100644
index 000000000..c615c56fd
--- /dev/null
+++ b/ubuntu/maverick/applications/tdmtheme/debian/control
@@ -0,0 +1,19 @@
+Source: tdmtheme-trinity
+Section: kde
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+XSBC-Original-Maintainer: Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>
+Uploaders: Kel Modderman <kel@otaku42.de>, Fathi Boudra <fabo@debian.org>,
+ Mark Purcell <msp@debian.org>
+Build-Depends: cdbs, debhelper (>= 5), quilt, tdelibs4-trinity-dev, automake, autoconf, libtool, libltdl-dev
+Standards-Version: 3.8.4
+Homepage: http://beta.smileaf.org/projects
+
+Package: tdmtheme-trinity
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, tdm-trinity
+Replaces: tdmtheme-trinity (<< 4:14.0.0)
+Breaks: tdmtheme-trinity (<< 4:14.0.0)
+Description: theme manager for TDM [Trinity]
+ tdmtheme is a theme manager for TDM. It provides a KDE Control Module (KCM)
+ that allows you to easily install, remove and change your TDM themes.
diff --git a/ubuntu/maverick/applications/tdmtheme/debian/copyright b/ubuntu/maverick/applications/tdmtheme/debian/copyright
new file mode 100644
index 000000000..c8d6d972f
--- /dev/null
+++ b/ubuntu/maverick/applications/tdmtheme/debian/copyright
@@ -0,0 +1,46 @@
+This package was debianized by Kel Modderman <kel@otaku42.de> on
+Tue, 1 Aug 2006 00:25:11 +0000.
+
+It was downloaded from http://beta.smileaf.org/projects/
+
+Upstream Authors:
+
+ Stephen Leaf <smileaf@smileaf.org>
+ Laurent Montel <montel@kde.org>
+ Oswald Buddenhagen <ossi@kde.org>
+
+Copyright:
+
+ (C) 2005-2007 Stephen Leaf <smileaf@smileaf.org>
+ (C) 2006 Oswald Buddenhagen <ossi@kde.org>
+
+License:
+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL'.
+
+The Debian packaging is (C) 2007, Kel Modderman <kel@otaku42.de> and
+is licensed under the GPL, see above.
+
+The documentations provided with tdmtheme is distributed under
+the GNU Free Documentation License (FDL). They are considered free with
+regards to the Debian Free Software Guidelines (DFSG) because they don't
+contain any unmodifiable parts (invariant sections).
+
+On Debian systems, the complete text of the GNU Free Documentation
+License can be found in `/usr/share/common-licenses/GFDL'.
+
diff --git a/ubuntu/maverick/applications/tdmtheme/debian/docs b/ubuntu/maverick/applications/tdmtheme/debian/docs
new file mode 100644
index 000000000..e845566c0
--- /dev/null
+++ b/ubuntu/maverick/applications/tdmtheme/debian/docs
@@ -0,0 +1 @@
+README
diff --git a/ubuntu/maverick/applications/tdmtheme/debian/patches/.gitignore b/ubuntu/maverick/applications/tdmtheme/debian/patches/.gitignore
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/ubuntu/maverick/applications/tdmtheme/debian/patches/.gitignore
diff --git a/ubuntu/maverick/applications/tdmtheme/debian/rules b/ubuntu/maverick/applications/tdmtheme/debian/rules
new file mode 100755
index 000000000..0eb4fad95
--- /dev/null
+++ b/ubuntu/maverick/applications/tdmtheme/debian/rules
@@ -0,0 +1,38 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/kde.mk
+include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_SCRIPT_ENV += LDFLAGS="-Wl,--as-needed"
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/kde
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap
+
+install/tdmtheme-trinity::
+ install -D -p -m644 debian/tdmtheme.lintian-overrides \
+ debian/tdmtheme-trinity/usr/share/lintian/overrides/tdmtheme-trinity
+
+get-orig-source:
+ @@dh_testdir
+ @@[ -d ../tarballs/. ]||mkdir -p ../tarballs
+ @@dpatch-get-origtargz ../tarballs
+
diff --git a/ubuntu/maverick/applications/tdmtheme/debian/source/format b/ubuntu/maverick/applications/tdmtheme/debian/source/format
new file mode 100644
index 000000000..89ae9db8f
--- /dev/null
+++ b/ubuntu/maverick/applications/tdmtheme/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/ubuntu/maverick/applications/tdmtheme/debian/source/options b/ubuntu/maverick/applications/tdmtheme/debian/source/options
new file mode 100644
index 000000000..9d7c8e036
--- /dev/null
+++ b/ubuntu/maverick/applications/tdmtheme/debian/source/options
@@ -0,0 +1,6 @@
+# Use bzip2 instead of gzip
+compression = "bzip2"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*
diff --git a/ubuntu/maverick/applications/tdmtheme/debian/tdmtheme.lintian-overrides b/ubuntu/maverick/applications/tdmtheme/debian/tdmtheme.lintian-overrides
new file mode 100644
index 000000000..88969d336
--- /dev/null
+++ b/ubuntu/maverick/applications/tdmtheme/debian/tdmtheme.lintian-overrides
@@ -0,0 +1,6 @@
+# provided by tdelibs
+tdmtheme: desktop-command-not-in-package ./usr/share/applications/kde/tdmtheme.desktop kcmshell
+# kcontrol module
+tdmtheme: desktop-entry-invalid-category X-KDE-settings-system ./usr/share/applications/kde/tdmtheme.desktop
+tdmtheme: desktop-entry-lacks-main-category ./usr/share/applications/kde/tdmtheme.desktop
+
diff --git a/ubuntu/maverick/applications/tdmtheme/debian/watch b/ubuntu/maverick/applications/tdmtheme/debian/watch
new file mode 100644
index 000000000..82cebbd47
--- /dev/null
+++ b/ubuntu/maverick/applications/tdmtheme/debian/watch
@@ -0,0 +1,2 @@
+version=3
+http://beta.smileaf.org/files/tdmtheme/tdmtheme-(.*)\.tar\.bz2 debian svn-upgrade