summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/tork/debian
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2019-04-03 22:56:40 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2019-04-03 22:56:40 +0900
commit11394aecd1f906fee2ebd2b90412aeba4651fbff (patch)
treebcf750380e6d9fc7dbe524e16bbe2afde25dcfa0 /ubuntu/maverick/applications/tork/debian
parentd24bd898174453b586ac90f2ef7a60165fa26fde (diff)
downloadtde-packaging-11394aecd1f906fee2ebd2b90412aeba4651fbff.tar.gz
tde-packaging-11394aecd1f906fee2ebd2b90412aeba4651fbff.zip
DEB: use _base folder for a distro instead of specific distros (squeeze
and maverick). Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'ubuntu/maverick/applications/tork/debian')
-rw-r--r--ubuntu/maverick/applications/tork/debian/cdbs/debian-qt-kde.mk115
-rw-r--r--ubuntu/maverick/applications/tork/debian/cdbs/kde.mk89
-rw-r--r--ubuntu/maverick/applications/tork/debian/cdbs/versions.pl19
-rw-r--r--ubuntu/maverick/applications/tork/debian/changelog146
-rw-r--r--ubuntu/maverick/applications/tork/debian/compat1
-rw-r--r--ubuntu/maverick/applications/tork/debian/control36
-rw-r--r--ubuntu/maverick/applications/tork/debian/copyright209
-rwxr-xr-xubuntu/maverick/applications/tork/debian/rules43
-rw-r--r--ubuntu/maverick/applications/tork/debian/source/format1
-rw-r--r--ubuntu/maverick/applications/tork/debian/source/options6
-rw-r--r--ubuntu/maverick/applications/tork/debian/tork-data-trinity.install4
-rw-r--r--ubuntu/maverick/applications/tork/debian/tork-trinity.install7
-rw-r--r--ubuntu/maverick/applications/tork/debian/tork-trinity.postinst9
-rw-r--r--ubuntu/maverick/applications/tork/debian/tork-trinity.postrm9
-rw-r--r--ubuntu/maverick/applications/tork/debian/watch2
15 files changed, 0 insertions, 696 deletions
diff --git a/ubuntu/maverick/applications/tork/debian/cdbs/debian-qt-kde.mk b/ubuntu/maverick/applications/tork/debian/cdbs/debian-qt-kde.mk
deleted file mode 100644
index 9f8f97776..000000000
--- a/ubuntu/maverick/applications/tork/debian/cdbs/debian-qt-kde.mk
+++ /dev/null
@@ -1,115 +0,0 @@
-ifndef _cdbs_bootstrap
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-endif
-
-ifndef _cdbs_class_debian-qt-kde
-_cdbs_class_debian-qt-kde := 1
-
-# Note: This _must_ be included before autotools.mk, or it won't work.
-common-configure-arch common-configure-indep:: debian/stamp-cvs-make
-debian/stamp-cvs-make:
- cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
- touch debian/stamp-cvs-make
-
-include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
-
-ifndef _cdbs_rules_patchsys_quilt
-DEB_PATCHDIRS := debian/patches/common debian/patches
-endif
-
-DEB_KDE_ENABLE_FINAL := yes
-DEB_INSTALL_DOCS_ALL :=
-
-DEB_DH_MAKESHLIBS_ARGS_ALL := -V
-DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
-
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
- ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
- else
- cdbs_kde_enable_final =
- endif
-endif
-
-common-build-arch:: debian/stamp-man-pages
-debian/stamp-man-pages:
- if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
- for f in $$(find debian/man -name '*.sgml'); do \
- docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
- done
- for f in $$(find debian/man -name '*.man'); do \
- soelim -I debian/man $$f \
- > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
- done
- touch debian/stamp-man-pages
-
-common-binary-indep::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_INDEP_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-common-binary-arch::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_ARCH_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-clean::
- rm -rf debian/man/out
- -rmdir debian/man
- rm -f debian/stamp-man-pages
- rm -rf debian/shlibs-check
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
- if test -e debian/$(cdbs_curpkg).lintian; then \
- install -p -D -m644 debian/$(cdbs_curpkg).lintian \
- debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
- fi
- if test -e debian/$(cdbs_curpkg).presubj; then \
- install -p -D -m644 debian/$(cdbs_curpkg).presubj \
- debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
- fi
-
-binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
- set -e; \
- for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
- pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
- echo Building $$pkg HTML docs...; \
- mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
- done
- for pkg in $(DOC_HTML_PRUNE) ; do \
- rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- done
-
-clean::
- if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
- cd $(DEB_SRCDIR); \
- find . -name Makefile.in -print | \
- xargs --no-run-if-empty rm -f; \
- rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
- configure configure.files configure.in stamp-h.in \
- subdirs; \
- fi
- rm -f debian/stamp-cvs-make
-
-endif
diff --git a/ubuntu/maverick/applications/tork/debian/cdbs/kde.mk b/ubuntu/maverick/applications/tork/debian/cdbs/kde.mk
deleted file mode 100644
index 1ac26c4b7..000000000
--- a/ubuntu/maverick/applications/tork/debian/cdbs/kde.mk
+++ /dev/null
@@ -1,89 +0,0 @@
-# -*- mode: makefile; coding: utf-8 -*-
-# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
-# Description: A class for KDE packages; sets KDE environment variables, etc
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-# 02111-1307 USA.
-
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-
-ifndef _cdbs_class_kde
-_cdbs_class_kde := 1
-
-# for dh_icons
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
-
-include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
-
-ifdef _cdbs_tarball_dir
-DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
-else
-DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
-endif
-
-include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
-
-export kde_cgidir = \$${libdir}/cgi-bin
-export kde_confdir = \$${sysconfdir}/trinity
-export kde_htmldir = \$${datadir}/doc/tde/HTML
-
-ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
-endif
-
-ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final =
- cdbs_kde_enable_debug = --enable-debug=yes
-else
- cdbs_kde_enable_debug = --disable-debug
-endif
-
-ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_debug = --enable-debug=full
-endif
-
-cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/tde"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
-
-cleanbuilddir::
- -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
-
-common-build-arch common-build-indep:: debian/stamp-kde-apidox
-debian/stamp-kde-apidox:
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
- touch $@
-
-common-install-arch common-install-indep:: common-install-kde-apidox
-common-install-kde-apidox::
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
-
-clean::
- rm -f debian/stamp-kde-apidox
-
-# This is a convenience target for calling manually. It's not part of
-# the build process.
-buildprep: clean apply-patches
- $(MAKE) -f admin/Makefile.common dist
- debian/rules clean
-
-endif
diff --git a/ubuntu/maverick/applications/tork/debian/cdbs/versions.pl b/ubuntu/maverick/applications/tork/debian/cdbs/versions.pl
deleted file mode 100644
index 1b110f7af..000000000
--- a/ubuntu/maverick/applications/tork/debian/cdbs/versions.pl
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/env perl
-
-use strict;
-use warnings;
-
-my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
-my ($version3, $version3_next);
-my ($version2, $version2_next);
-
-($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
-($version2 = $version3) =~ s/\.[^.]+$//;
-
-($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
-($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
-
-print "TDE-Version3=$version3\n";
-print "TDE-Version2=$version2\n";
-print "TDE-Next-Version3=$version3_next\n";
-print "TDE-Next-Version2=$version2_next\n";
diff --git a/ubuntu/maverick/applications/tork/debian/changelog b/ubuntu/maverick/applications/tork/debian/changelog
deleted file mode 100644
index 3b95e00b3..000000000
--- a/ubuntu/maverick/applications/tork/debian/changelog
+++ /dev/null
@@ -1,146 +0,0 @@
-tork-trinity (0.33-1) unstable; urgency=low
-
- * Initial Release for TDE
-
- -- Slávek Banko <slavek.banko@axis.cz> Sat, 27 Jul 2013 17:16:15 +0200
-
-tork (0.33-1) unstable; urgency=low
-
- * New upstream release.
- * Bump Standards-Version to 3.9.1 (no changes needed).
-
- -- Patrick Matthäi <pmatthaei@debian.org> Sun, 15 Aug 2010 11:44:13 +0200
-
-tork (0.32~pre1-1) unstable; urgency=medium
-
- * New upstream pre-release.
- - Detect GnuTLS about pkg-config now, also adding pkg-config as build
- dependency.
- Closes: #529908
- - Adjust debian/tork.install.
- * Fix typo in get-orig-source target.
- * Merge 0.31-1~bpo50+1 changelog.
- * Bump Standards-Version to 3.8.3 (no changes needed).
- * Wrap build dependency line.
- * Depend and Build-Depend on torsocks, also build tork with the external
- torsocks option. This fixes a FTBFS with the current autofoo scripts.
- * Convert package to 3.0 (quilt).
- * Remove tsocks from depends, we are using now torsocks.
-
- -- Patrick Matthäi <pmatthaei@debian.org> Fri, 20 Nov 2009 08:16:58 +0100
-
-tork (0.31-2) unstable; urgency=low
-
- * Bump Standards-Version to 3.8.1 (no changes needed).
- * Change my email address.
- * Remove DM-Upload-Allowed control field.
- * Add upstreams changelog to the packages.
- * Refer in debian/copyright to the GPL-2 file instead of GPL.
- This fixes the lintian warning copyright-refers-to-symlink-license.
-
- -- Patrick Matthäi <pmatthaei@debian.org> Thu, 23 Apr 2009 13:42:39 +0200
-
-tork (0.31-1~bpo50+1) lenny-backports; urgency=low
-
- * Rebuild for lenny-backports.
-
- -- Patrick Matthäi <patrick.matthaei@web.de> Tue, 17 Feb 2009 18:28:26 +0200
-
-tork (0.31-1) unstable; urgency=low
-
- * New upstream release.
- * Add get-orig-source target.
- * Fix copyright-with-old-dh-make-debian-copyright.
- * Fix binary-control-field-duplicates-source.
- * Add my own Debian packaging copyright.
-
- -- Patrick Matthäi <patrick.matthaei@web.de> Wed, 4 Feb 2009 12:42:02 +0200
-
-tork (0.30-2) unstable; urgency=low
-
- * Removed icedove-torbutton from the suggests, it has been removed from the
- archive.
- * Add missing ${misc:Depends}. Thanks lintian.
-
- -- Patrick Matthäi <patrick.matthaei@web.de> Wed, 24 Dec 2008 11:20:45 +0200
-
-tork (0.30-1) unstable; urgency=low
-
- * New upstream release.
- Closes: #502155
-
- -- Patrick Matthäi <patrick.matthaei@web.de> Wed, 22 Oct 2008 20:18:57 +0200
-
-tork (0.29.2-2) unstable; urgency=low
-
- * Uploading to unstable.
- * Set the -e flag in the maintainer scripts.
- Thanks lintian.
-
- -- Patrick Matthäi <patrick.matthaei@web.de> Tue, 7 Oct 2008 11:08:22 +0200
-
-tork (0.29.2-1) experimental; urgency=low
-
- * New upstream release.
- Uploading to experimental because Lenny is frozen.
- * Downgrade konqueror recommending to suggesting.
-
- -- Patrick Matthäi <patrick.matthaei@web.de> Sun, 27 Jul 2008 16:00:21 +0200
-
-tork (0.29.1-2) unstable; urgency=low
-
- * Remove the indefinite article "an" from the short description.
- Closes: #490050
-
- -- Patrick Matthäi <patrick.matthaei@web.de> Thu, 17 Jul 2008 17:28:30 +0200
-
-tork (0.29.1-1) unstable; urgency=low
-
- * New upstream release.
- - Patch has been merged in upstream.
- - Drop dpatch.
- - Drop README.source.
- * Some little debian/rules modifications.
-
- -- Patrick Matthäi <patrick.matthaei@web.de> Sun, 6 Jul 2008 09:52:00 +0200
-
-tork (0.29-1) unstable; urgency=low
-
- * New upstream release.
- - Included dpatch again and add 01-gcc43-ftbfs-fix.dpatch.
- * Reorder odd dh_installdeb call and do not permit dh_makeshlibs to modify
- the maintainer scripts.
- Thanks lintian.
- * Added DM-Upload-Allowed control field.
- * Bumped Standards-Version to 3.8.0.
- - Added README.source.
-
- -- Patrick Matthäi <patrick.matthaei@web.de> Sat, 14 Jun 2008 11:18:00 +0100
-
-tork (0.28-1) unstable; urgency=low
-
- * New upstream release.
- - Removed 01-fix-gcc4.3-ftbfs.dpatch, it is merged in upstream.
- - Removed now useless dpatch.
- * Fixed grammar error in copyright.
-
- -- Patrick Matthäi <patrick.matthaei@web.de> Mon, 14 Apr 2008 15:10:22 +0100
-
-tork (0.27-2) unstable; urgency=low
-
- * Included dpatch and added 01-fix-gcc4.3-ftbfs.dpatch. There were some
- #include <cstdlib> missing for the getenv function.
- * Added icedove-torbutton and iceweasel-torbutton as Suggests for tork.
- * If the previous build failed at configure, it could happen, that the
- config.log won't be deleted. Now it will be deleted in the clean target.
- * Lowered down compatibility level from 6 to 5. The packaging is now tested
- with debhelper >= 5 versions and it also fixes an lintian warning.
-
- -- Patrick Matthäi <patrick.matthaei@web.de> Thu, 3 Apr 2008 22:08:55 +0100
-
-tork (0.27-1) unstable; urgency=low
-
- * Initial release.
- Closes: #444329
-
- -- Patrick Matthäi <patrick.matthaei@web.de> Sun, 16 Mar 2008 11:59:21 +0100
diff --git a/ubuntu/maverick/applications/tork/debian/compat b/ubuntu/maverick/applications/tork/debian/compat
deleted file mode 100644
index 7f8f011eb..000000000
--- a/ubuntu/maverick/applications/tork/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-7
diff --git a/ubuntu/maverick/applications/tork/debian/control b/ubuntu/maverick/applications/tork/debian/control
deleted file mode 100644
index de25d91d2..000000000
--- a/ubuntu/maverick/applications/tork/debian/control
+++ /dev/null
@@ -1,36 +0,0 @@
-Source: tork-trinity
-Section: tde
-Priority: optional
-Homepage: http://tork.sourceforge.net/
-Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
-Build-Depends: debhelper (>= 7.0.50~), cdbs, automake, libtool, tdelibs-trinity-dev, libgeoip-dev,
- libjpeg-dev, libpng-dev, zlib1g-dev, pkg-config, torsocks, libssl-dev
-Standards-Version: 3.9.1
-
-Package: tork-trinity
-Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, tork-data-trinity (= ${source:Version}),
- geoip-bin, torsocks
-Recommends: tor, privoxy
-Suggests: konqueror-trinity, iceweasel-torbutton
-Description: anonymity manager for TDE
- TorK is an anonymity manager for the Trinity desktop.
- Browse anonymously on Konqueror, Iceweasel or Opera.
- Send anonymous email via the MixMinion network.
- Use ssh, IRC and IM anonymously. Control and monitor
- your anonymous traffic and non-anonymous traffic on
- the Tor network.
-
-Package: tork-data-trinity
-Architecture: all
-Depends: ${misc:Depends}
-Recommends: tork-trinity
-Description: anonymity manager for TDE (data files)
- TorK is an anonymity manager for the Trinity desktop.
- Browse anonymously on Konqueror, Iceweasel or Opera.
- Send anonymous email via the MixMinion network.
- Use ssh, IRC and IM anonymously. Control and monitor
- your anonymous traffic and non-anonymous traffic on
- the Tor network.
- .
- This package contains the data files for tork-trinity.
diff --git a/ubuntu/maverick/applications/tork/debian/copyright b/ubuntu/maverick/applications/tork/debian/copyright
deleted file mode 100644
index 898d738e9..000000000
--- a/ubuntu/maverick/applications/tork/debian/copyright
+++ /dev/null
@@ -1,209 +0,0 @@
-This package was debianized by Patrick Matthäi <patrick.matthaei@web.de> on
-Sun, 16 Mar 2008 11:59:21 +0100.
-
-It was downloaded from <http://tork.sourceforge.net/>.
-
-
-The directory "src/arkollon" provides Arkollon.
-
-Upstream Author: David Sansome <me@davidsansome.com>
-
-Copyright: 2004 by David Sansome <me@davidsansome.com>
-
-License:
-
- This program is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 2 of the License, or
- (at your option) any later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program; if not, write to the Free Software
- Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.
-
-On Debian systems, the complete text of the GNU General Public License
-can be found in /usr/share/common-licenses/GPL-2 file.
-
-
-The directory "src/GeoIP-1.4.0" contains the GeoIP library.
-
-Upstream Author: T.J. Mather <tjmather@maxmind.com>
-
-Copyright: 2007 MaxMind LLC
-
-License:
-
- This program is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 2 of the License, or
- (at your option) any later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program; if not, write to the Free Software
- Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.
-
-On Debian systems, the complete text of the GNU General Public License
-can be found in /usr/share/common-licenses/GPL-2 file.
-
-
-The directory "src/tsocks" provides a wrapper library for transparent SOCKS.
-
-Upstream Author: Shaun Clowes
-
-Copyright: 2000 Shaun Clowes
-
-License:
-
- This program is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 2 of the License, or
- (at your option) any later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program; if not, write to the Free Software
- Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.
-
-On Debian systems, the complete text of the GNU General Public License
-can be found in /usr/share/common-licenses/GPL-2 file.
-
-
-The directory "src/upnp" provides a library for UPNP support.
-
-Upstream Author: Joris Guisson <joris.guisson@gmail.com>
-
-Copyright: 2005 Joris Guisson <joris.guisson@gmail.com>
-
-License:
-
- This program is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 2 of the License, or
- (at your option) any later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program; if not, write to the Free Software
- Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.
-
-On Debian systems, the complete text of the GNU General Public License
-can be found in /usr/share/common-licenses/GPL-2 file.
-
-
-The directory "src/privoxytemplates" contains templates for privoxy.
-
-Upstream Author: Jonathan Foster
-
-Copyright: 2001 the SourceForge Privoxy team. http://www.privoxy.org/
-
-License:
-
- This program is free software; you can redistribute it
- and/or modify it under the terms of the GNU General
- Public License as published by the Free Software
- Foundation; either version 2 of the License, or (at
- your option) any later version.
-
- This program is distributed in the hope that it will
- be useful, but WITHOUT ANY WARRANTY; without even the
- implied warranty of MERCHANTABILITY or FITNESS FOR A
- PARTICULAR PURPOSE. See the GNU General Public
- License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program; if not, write to the Free Software
- Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.
-
-On Debian systems, the complete text of the GNU General Public License
-can be found in /usr/share/common-licenses/GPL-2 file.
-
-
-The rest of the source has the following license.
-
-Upstream Author: Robert Hogan <robert@roberthogan.net>
-
-Copyright: 2006 - 2007 by Robert Hogan <robert@roberthogan.net>
-
-License:
-
- This program is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 2 of the License, or
- (at your option) any later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program; if not, write to the Free Software
- Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.
-
-On Debian systems, the complete text of the GNU General Public License
-can be found in /usr/share/common-licenses/GPL-2 file.
-
-
-These files in the "src" directory also have additional Copyright holders:
-
-chart.cpp, chart.h:
- Copyright © 2005 by Hugo Parente Lima
-
-crypto.cpp, crypto.h:
- Copyright (c) 2001 Matej Pfajfar
- Copyright (c) 2001-2004, Roger Dingledine
- Copyright (c) 2004-2006, Roger Dingledine, Nick Mathewson
- Copyright © 2007, Matt Edman, Justin Hipple
-
-hitwidget.cpp, hitwidget.h:
- Copyright © 2005 Novell, Inc.
-
-kerrylabel.cpp, kerrylabel.h:
- Copyright © 1998 Kurt Granroth <granroth@kde.org>
- Copyright © 2000 Peter Putzer <putzer@kde.org>
- Copyright © 2005 Jaroslaw Staniek <js@iidea.pl>
-
-kwidgetlistbox.cpp, kwidgetlistbox.h:
- Copyright © 2005 Petri Damsten <petri.damsten@iki.fi>
-
-likeback.cpp, likeback.h, likeback_private.h:
- Copyright © 2006 by Sebastien Laout
-
-newstreamosd.cpp, newstreamosd.h:
- Copyright © 2005 Sebastian Trueg <trueg@k3b.org>
- Copyright © 1998-2005 Sebastian Trueg <trueg@k3b.org>
-
-crashhandler.cpp, crashhandler.h, overlayWidget.cpp, overlayWidget.h,
-popupMessage.cpp, popupMessage.h:
- Copyright © 2005 by Max Howell <max.howell@methylblue.com>
-
-torclient.h:
- Copyright © 1992-2000 Trolltech AS. All rights reserved.
-
-trayhoverpopup.cpp, trayhoverpopup.h, functions.cpp, functions.h, constants.h:
- Copyright © 2005 by Joris Guisson
-
-trayicon.h:
- Copyright © 2005 by <joris.guisson@gmail.com>
- Copyright © 2005 by Ivan Vasic <ivasic@gmail.com>
-
-The Debian packaging is © 2009, Patrick Matthäi <pmatthaei@debian.org> and
-is licensed under the GPL, see above.
diff --git a/ubuntu/maverick/applications/tork/debian/rules b/ubuntu/maverick/applications/tork/debian/rules
deleted file mode 100755
index 36fed7dc5..000000000
--- a/ubuntu/maverick/applications/tork/debian/rules
+++ /dev/null
@@ -1,43 +0,0 @@
-#!/usr/bin/make -f
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include debian/cdbs/kde.mk
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
- dh_testdir
-
- # Regenerate build system
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- autoreconf --install && automake -f && \
- $(MAKE) -f admin/Makefile.common && \
- touch debian/stamp-bootstrap
-
-install/tork-trinity::
- mkdir -p debian/tmp/usr/share/menu
- sed "s|package(tork)|package(tork-trinity)|" \
- <debian/tmp/opt/trinity/share/menu/tork \
- >debian/tmp/usr/share/menu/tork-trinity
-
-clean::
- dh_testdir
- rm -f debian/stamp-bootstrap
diff --git a/ubuntu/maverick/applications/tork/debian/source/format b/ubuntu/maverick/applications/tork/debian/source/format
deleted file mode 100644
index 163aaf8d8..000000000
--- a/ubuntu/maverick/applications/tork/debian/source/format
+++ /dev/null
@@ -1 +0,0 @@
-3.0 (quilt)
diff --git a/ubuntu/maverick/applications/tork/debian/source/options b/ubuntu/maverick/applications/tork/debian/source/options
deleted file mode 100644
index 72f1f5450..000000000
--- a/ubuntu/maverick/applications/tork/debian/source/options
+++ /dev/null
@@ -1,6 +0,0 @@
-# Use xz instead of gzip
-compression = "xz"
-compression-level = 9
-
-# Don't run differences
-diff-ignore = .*
diff --git a/ubuntu/maverick/applications/tork/debian/tork-data-trinity.install b/ubuntu/maverick/applications/tork/debian/tork-data-trinity.install
deleted file mode 100644
index cde21cb0e..000000000
--- a/ubuntu/maverick/applications/tork/debian/tork-data-trinity.install
+++ /dev/null
@@ -1,4 +0,0 @@
-debian/tmp/opt/trinity/share/apps/tork/*
-debian/tmp/opt/trinity/share/doc/*
-debian/tmp/opt/trinity/share/locale/*
-debian/tmp/opt/trinity/share/config.kcfg/*
diff --git a/ubuntu/maverick/applications/tork/debian/tork-trinity.install b/ubuntu/maverick/applications/tork/debian/tork-trinity.install
deleted file mode 100644
index ff343137a..000000000
--- a/ubuntu/maverick/applications/tork/debian/tork-trinity.install
+++ /dev/null
@@ -1,7 +0,0 @@
-debian/tmp/opt/trinity/bin/*
-debian/tmp/usr/share/menu/tork-trinity
-debian/tmp/opt/trinity/share/pixmaps/tork.xpm
-debian/tmp/opt/trinity/share/man/*
-debian/tmp/opt/trinity/share/apps/tork/icons/hicolor/48x48/apps/tork.png opt/trinity/share/icons/hicolor/48x48/apps
-debian/tmp/opt/trinity/share/applications/*
-debian/tmp/opt/trinity/share/apps/konqueror/*
diff --git a/ubuntu/maverick/applications/tork/debian/tork-trinity.postinst b/ubuntu/maverick/applications/tork/debian/tork-trinity.postinst
deleted file mode 100644
index f2b7c5c96..000000000
--- a/ubuntu/maverick/applications/tork/debian/tork-trinity.postinst
+++ /dev/null
@@ -1,9 +0,0 @@
-#! /bin/sh
-
-set -e
-
-if [ -x /usr/bin/update-menus ] ; then update-menus ; fi
-
-#DEBHELPER#
-
-exit 0
diff --git a/ubuntu/maverick/applications/tork/debian/tork-trinity.postrm b/ubuntu/maverick/applications/tork/debian/tork-trinity.postrm
deleted file mode 100644
index f2b7c5c96..000000000
--- a/ubuntu/maverick/applications/tork/debian/tork-trinity.postrm
+++ /dev/null
@@ -1,9 +0,0 @@
-#! /bin/sh
-
-set -e
-
-if [ -x /usr/bin/update-menus ] ; then update-menus ; fi
-
-#DEBHELPER#
-
-exit 0
diff --git a/ubuntu/maverick/applications/tork/debian/watch b/ubuntu/maverick/applications/tork/debian/watch
deleted file mode 100644
index 94d0d842f..000000000
--- a/ubuntu/maverick/applications/tork/debian/watch
+++ /dev/null
@@ -1,2 +0,0 @@
-version=3
-http://sf.net/tork/tork-(.*)\.tar\.gz