summaryrefslogtreecommitdiffstats
path: root/ubuntu/precise/applications/k3b-i18n/debian/rules
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-09-10 16:16:32 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-09-10 16:16:32 -0500
commit02dc85a95b228b7242b0d11ea35619faad96db03 (patch)
treee161ba877a0720bbdf7818bdec06eb239d8ad271 /ubuntu/precise/applications/k3b-i18n/debian/rules
parent6f2c7dc70e77d2f768d687838b6cc9f7632f609e (diff)
downloadtde-packaging-02dc85a95b228b7242b0d11ea35619faad96db03.tar.gz
tde-packaging-02dc85a95b228b7242b0d11ea35619faad96db03.zip
Split precise from maverick
Diffstat (limited to 'ubuntu/precise/applications/k3b-i18n/debian/rules')
-rwxr-xr-xubuntu/precise/applications/k3b-i18n/debian/rules111
1 files changed, 111 insertions, 0 deletions
diff --git a/ubuntu/precise/applications/k3b-i18n/debian/rules b/ubuntu/precise/applications/k3b-i18n/debian/rules
new file mode 100755
index 000000000..2048362b9
--- /dev/null
+++ b/ubuntu/precise/applications/k3b-i18n/debian/rules
@@ -0,0 +1,111 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+ INSTALL_PROGRAM += -s
+endif
+
+config.status: configure
+ dh_testdir
+
+configure:
+ dh_testdir
+
+ # Regenerate build system
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap
+
+ # Add here commands to configure the package.
+ ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
+ --prefix=$(DEB_CONFIGURE_PREFIX) \
+ --mandir=$(DEB_CONFIGURE_MANDIR) \
+ --infodir=$(DEB_CONFIGURE_INFODIR)
+
+
+build: build-stamp
+
+build-stamp: config.status
+ dh_testdir
+
+ # Add here commands to compile the package.
+ $(MAKE)
+ #/usr/bin/docbook-to-man debian/k3b-i18n.sgml > k3b-i18n.1
+
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp
+
+ # Add here commands to clean up after the build process.
+ [ ! -f Makefile ] || $(MAKE) distclean
+ifneq "$(wildcard /usr/share/misc/config.sub)" ""
+ cp -f /usr/share/misc/config.sub config.sub
+endif
+ifneq "$(wildcard /usr/share/misc/config.guess)" ""
+ cp -f /usr/share/misc/config.guess config.guess
+endif
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/k3b-i18n-trinity.
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/k3b-i18n-trinity
+ mkdir -p $(CURDIR)/debian/k3b-i18n-trinity$(DEB_CONFIGURE_PREFIX)/share/doc/tde/
+
+# Build architecture-independent files here.
+binary-indep: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb -- -Z bzip2
+
+# Build architecture-dependent files here.
+binary-arch: build install
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install