summaryrefslogtreecommitdiffstats
path: root/ubuntu/precise/applications/kerry/debian/rules
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-09-10 16:16:32 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-09-10 16:16:32 -0500
commit02dc85a95b228b7242b0d11ea35619faad96db03 (patch)
treee161ba877a0720bbdf7818bdec06eb239d8ad271 /ubuntu/precise/applications/kerry/debian/rules
parent6f2c7dc70e77d2f768d687838b6cc9f7632f609e (diff)
downloadtde-packaging-02dc85a95b228b7242b0d11ea35619faad96db03.tar.gz
tde-packaging-02dc85a95b228b7242b0d11ea35619faad96db03.zip
Split precise from maverick
Diffstat (limited to 'ubuntu/precise/applications/kerry/debian/rules')
-rwxr-xr-xubuntu/precise/applications/kerry/debian/rules32
1 files changed, 32 insertions, 0 deletions
diff --git a/ubuntu/precise/applications/kerry/debian/rules b/ubuntu/precise/applications/kerry/debian/rules
new file mode 100755
index 000000000..7dc0fbe23
--- /dev/null
+++ b/ubuntu/precise/applications/kerry/debian/rules
@@ -0,0 +1,32 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+# include /usr/share/cdbs/1/class/kde.mk
+include debian/cdbs/debian-qt-kde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
+
+DEB_INSTALL_MANPAGES_kerry-trinity = kerry.1
+
+build/kerry-trinity::
+ docbook2x-man debian/kerry.1.docbook
+
+clean::
+ rm -f kerry.1
+
+binary-post-install/kerry-trinity::
+ chrpath -d debian/kerry-trinity/opt/trinity/lib/libtdeinit_kerry.so
+ chrpath -d debian/kerry-trinity/opt/trinity/bin/kerry
+ chrpath -d debian/kerry-trinity/opt/trinity/lib/trinity/kerry.so
+ chrpath -d debian/kerry-trinity/opt/trinity/lib/trinity/kcm_beagle.so
+ mkdir -p debian/kerry-trinity/opt/trinity/share/man/man1/
+ mv debian/kerry-trinity/usr/share/man/man1/kerry.1 debian/kerry-trinity/opt/trinity/share/man/man1/kerry.1
+ rm -rf debian/kerry-trinity/usr/share/man