summaryrefslogtreecommitdiffstats
path: root/ubuntu/precise/tdevelop/debian
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2012-11-17 16:14:08 +0100
committerSlávek Banko <slavek.banko@axis.cz>2012-11-17 16:14:08 +0100
commite1f624286dd31967e17a2bcdc0236de72659c23b (patch)
treee80eb7bead9e64b930d676872b88c887d7c6a521 /ubuntu/precise/tdevelop/debian
parent7c5d232eb26d4a925503f551a46965de870eefe7 (diff)
downloadtde-packaging-e1f624286dd31967e17a2bcdc0236de72659c23b.tar.gz
tde-packaging-e1f624286dd31967e17a2bcdc0236de72659c23b.zip
Fix tdevelop build issues on Debian and Ubuntu
Cdbs files modified to support both automake and cmake Removed unnecessary files installed into doc Include files moved to default location
Diffstat (limited to 'ubuntu/precise/tdevelop/debian')
-rw-r--r--ubuntu/precise/tdevelop/debian/cdbs/debian-qt-kde.mk8
-rw-r--r--ubuntu/precise/tdevelop/debian/cdbs/kde.mk4
-rwxr-xr-xubuntu/precise/tdevelop/debian/rules2
-rw-r--r--ubuntu/precise/tdevelop/debian/tdevelop-trinity-dev.install2
-rw-r--r--ubuntu/precise/tdevelop/debian/tdevelop-trinity-doc.install2
5 files changed, 12 insertions, 6 deletions
diff --git a/ubuntu/precise/tdevelop/debian/cdbs/debian-qt-kde.mk b/ubuntu/precise/tdevelop/debian/cdbs/debian-qt-kde.mk
index d135c4257..f8b76cb04 100644
--- a/ubuntu/precise/tdevelop/debian/cdbs/debian-qt-kde.mk
+++ b/ubuntu/precise/tdevelop/debian/cdbs/debian-qt-kde.mk
@@ -10,9 +10,11 @@ _cdbs_class_debian-qt-kde := 1
# Note: This _must_ be included before autotools.mk, or it won't work.
common-configure-arch common-configure-indep:: debian/stamp-cvs-make
debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
$(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
touch debian/stamp-cvs-make
include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
@@ -75,11 +77,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
if test -e debian/$(cdbs_curpkg).lintian; then \
install -p -D -m644 debian/$(cdbs_curpkg).lintian \
- debian/$(cdbs_curpkg)/opt/trinity/share/lintian/overrides/$(cdbs_curpkg); \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
fi
if test -e debian/$(cdbs_curpkg).presubj; then \
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
- debian/$(cdbs_curpkg)/opt/trinity/share/bug/$(cdbs_curpkg)/presubj; \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
@@ -96,6 +98,7 @@ binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
done
clean::
+ifndef _cdbs_class_cmake
if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
cd $(DEB_SRCDIR); \
find . -name Makefile.in -print | \
@@ -104,6 +107,7 @@ clean::
configure configure.files configure.in stamp-h.in \
subdirs; \
fi
+endif
rm -f debian/stamp-cvs-make
endif
diff --git a/ubuntu/precise/tdevelop/debian/cdbs/kde.mk b/ubuntu/precise/tdevelop/debian/cdbs/kde.mk
index 765560c89..023886fc8 100644
--- a/ubuntu/precise/tdevelop/debian/cdbs/kde.mk
+++ b/ubuntu/precise/tdevelop/debian/cdbs/kde.mk
@@ -35,7 +35,9 @@ else
DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
endif
+ifndef _cdbs_class_cmake
include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
export kde_cgidir = \$${libdir}/cgi-bin
export kde_confdir = \$${sysconfdir}/trinity
@@ -59,7 +61,7 @@ endif
cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/tde"
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
diff --git a/ubuntu/precise/tdevelop/debian/rules b/ubuntu/precise/tdevelop/debian/rules
index 6bb4ec733..74b304533 100755
--- a/ubuntu/precise/tdevelop/debian/rules
+++ b/ubuntu/precise/tdevelop/debian/rules
@@ -9,7 +9,7 @@ include debian/cdbs/debian-qt-kde.mk
include /usr/share/cdbs/1/rules/simple-patchsys.mk
include /usr/share/cdbs/1/rules/utils.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
DEB_CONFIGURE_PREFIX := /opt/trinity
DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
diff --git a/ubuntu/precise/tdevelop/debian/tdevelop-trinity-dev.install b/ubuntu/precise/tdevelop/debian/tdevelop-trinity-dev.install
index f9f8c82ab..a8813a5e2 100644
--- a/ubuntu/precise/tdevelop/debian/tdevelop-trinity-dev.install
+++ b/ubuntu/precise/tdevelop/debian/tdevelop-trinity-dev.install
@@ -1,3 +1,3 @@
-debian/tmp/opt/trinity/include/tde
+debian/tmp/opt/trinity/include
debian/tmp/opt/trinity/lib/lib*.so
debian/tmp/opt/trinity/lib/lib*.la
diff --git a/ubuntu/precise/tdevelop/debian/tdevelop-trinity-doc.install b/ubuntu/precise/tdevelop/debian/tdevelop-trinity-doc.install
index 765acf0e0..2e687a858 100644
--- a/ubuntu/precise/tdevelop/debian/tdevelop-trinity-doc.install
+++ b/ubuntu/precise/tdevelop/debian/tdevelop-trinity-doc.install
@@ -1,5 +1,5 @@
debian/tmp/opt/trinity/share/doc/tde/HTML/en/tdevelop
-debian/tmp/opt/trinity/share/doc/tde/HTML/en/tdevelop-apidocs/common
+#debian/tmp/opt/trinity/share/doc/tde/HTML/en/tdevelop-apidocs/common
debian/tmp/opt/trinity/share/doc/tde/HTML/en/kde_app_devel/appwizard.png
debian/tmp/opt/trinity/share/doc/tde/HTML/en/kde_app_devel/index.docbook
debian/tmp/opt/trinity/share/doc/tde/HTML/en/kde_app_devel/kscribblefiles.png