summaryrefslogtreecommitdiffstats
path: root/arch/tde-core/tde-tdelibs/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'arch/tde-core/tde-tdelibs/PKGBUILD')
-rw-r--r--arch/tde-core/tde-tdelibs/PKGBUILD22
1 files changed, 15 insertions, 7 deletions
diff --git a/arch/tde-core/tde-tdelibs/PKGBUILD b/arch/tde-core/tde-tdelibs/PKGBUILD
index bdb3d5e00..c8f67d616 100644
--- a/arch/tde-core/tde-tdelibs/PKGBUILD
+++ b/arch/tde-core/tde-tdelibs/PKGBUILD
@@ -8,14 +8,16 @@ _cat=core/
_kdemod="${_mod/tde/kde}"
pkgname="tde-${_mod}"
-pkgver=14.0.12
+pkgver=14.1.1
pkgrel=1
pkgdesc="Trinity Desktop core libraries and applications"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'powerpc64le')
url="https://scm.trinitydesktop.org/scm/git/${_mod}"
license=('GPL')
groups=('tde-core')
-depends=('aspell'
+depends=(
+ 'aspell'
+ 'cryptsetup'
'hspell'
'jasper'
'libcups'
@@ -24,9 +26,11 @@ depends=('aspell'
'libxcomposite'
'libxslt'
'libxtst'
- 'openssl-1.0'
+ 'openssl'
'openexr'
+ 'opensc'
'pcre'
+ 'pkcs11-helper'
'tde-arts'
'tde-avahi-tqt'
'tde-dbus-1-tqt'
@@ -35,14 +39,15 @@ depends=('aspell'
'xorg-xmessage'
'xorg-xprop'
'xorg-xset'
- 'xorg-xsetroot')
+ 'xorg-xsetroot'
+)
makedepends=('tde-cmake-trinity')
provides=("${_mod}")
conflicts=("trinity-${_kdemod}" "trinity-${_mod}" "kdemod3-${_kdemod}" "${_kdemod}3")
replaces=("trinity-${_kdemod}" "trinity-${_mod}")
options=('staticlibs' 'libtool' '!makeflags' '!strip')
source=("https://mirror.ppa.trinitydesktop.org/trinity/releases/R${pkgver}/main/${_cat}${_mod}-trinity-${pkgver}.tar.xz")
-md5sums=('51ee6897dd364a3d6f42d633fcf53efc')
+md5sums=('c0191df81fc351a8a55e7a503cccabe6')
install="trinity-${_mod}.install"
@@ -73,12 +78,15 @@ build() {
-DWITH_OPENEXR=ON \
-DWITH_UTEMPTER=ON \
-DWITH_AVAHI=ON \
- -DWITH_PAM=ON \
-DWITH_PCRE=ON \
-DWITH_GCC_VISIBILITY=ON \
-DWITH_TDEHWLIB_DAEMONS=ON \
-DWITH_UPOWER=ON \
-DWITH_UDISKS2=ON \
+ -DWITH_UDEVIL=ON \
+ -DWITH_PCSC=ON \
+ -DWITH_PKCS=ON \
+ -DWITH_CRYPTSETUP=ON \
-DWITH_NETWORK_MANAGER_BACKEND=ON \
-DWITH_LZMA=ON \
-DWITH_XRANDR=ON \