summaryrefslogtreecommitdiffstats
path: root/arch/tde-core/tde-tqca/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'arch/tde-core/tde-tqca/PKGBUILD')
-rw-r--r--arch/tde-core/tde-tqca/PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/arch/tde-core/tde-tqca/PKGBUILD b/arch/tde-core/tde-tqca/PKGBUILD
index 4c04b7be4..54e442603 100644
--- a/arch/tde-core/tde-tqca/PKGBUILD
+++ b/arch/tde-core/tde-tqca/PKGBUILD
@@ -9,36 +9,36 @@ _cat=dependencies/
_kdemod="${_mod/tde/kde}"
pkgname="tde-${_mod}"
-pkgver=14.0.12
+pkgver=14.1.1
pkgrel=1
pkgdesc="Trinity SSL/TLS interface for TQt Cryptographic Architecture (TQCA)"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'powerpc64le')
url="https://scm.trinitydesktop.org/scm/git/${_mod}"
license=('GPL')
groups=('tde-core')
-depends=('tde-tqtinterface' 'openssl-1.0')
+depends=('tde-tqtinterface' 'openssl')
makedepends=('tde-cmake-trinity')
provides=(${_mod})
conflicts=("trinity-${_mod}")
replaces=("trinity-${_mod}")
options=('staticlibs' 'libtool' '!strip')
source=("https://mirror.ppa.trinitydesktop.org/trinity/releases/R${pkgver}/main/${_cat}${_mod}-trinity-${pkgver}.tar.xz")
-md5sums=('0ded8a6923a3d77459daf2f8f207905c')
+md5sums=('67b1edf8826cf97c281ab70cec5e9b7c')
[ -n "$TDEDIR" ] || TDEDIR=/opt/trinity
-[ -n "$QTDIR" ] || QTDIR=${TDEDIR}/tqt3
+[ -n "$TQTDIR" ] || TQTDIR=${TDEDIR}/tqt3
build() {
msg "Creating out-of-source build directory: ${srcdir}/build"
mkdir -p ${srcdir}/build
cd ${srcdir}/build
- export PKG_CONFIG_PATH=${QTDIR}/lib/pkgconfig:${PKG_CONFIG_PATH}
+ export PKG_CONFIG_PATH=${TQTDIR}/lib/pkgconfig:${PKG_CONFIG_PATH}
msg "Starting cmake..."
cmake ${srcdir}/${pkgname#*-}-trinity-${pkgver}/ \
-GNinja \
- -DCMAKE_INSTALL_PREFIX=$QTDIR \
+ -DCMAKE_INSTALL_PREFIX=$TQTDIR \
-DBUILD_ALL=OFF \
-DBUILD_TQCA=ON \
-DWITH_ALL_OPTIONS=ON